............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Especificar nombre hallado en frase dada una lista

Ver el tema anterior Ver el tema siguiente Ir abajo

Especificar nombre hallado en frase dada una lista

Mensaje por GalileoGali el Vie Abr 25, 2008 7:59 pm

Identificar Nombres de una lista en frase y devolver el nombre incluido:
Hoja1

 ABCDEF
1Claudio1 Andrés cocinaba pasteles3Andrés
2Alex2 Claudio subio una escalera1Claudio
3Andrés3 Mientras Alex la sostenía2Alex
4Roque4 Que luego Roque comería4Roque
Spreadsheet Formulas
CellFormula
E1{=SUMA(((LARGO(D1)-LARGO(SUSTITUIR(D1;TRANSPONER($A$1:$A$4);"")))>0)*TRANSPONER($B$1:$B$4))}
F1=INDICE($A$1:$A$4;E1)
E2{=SUMA(((LARGO(D2)-LARGO(SUSTITUIR(D2;TRANSPONER($A$1:$A$4);"")))>0)*TRANSPONER($B$1:$B$4))}
F2=INDICE($A$1:$A$4;E2)
E3{=SUMA(((LARGO(D3)-LARGO(SUSTITUIR(D3;TRANSPONER($A$1:$A$4);"")))>0)*TRANSPONER($B$1:$B$4))}
F3=INDICE($A$1:$A$4;E3)
E4{=SUMA(((LARGO(D4)-LARGO(SUSTITUIR(D4;TRANSPONER($A$1:$A$4);"")))>0)*TRANSPONER($B$1:$B$4))}
F4=INDICE($A$1:$A$4;E4)
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

En A:A esta la lista de Nombres a rastrear, en B códigos, que podrian susituirse en la formula por la funcion Fila, luego las Frases donde buscar los Nombres, devolucion del codigo en la otra columna y finalmente dar el nombre correspondiente.

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Especificar nombre hallado en frase dada una lista

Mensaje por GalileoGali el Vie Abr 25, 2008 9:07 pm

Otra version

Hoja1

 ABCD
1Claudio Andrés jugaba ajedrezAndrés
2Pedro Las piezas de cedro eran de PedroPedro
3Roque Roque propuso, comedido, un enroqueRoque
4Andrés Mientras Andrés observaba a los tresAndrés
5  Clamaban por un descanso#N/A
6  Evitando que Pedro pensaraPedro
7  Hasta que Claudio, espetó un jaque Claudio
8  y a Roque le dio el ataqueRoque
Spreadsheet Formulas
CellFormula
D1{=INDICE($A$1:$A$4;SI(MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C1)))*TRANSPONER(FILA($A$1:$A$4)))=0;NOD();MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C1)))*TRANSPONER(FILA($A$1:$A$4)))))}
D2{=INDICE($A$1:$A$4;SI(MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C2)))*TRANSPONER(FILA($A$1:$A$4)))=0;NOD();MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C2)))*TRANSPONER(FILA($A$1:$A$4)))))}
D3{=INDICE($A$1:$A$4;SI(MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C3)))*TRANSPONER(FILA($A$1:$A$4)))=0;NOD();MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C3)))*TRANSPONER(FILA($A$1:$A$4)))))}
D4{=INDICE($A$1:$A$4;SI(MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C4)))*TRANSPONER(FILA($A$1:$A$4)))=0;NOD();MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C4)))*TRANSPONER(FILA($A$1:$A$4)))))}
D5{=INDICE($A$1:$A$4;SI(MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C5)))*TRANSPONER(FILA($A$1:$A$4)))=0;NOD();MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C5)))*TRANSPONER(FILA($A$1:$A$4)))))}
D6{=INDICE($A$1:$A$4;SI(MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C6)))*TRANSPONER(FILA($A$1:$A$4)))=0;NOD();MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C6)))*TRANSPONER(FILA($A$1:$A$4)))))}
D7{=INDICE($A$1:$A$4;SI(MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C7)))*TRANSPONER(FILA($A$1:$A$4)))=0;NOD();MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C7)))*TRANSPONER(FILA($A$1:$A$4)))))}
D8{=INDICE($A$1:$A$4;SI(MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C8)))*TRANSPONER(FILA($A$1:$A$4)))=0;NOD();MAX(NO(ESERROR(HALLAR(TRANSPONER($A$1:$A$4);C8)))*TRANSPONER(FILA($A$1:$A$4)))))}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Especificar nombre hallado en frase dada una lista

Mensaje por Joaquin.dehoyos el Lun Feb 08, 2016 12:18 pm

Me urge esta formula, pero no la puedo hacer funcionar en mi excel, tengo la versión 2010.

Saludos

Joaquin.dehoyos

Masculino Cantidad de envíos : 1
Edad : 29
Ciudad - Pais : Monterrey, México
Version de Excel : 2010
Fecha de inscripción : 08/02/2016

Volver arriba Ir abajo

Re: Especificar nombre hallado en frase dada una lista

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.