............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

filas a columnas(aporte)

Ver el tema anterior Ver el tema siguiente Ir abajo

filas a columnas(aporte)

Mensaje por moises melgar el Miér Nov 17, 2010 3:57 pm

hola muchas personas que conosco me han preguntado como hacer referencias a datos que estan contenidos en filas pasarlos a columnas usando formulas, para que al colocar la formula solo lo arrastren hacia abajo usando Ctr + J o usando el "raton"

Ok aqui les dejo una forma sencilla de como hacerlo

bye


moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 512
Edad : 28
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: filas a columnas(aporte)

Mensaje por Tatayayan el Miér Nov 17, 2010 5:12 pm

Hola, otra forma,s egún el archivo de moises:
=INDICE(Hoja1!$B$8:$G$19;COINCIDIR(Hoja2!B$7;Hoja1!$A$8:$A$19;0);COINCIDIR(Hoja2!A8;Hoja1!$B$7:$G$7;0))
o también:
=INDICE(Hoja1!$B$8:$G$19;MES("1/"&Hoja2!B7);Hoja2!A8)

Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: filas a columnas(aporte)

Mensaje por Tatayayan el Miér Nov 17, 2010 5:21 pm

=INDICE(sdf!$B$8:$G$19;MES("1/"&Hoja2!B$7);Hoja2!A8)
Correción

Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: filas a columnas(aporte)

Mensaje por GalileoGali el Miér Nov 17, 2010 5:53 pm

Otra
Hoja1

 ABCD
7 123
8EneroEnero1Enero2Enero3
9FebreroFebrero1Febrero2Febrero3
10MarzoMarzo1Marzo2Marzo3


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]



Hoja1

 IJKL
7 EneroFebreroMarzo
81Enero1Febrero1Marzo1
92Enero2Febrero2Marzo2
103Enero3Febrero3Marzo3
Spreadsheet Formulas
CellFormula
I7=SI(INDICE($A$7:$G$19;COLUMNA(A1);FILA(A1))="";"";INDICE($A$7:$G$19;COLUMNA(A1);FILA(A1)))
J7=SI(INDICE($A$7:$G$19;COLUMNA(B1);FILA(B1))="";"";INDICE($A$7:$G$19;COLUMNA(B1);FILA(B1)))
K7=SI(INDICE($A$7:$G$19;COLUMNA(C1);FILA(C1))="";"";INDICE($A$7:$G$19;COLUMNA(C1);FILA(C1)))
L7=SI(INDICE($A$7:$G$19;COLUMNA(D1);FILA(D1))="";"";INDICE($A$7:$G$19;COLUMNA(D1);FILA(D1)))
I8=SI(INDICE($A$7:$G$19;COLUMNA(A2);FILA(A2))="";"";INDICE($A$7:$G$19;COLUMNA(A2);FILA(A2)))
J8=SI(INDICE($A$7:$G$19;COLUMNA(B2);FILA(B2))="";"";INDICE($A$7:$G$19;COLUMNA(B2);FILA(B2)))
K8=SI(INDICE($A$7:$G$19;COLUMNA(C2);FILA(C2))="";"";INDICE($A$7:$G$19;COLUMNA(C2);FILA(C2)))
L8=SI(INDICE($A$7:$G$19;COLUMNA(D2);FILA(D2))="";"";INDICE($A$7:$G$19;COLUMNA(D2);FILA(D2)))
I9=SI(INDICE($A$7:$G$19;COLUMNA(A3);FILA(A3))="";"";INDICE($A$7:$G$19;COLUMNA(A3);FILA(A3)))
J9=SI(INDICE($A$7:$G$19;COLUMNA(B3);FILA(B3))="";"";INDICE($A$7:$G$19;COLUMNA(B3);FILA(B3)))
K9=SI(INDICE($A$7:$G$19;COLUMNA(C3);FILA(C3))="";"";INDICE($A$7:$G$19;COLUMNA(C3);FILA(C3)))
L9=SI(INDICE($A$7:$G$19;COLUMNA(D3);FILA(D3))="";"";INDICE($A$7:$G$19;COLUMNA(D3);FILA(D3)))
I10=SI(INDICE($A$7:$G$19;COLUMNA(A4);FILA(A4))="";"";INDICE($A$7:$G$19;COLUMNA(A4);FILA(A4)))
J10=SI(INDICE($A$7:$G$19;COLUMNA(B4);FILA(B4))="";"";INDICE($A$7:$G$19;COLUMNA(B4);FILA(B4)))
K10=SI(INDICE($A$7:$G$19;COLUMNA(C4);FILA(C4))="";"";INDICE($A$7:$G$19;COLUMNA(C4);FILA(C4)))
L10=SI(INDICE($A$7:$G$19;COLUMNA(D4);FILA(D4))="";"";INDICE($A$7:$G$19;COLUMNA(D4);FILA(D4)))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: filas a columnas(aporte)

Mensaje por Tatayayan el Miér Nov 17, 2010 7:18 pm

En la fórmula de moises, si se cambia el nombre de la hoja me parece se producirá un error.

Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: filas a columnas(aporte)

Mensaje por moises melgar el Miér Nov 17, 2010 8:55 pm

efectivamente, ya que en mi formula es super basica pero me gusto el efecto que ocaciono muchos aportaron
cuidense

moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 512
Edad : 28
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: filas a columnas(aporte)

Mensaje por Potter2K10 el Jue Nov 18, 2010 1:37 pm

Yo uso esta para pasar de filas a columnas, y se controla la distribucion desde otra celda. por ejemplo si las celdas no son continuas las que se necesitan transponer.

=INDIRECT(CONCATENATE("'Base datos'!","R",$R$1,"C",W2),FALSE)

Espero les sirva.

Saludos

Potter2K10

Masculino Cantidad de envíos : 5
Edad : 43
Ciudad - Pais : El Salvador
Version de Excel : 97-2003-2007
Fecha de inscripción : 23/12/2009

Volver arriba Ir abajo

Re: filas a columnas(aporte)

Mensaje por Tatayayan el Jue Nov 18, 2010 1:40 pm

Hola Potter2K10, si cambia de nombre la hoja creo que tb se produce un error, puede ser?

Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: filas a columnas(aporte)

Mensaje por Potter2K10 el Jue Nov 18, 2010 1:59 pm

Pero para eso puedes usar esta fromula en una celda de la hoja base de datos y hacer referencia a dicha celda.

Pone el nombre de la hoja activa en la celda a1:
=MID(CELL("filename",A1),FIND("]",CELL("filename",A1))+1,256)

Creo que serivia y no daria error al cambiar de nombre la hoja, solo tendriamos que trabajar mas la formula.

Tambien se podria usar macros de evento para esto tambien, con funciones difinidas por el usuario.

Saludos

Potter2K10

Masculino Cantidad de envíos : 5
Edad : 43
Ciudad - Pais : El Salvador
Version de Excel : 97-2003-2007
Fecha de inscripción : 23/12/2009

Volver arriba Ir abajo

Re: filas a columnas(aporte)

Mensaje por Tatayayan el Jue Nov 18, 2010 2:23 pm

Claro, pero para no utilizar celda auxiliares: =INDICE(Hoja1!$B$8:$G$19;MES("1/"&Hoja2!B$7);Hoja2!A8)
o puedes utilizar tu fórmula, creando el nombre NombreHoja con la fórmula que describes para ello.

Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: filas a columnas(aporte)

Mensaje por moises melgar el Jue Nov 18, 2010 7:55 pm

Felicidades con esto checamos que es mejor el uso de indice, esta muy buenos todos los comentarios expuestos

por Potter2K10 Hoy a las 1:59 pm
Pone el nombre de la hoja activa en la celda a1:
=MID(CELL("filename",A1),FIND("]",CELL("filename",A1))+1,256)
en español
=EXTRAE(CELDA("filename",A1),ENCONTRAR("]",CELDA("filename",A1))+1,256)
definitivamente este tema es uno de los mejores que he visto y espero que los miembros del foro lo disfruten tanto como yo lo disfrute al experimentar con las formulas de cada uno.
gracias

moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 512
Edad : 28
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: filas a columnas(aporte)

Mensaje por Contenido patrocinado Hoy a las 3:15 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.