............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

FORMULA CON RESULTADO NUMERICO, TENIEDO REFERECIA EL RELLENO DE COLOR DE UNA CELDA

Ver el tema anterior Ver el tema siguiente Ir abajo

FORMULA CON RESULTADO NUMERICO, TENIEDO REFERECIA EL RELLENO DE COLOR DE UNA CELDA

Mensaje por JUANANTO el Jue Dic 23, 2010 9:29 pm

¿Que formula puedo emplear? Para tener un resultado numerico, teniendo la condicion depositada en el color de relleno de otra celda, o del tipo de color de la fuente o de su tamaño, etc.
Ejemplo: Quiero que la celda H1, muestre 1 si la celda B1 es de color rojo y muestre 2 si tambien tiene la letra D.
He visto otros mensajes y algunas macros pero no aportan formulas y no son referentes a los colores.
Espero alguna respuesta.
Saludos

JUANANTO

Masculino Cantidad de envíos : 2
Edad : 59
Ciudad - Pais : MADRID
Version de Excel : XP-2010
Fecha de inscripción : 23/12/2010

Volver arriba Ir abajo

Re: FORMULA CON RESULTADO NUMERICO, TENIEDO REFERECIA EL RELLENO DE COLOR DE UNA CELDA

Mensaje por GalileoGali el Vie Dic 24, 2010 1:20 am

Una cosa es si los formatos provienen de Formatos condicionales o no

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: FORMULA CON RESULTADO NUMERICO, TENIEDO REFERECIA EL RELLENO DE COLOR DE UNA CELDA

Mensaje por JUANANTO el Vie Dic 24, 2010 4:46 am

Una sugerencia para los formatos condicionales y otra para los que no, en relacion al ejemplo dado.
Saludos de Juananto.

JUANANTO

Masculino Cantidad de envíos : 2
Edad : 59
Ciudad - Pais : MADRID
Version de Excel : XP-2010
Fecha de inscripción : 23/12/2010

Volver arriba Ir abajo

Re: FORMULA CON RESULTADO NUMERICO, TENIEDO REFERECIA EL RELLENO DE COLOR DE UNA CELDA

Mensaje por GalileoGali el Sáb Dic 25, 2010 9:40 am

EJEMPLO

 ABCDEFGHI
1FECHASEMANAENTRADASALIDDAFESTIVOSSABADOSDOMINGOS FESTIVOS
201-12-10X06:3410:38    01/01/2010
302-12-10J15:1922:48    08/12/2010
403-12-10V06:4914:26    25/12/2010
504-12-10S05:0008:30 1   
605-12-10D    1  
706-12-10L       
807-12-10M       
908-12-10X22:1923:311    
Spreadsheet Formulas
CellFormula
E2=SI(A2>0;SI(ESNUMERO(COINCIDIR(A2;FESTIVOS;));1;""))
F2=SI(E2=1;"";SI(Y(A2>0;DIASEM(A2;2)=6);1;""))
G2=SI(E2=1;"";SI(Y(A2>0;DIASEM(A2;2)=7);1;""))
E3=SI(A3>0;SI(ESNUMERO(COINCIDIR(A3;FESTIVOS;));1;""))
F3=SI(E3=1;"";SI(Y(A3>0;DIASEM(A3;2)=6);1;""))
G3=SI(E3=1;"";SI(Y(A3>0;DIASEM(A3;2)=7);1;""))
E4=SI(A4>0;SI(ESNUMERO(COINCIDIR(A4;FESTIVOS;));1;""))
F4=SI(E4=1;"";SI(Y(A4>0;DIASEM(A4;2)=6);1;""))
G4=SI(E4=1;"";SI(Y(A4>0;DIASEM(A4;2)=7);1;""))
E5=SI(A5>0;SI(ESNUMERO(COINCIDIR(A5;FESTIVOS;));1;""))
F5=SI(E5=1;"";SI(Y(A5>0;DIASEM(A5;2)=6);1;""))
G5=SI(E5=1;"";SI(Y(A5>0;DIASEM(A5;2)=7);1;""))
E6=SI(A6>0;SI(ESNUMERO(COINCIDIR(A6;FESTIVOS;));1;""))
F6=SI(E6=1;"";SI(Y(A6>0;DIASEM(A6;2)=6);1;""))
G6=SI(E6=1;"";SI(Y(A6>0;DIASEM(A6;2)=7);1;""))
E7=SI(A7>0;SI(ESNUMERO(COINCIDIR(A7;FESTIVOS;));1;""))
F7=SI(E7=1;"";SI(Y(A7>0;DIASEM(A7;2)=6);1;""))
G7=SI(E7=1;"";SI(Y(A7>0;DIASEM(A7;2)=7);1;""))
E8=SI(A8>0;SI(ESNUMERO(COINCIDIR(A8;FESTIVOS;));1;""))
F8=SI(E8=1;"";SI(Y(A8>0;DIASEM(A8;2)=6);1;""))
G8=SI(E8=1;"";SI(Y(A8>0;DIASEM(A8;2)=7);1;""))
E9=SI(A9>0;SI(ESNUMERO(COINCIDIR(A9;FESTIVOS;));1;""))
F9=SI(E9=1;"";SI(Y(A9>0;DIASEM(A9;2)=6);1;""))
G9=SI(E9=1;"";SI(Y(A9>0;DIASEM(A9;2)=7);1;""))
Names in Formulas
CellNameApplies to
E2FESTIVOS=EJEMPLO!$I$2:INDICE(EJEMPLO!$I:$I;COINCIDIR(9E+307;EJEMPLO!$I:$I))
E3FESTIVOS=EJEMPLO!$I$2:INDICE(EJEMPLO!$I:$I;COINCIDIR(9E+307;EJEMPLO!$I:$I))
E4FESTIVOS=EJEMPLO!$I$2:INDICE(EJEMPLO!$I:$I;COINCIDIR(9E+307;EJEMPLO!$I:$I))
E5FESTIVOS=EJEMPLO!$I$2:INDICE(EJEMPLO!$I:$I;COINCIDIR(9E+307;EJEMPLO!$I:$I))
E6FESTIVOS=EJEMPLO!$I$2:INDICE(EJEMPLO!$I:$I;COINCIDIR(9E+307;EJEMPLO!$I:$I))
E7FESTIVOS=EJEMPLO!$I$2:INDICE(EJEMPLO!$I:$I;COINCIDIR(9E+307;EJEMPLO!$I:$I))
E8FESTIVOS=EJEMPLO!$I$2:INDICE(EJEMPLO!$I:$I;COINCIDIR(9E+307;EJEMPLO!$I:$I))
E9FESTIVOS=EJEMPLO!$I$2:INDICE(EJEMPLO!$I:$I;COINCIDIR(9E+307;EJEMPLO!$I:$I))
Conditional formatting
CellNr.: / ConditionFormat
B21. / Formula is =COINCIDIR(1;$E2:$G2;)=3Abc
B22. / Formula is =COINCIDIR(1;$E2:$G2;)=2Abc
B23. / Formula is =COINCIDIR(1;$E2:$G2;)=1Abc
B31. / Formula is =COINCIDIR(1;$E2:$G2;)=3Abc
B32. / Formula is =COINCIDIR(1;$E2:$G2;)=2Abc
B33. / Formula is =COINCIDIR(1;$E2:$G2;)=1Abc
B41. / Formula is =COINCIDIR(1;$E2:$G2;)=3Abc
B42. / Formula is =COINCIDIR(1;$E2:$G2;)=2Abc
B43. / Formula is =COINCIDIR(1;$E2:$G2;)=1Abc
B51. / Formula is =COINCIDIR(1;$E2:$G2;)=3Abc
B52. / Formula is =COINCIDIR(1;$E2:$G2;)=2Abc
B53. / Formula is =COINCIDIR(1;$E2:$G2;)=1Abc
B61. / Formula is =COINCIDIR(1;$E2:$G2;)=3Abc
B62. / Formula is =COINCIDIR(1;$E2:$G2;)=2Abc
B63. / Formula is =COINCIDIR(1;$E2:$G2;)=1Abc
B71. / Formula is =COINCIDIR(1;$E2:$G2;)=3Abc
B72. / Formula is =COINCIDIR(1;$E2:$G2;)=2Abc
B73. / Formula is =COINCIDIR(1;$E2:$G2;)=1Abc
B81. / Formula is =COINCIDIR(1;$E2:$G2;)=3Abc
B82. / Formula is =COINCIDIR(1;$E2:$G2;)=2Abc
B83. / Formula is =COINCIDIR(1;$E2:$G2;)=1Abc
B91. / Formula is =COINCIDIR(1;$E2:$G2;)=3Abc
B92. / Formula is =COINCIDIR(1;$E2:$G2;)=2Abc
B93. / Formula is =COINCIDIR(1;$E2:$G2;)=1Abc


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: FORMULA CON RESULTADO NUMERICO, TENIEDO REFERECIA EL RELLENO DE COLOR DE UNA CELDA

Mensaje por Contenido patrocinado Hoy a las 11:25 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.