............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

formulas en excel

Ver el tema anterior Ver el tema siguiente Ir abajo

formulas en excel

Mensaje por Invitado el Dom Feb 20, 2011 2:21 pm

hola, tengo un cuadro de notas para una lista de alumnos
mi intencion es que al calificar a cada alumno en la celda contigua me aparezca un valor en porcentaje que va deacuerdo a una

por eje: mayor o igual a 1.0 ---> 20%
mayor o igual a 2.0 -> 40%

y asi hasta el 5.0 (100%)


trabajo con el codicional si pero no logro ver el error, pues tampoco lo marca


Invitado
Invitado


Volver arriba Ir abajo

Re: formulas en excel

Mensaje por GalileoGali el Dom Feb 20, 2011 3:56 pm

Sería interesante, ver lo que tienes hasta ahora, no hace falta que subas un archivo, diciendo
por ejemplo, en B1 tengo esto en C1 puse, esto y espero que el resultado sea

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: formulas en excel

Mensaje por Invitado el Dom Feb 20, 2011 4:03 pm

gracias, ya lo resolvi, la formula fue esta: =SI(Y(C6>=1;C6<2);"20%";SI(Y(C6>=2;C6<3);"40%";SI(Y(C6>=3;C6<4);"60%";SI(Y(C6>=4;C6<5);"80%";SI(C6=5;"100%";"")))))

PERO ahora se me presento otro inconveniente, resulta que la celda de ala lado automaticamente aparece aprobado si es mayor o igual que 60% y reprobado si es menor que 60%, ahora todos me salen aprobados, la formula que utlizo es esta: =SI(C7>=60%;"APROBADO";"REPROBO"))

Invitado
Invitado


Volver arriba Ir abajo

Re: formulas en excel

Mensaje por GalileoGali el Dom Feb 20, 2011 4:11 pm

Prueba con esto

=BUSCAR(C6;{1;2;3;4;5};{0,2;0,4;0,6;0,8;1})


En tu formula, si quieres resultados consistentes, elimna las comillas ("20%")


Última edición por GalileoGali el Dom Feb 20, 2011 7:04 pm, editado 1 vez

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: formulas en excel

Mensaje por Invitado el Dom Feb 20, 2011 4:35 pm

hola, no entiendo tu formula, ya el problema anterior lo resolvi pero la celda de al lado se altero colocando a todos aprobados, aunque tengan mala nota o esten por debajo del 60%



Invitado
Invitado


Volver arriba Ir abajo

Re: formulas en excel

Mensaje por Invitado el Dom Feb 20, 2011 4:50 pm

HOLA, TUVE que hacerlo en base ala celdas donde digito las notas, solo asi me funciono, es lo mismo pero lo queria hacer en base ala celdas donde nmarca el porcentaje.

gracias.

Invitado
Invitado


Volver arriba Ir abajo

Re: formulas en excel

Mensaje por GalileoGali el Dom Feb 20, 2011 7:07 pm

Hoja1

 CDE
63,260%APROBADO
Spreadsheet Formulas
CellFormula
D6=BUSCAR(C6;{1;2;3;4;5};{0,2;0,4;0,6;0,8;1})
E6=SI(D6>=60%;"APROBADO";"REPROBO")


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

Sigo insistiendo: si en tu formula utilizas, los valores porcentuales, entre comillas en lugar de sin ellas, entonces, reconoce 0 en todos los posibles resultados

Pones: "20%" y tendrias que poner 20% ó 0,2 y asi con cada porcentaje



Última edición por GalileoGali el Dom Feb 20, 2011 7:23 pm, editado 1 vez

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: formulas en excel

Mensaje por GalileoGali el Dom Feb 20, 2011 7:15 pm

Hoja1

 CDE
65100%APROBADO
Spreadsheet Formulas
CellFormula
D6=ENTERO(C6)*0,2
E6=SI(D6>=60%;"APROBADO";"REPROBO")


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: formulas en excel

Mensaje por Invitado el Dom Feb 20, 2011 9:33 pm

ok, puede ser, te lo explico asi

en la celda a1 va el nombre del alumno
en la celda b1 la nota que digita el profesor
en la celda c1 ya el procedimiento es automatico es decir cuando digito un valor = o > que 3 debe salir en la celda d1 el procentaje 60% si es menor 40% y asi sucecivamente, en la celda e1 debera salir el estado de la nota , si aprobo o reprobo si supera el 3 aprueba y sino reprueba.

ya lo resolvi el problema pero con otro procedimiento, pero me gustaria probar tu formula para entenderla mejor, por que encierras en llaves el 1,2,3,4, y despues el 0,2,0,4 ??? etc.

Invitado
Invitado


Volver arriba Ir abajo

Re: formulas en excel

Mensaje por Invitado el Dom Feb 20, 2011 9:57 pm

LO HICE CON tu formula pero no se si es que no la entiendo o esta mal enfocada, pues cuando no hay nota, en la celda del porcentaje me muestra 0% y no deberia mistrame nada yen el estado me muestra reprobado y tampoco deberia mostrme nada

y si el aplicas c5=0;""; entonces sale aprobado en todo

de todas formas muchas gracias, le quite las comillas a los valores, la mia es mas larga pero funciona

Invitado
Invitado


Volver arriba Ir abajo

Re: formulas en excel

Mensaje por GalileoGali el Dom Feb 20, 2011 10:48 pm

aca va con los detalles

Hoja1

 ABCD
1Nombre AlumnoNotaPorcentualResulTado
2TestaLomaNegra30,6APROBADO
Spreadsheet Formulas
CellFormula
C2=SI(B2="";"";ENTERO(B2)*0,2)
D2=SI(N(C2);SI(C2>=60%;"APROBADO";"REPROBO");"")


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: formulas en excel

Mensaje por GalileoGali el Dom Feb 20, 2011 10:55 pm

y ahora con la primera formula, atajando los vacios....


Hoja1

 ABCD
1Nombre AlumnoNotaPorcentualResulTado
2TestaLomaNegra2,3040%REPROBO
Spreadsheet Formulas
CellFormula
C2=SI(B2="";"";BUSCAR(B2;{1;2;3;4;5};{0,2;0,4;0,6;0,8;1}))
D2=SI(N(C2);SI(C2>=60%;"APROBADO";"REPROBO");"")


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: formulas en excel

Mensaje por Invitado el Lun Feb 21, 2011 9:20 am

gracias amigo gali, esta mejor que mi formula, esta mas perfeccionada, la aplique a mi tabla de notas y funcion perfecto, por ultimo le hice una validacion pues cuando se digitaba un numero mayor que 5 me clocaba 10% y aprobado. ahora si esta mucho mejor.

lo que mas me gusta de excel es que todo se puede automatizar. saludes.

Invitado
Invitado


Volver arriba Ir abajo

Re: formulas en excel

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.