............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

última Fila Ocupada

Ver el tema anterior Ver el tema siguiente Ir abajo

última Fila Ocupada

Mensaje por Tatayayan el Dom Mayo 08, 2011 2:24 pm

Hola supongamos que deseamos conocer la última celda ocupada en la columna A, GALI propone:
=BUSCAR(2;1/(A:A<>"");FILA(A:A))
Y otra que no recuerdo, mi aporte (no muy probado) es:
=SUMAPRODUCTO(MAX((A:A<>"")*FILA(A:A)))

Salu2.xlsx
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: última Fila Ocupada

Mensaje por GalileoGali el Dom Mayo 08, 2011 11:19 pm

Que tal Tatayayan:

siguiendo con tu propuesta, veamos qué pasa con esto

Hoja1

 ABCDEFGHI
1  17supera errores intermedios, pero especifica hasta ultima sin error     
2         
3  #¡DIV/0!No supera errores     
4         
58 17supera errores intermedios o los toma como ultima fila en caso de serlo     
6         
7r        
8         
9FALSO        
10         
11#¡DIV/0!        
12         
13#N/A        
14         
15#¡REF!        
16         
17tttt        
Spreadsheet Formulas
CellFormula
C1=BUSCAR(2;1/(A:A<>"");FILA(A:A))
C3=SUMAPRODUCTO(MAX((A:A<>"")*FILA(A:A)))
C5=MAX(BUSCAR(2;1/(A:A<>"");FILA(A:A));BUSCAR(2;1/ESERROR(A:A);FILA(A:A)))
A11=1/0
A13=NOD()
A15=DESREF(A1;0;-1)


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

Invito a jugar, borrando errores, dejando todo menos ellos. Dejando,,luego los erroes y dejandolos como ultimos ocupantes de fila

Falta probar los Blancos
=""


_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: última Fila Ocupada

Mensaje por Tatayayan el Mar Mayo 10, 2011 7:58 pm

Hola, una matricial que a primera instancia da la ultima fila:
{=SUMAPRODUCTO(MAX(NO(ESBLANCO(A:A))*FILA(A:A)))}
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: última Fila Ocupada

Mensaje por Logroastur el Vie Mayo 13, 2011 5:13 am

Buenas otra posible opción

Código:
 =MAX(INDICE(($A:$A<>"")*FILA($A:$A);))

un saludo

_________________

[Tienes que estar registrado y conectado para ver este vínculo]
ForoExcel
[Tienes que estar registrado y conectado para ver este vínculo]

avatar
Logroastur
Moderador
Moderador

Masculino Cantidad de envíos : 32
Edad : 53
Ciudad - Pais : España
Version de Excel : 2007
Fecha de inscripción : 20/11/2010

http://www.foroexcel.com/foro/

Volver arriba Ir abajo

Re: última Fila Ocupada

Mensaje por Tatayayan el Vie Mayo 13, 2011 11:49 am

HolaLogroastur,
=MAX(INDICE(($A:$A<>"")*FILA($A:$A);))
Si la columna A tiene errores (como plateó Gali) esta fórmula me da error.
Mira lo que plentea Gali, suerte!
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: última Fila Ocupada

Mensaje por sailepaty el Vie Mayo 13, 2011 10:26 pm

Puede que esta funcione,

=BUSCAR(2;1/NO(ESBLANCO(A:A));FILA(A:A))

Saludos

_________________
I didn't ask to be Mexican I just got lucky!!!
avatar
sailepaty
Moderador
Moderador

Masculino Cantidad de envíos : 135
Edad : 54
Ciudad - Pais : Dallas, TX
Version de Excel : 2007 y 2010
Fecha de inscripción : 04/03/2008

Volver arriba Ir abajo

Re: última Fila Ocupada

Mensaje por GalileoGali el Vie Mayo 13, 2011 11:55 pm

La formula de saile me parece INSUPERABLE, lo digo porque detecta todo, aun la presencia de formulas como esta:

=""
resultado cadena nula

.....que soslayan (no reconocen) las otras

EXCELENTE SAILE!!!
De todas maneras, no creo que necesariamente haya que desechar las otras, ya que pueden presentarse casos particulares, donde interese "pasar por alto" esas celdas de valor null string (Valor "")

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: última Fila Ocupada

Mensaje por Tatayayan el Sáb Mayo 14, 2011 1:09 pm

Buenisímo lo de Saile, y no es matricial, estoy probando mi matricial:
=SUMAPRODUCTO(MAX(NO(ESBLANCO(A:A))*FILA(A:A)))
con ="" y lo sigue contemplando.
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: última Fila Ocupada

Mensaje por GalileoGali el Sáb Mayo 14, 2011 1:42 pm

=SUMAPRODUCTO(MAX(INDICE(NO(ESBLANCO(A:A))*FILA(A:A);)))
Basad en la tuya, pero INDICE, RESUELVE LA NECESIDAD DE CTRL+MAY+ENTER

No me fije, pero es probable que esta o alguna otra parecida, ya hayan sido aportadas. (disculpas, si es asi)

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: última Fila Ocupada

Mensaje por sailepaty el Dom Mayo 15, 2011 11:03 pm

Gracias y saludos a todos.

_________________
I didn't ask to be Mexican I just got lucky!!!
avatar
sailepaty
Moderador
Moderador

Masculino Cantidad de envíos : 135
Edad : 54
Ciudad - Pais : Dallas, TX
Version de Excel : 2007 y 2010
Fecha de inscripción : 04/03/2008

Volver arriba Ir abajo

Re: última Fila Ocupada

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.