............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Busqueda por una determinada columna

Ver el tema anterior Ver el tema siguiente Ir abajo

Busqueda por una determinada columna

Mensaje por carlosh el Miér Jun 08, 2011 1:34 pm

Tengo una tabla con tres columnas que son: codigo (numerico de cuatro cifras), nombres, valor total, abono 1, abono 2, abono 3, total abonos y saldo (todas estas son numericas en miles de pesos). Al realizar una búsqueda o consulta segun el codigo se presenta ERROR debido a que al buscar por ejemplo 3450 lo confunde y encuentra un valor o abono de 3450000 y lo presenta este y no el codigo solicitado.
Cómo hacer que la busqueda se realice EXCLUSIVAMENTE por la COLUMNA DE CÓDIGO?
Cuál es el codigo vba?

Gracias

carlosh

Masculino Cantidad de envíos : 2
Edad : 52
Ciudad - Pais : colombia
Version de Excel : XP - 2010
Fecha de inscripción : 15/04/2011

Volver arriba Ir abajo

busqueda

Mensaje por federico ramirez marron el Miér Jun 08, 2011 7:16 pm

Ve si puedes adaptarlo a tu caso

[Tienes que estar registrado y conectado para ver este vínculo]
avatar
federico ramirez marron

Masculino Cantidad de envíos : 95
Edad : 44
Ciudad - Pais : acapulco, gro mexico
Fecha de inscripción : 03/03/2008

Volver arriba Ir abajo

mil gracias, ahora necesito ingresar datos unicos en una columna

Mensaje por carlosh el Dom Jun 12, 2011 7:15 pm

MIL GRACIAS FEDERICO

Lo adapte a mi proyecto y resulto UNO A!

Ahora necesito lo siguiente: En esa columna de códigos de tres o cuatro dígitos requiero que SOLO se ingresen CÓDIGOS ÚNICOS, es decir, que dicha columna no admita duplicados. Cuál es el código para hacer eso?

Oye también como se hace para buscar algo en una columna donde hay SOLO TEXTO, como por ejemplo, en una columna de nombres y apellidos y se desea buscar UN NOMBRE? cuál es el código?

MIL GRACIAS POR TU TIEMPO

carlos h

carlosh

Masculino Cantidad de envíos : 2
Edad : 52
Ciudad - Pais : colombia
Version de Excel : XP - 2010
Fecha de inscripción : 15/04/2011

Volver arriba Ir abajo

Re: Busqueda por una determinada columna

Mensaje por ioyama el Lun Jun 13, 2011 8:07 am

Hola Carlos

En lo refernte a códigos unicos puedes usar una validación de celda tipo personalizada con algo como

=CONTAR.SI(A:A;A2)=1

Un saludo desde Vitoria

ioyama
Moderador
Moderador

Masculino Cantidad de envíos : 128
Edad : 54
Ciudad - Pais : Vitoria (España)
Fecha de inscripción : 03/03/2008

Volver arriba Ir abajo

Re: Busqueda por una determinada columna

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.