............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

seguimientos

Ver el tema anterior Ver el tema siguiente Ir abajo

seguimientos

Mensaje por Invitado el Mar Jul 05, 2011 10:49 am

hola, en una hoja de excel , .. lo que trato de hacer es lo sgt:

que cuando el cliente cumpla un año de seguimiento, medido desde la primera consulta, el sistema notifique que debe pagar otra consulta por un año mas..

hay alguna funcion que pueda aplicar o formula, me dan alguna idea por fa..

Invitado
Invitado


Volver arriba Ir abajo

Re: seguimientos

Mensaje por ioyama el Vie Jul 08, 2011 4:18 am

Hola Jhon

Usando Si y HOY, puedes montar algo como

=SI(Y(DIA(HOY())=DIA(G11);MES(HOY())=MES(G11);AÑO(HOY())=AÑO(G11)+1);"ha pasado un año";"")

o como

=SI(HOY()=G11+365;"ha pasado un año";"")

Mejor cambiando el = por >= (mayor e igual) de lo contrario solo funcionaría el día concreto.

Otra opción es eliminar la parte del AÑO en la primera, así serviría para cualquier año sin modificar nada.

Sin un archivo en el que se vea la estructura poco más puedo decirte.

Espero que las ideas te sirvan.

Un saludo desde Vitoria

ioyama
Moderador
Moderador

Masculino Cantidad de envíos : 128
Edad : 54
Ciudad - Pais : Vitoria (España)
Fecha de inscripción : 03/03/2008

Volver arriba Ir abajo

Re: seguimientos

Mensaje por Invitado el Vie Jul 08, 2011 3:34 pm

gracias ioyama, pues podria ser, enviame tu correo y te lo envio. vale

ioyama escribió:Hola Jhon

Usando Si y HOY, puedes montar algo como

=SI(Y(DIA(HOY())=DIA(G11);MES(HOY())=MES(G11);AÑO(HOY())=AÑO(G11)+1);"ha pasado un año";"")

o como

=SI(HOY()=G11+365;"ha pasado un año";"")

Mejor cambiando el = por >= (mayor e igual) de lo contrario solo funcionaría el día concreto.

Otra opción es eliminar la parte del AÑO en la primera, así serviría para cualquier año sin modificar nada.

Sin un archivo en el que se vea la estructura poco más puedo decirte.

Espero que las ideas te sirvan.

Un saludo desde Vitoria

Invitado
Invitado


Volver arriba Ir abajo

Re: seguimientos

Mensaje por Invitado el Vie Jul 08, 2011 5:25 pm

IOYAMA, ESTUVE PROBANDO TU FORMULA PERO NO ME FUNCIONA, les cambio las fechas pero donde va la formula queda en blanco, le aplique SI(HOY()=AA6+365;"ha pasado un año";"")

"AA" ES LA CELDA DE LA FECHA EN QUE INGRESO EL CLIENTE.

Invitado
Invitado


Volver arriba Ir abajo

Re: seguimientos

Mensaje por Tatayayan el Vie Jul 08, 2011 8:32 pm

hola jhon nash, creo que tu fórmula le faltaría el >=, creo que con el igual te traerá problemas, otra alternativa =SI(SIFECHA(A1;HOY();"Y")>0;"Pasó un Año";"")
en A1 estaría la fecha.
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: seguimientos

Mensaje por Tatayayan el Vie Jul 08, 2011 8:36 pm

Otra alternativa:
=SI(FECHA(AÑO(HOY());MES(A1);DIA(A1))
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: seguimientos

Mensaje por Invitado el Vie Jul 08, 2011 11:31 pm

hola, la fecha se diigta una sola vez y va en la celda AA6, en la celda AB6 va tu formula,, cuando el sitema marque el 08/07/2012 en esta celda debe salir in mensaje "ha pasado un año", pero yo hago el simulacro digitando fechas despues de 08/07/2012 y nada
deberia salir el mensaje, pero quedaen blanco.. con = o >= con ninguno

sale #!NUM
si digito la fecha por ejemplo 07/08/2010 si me sale el mensaje pero si didgito una fecha posteriror sale #ªnum.. los registro se va a empeszar a ingresar en el dia de hoy, y al año debe hberse cumplido debe salir el mensaje
gracias


Tatayayan escribió:hola jhon nash, creo que tu fórmula le faltaría el >=, creo que con el igual te traerá problemas, otra alternativa =SI(SIFECHA(A1;HOY();"Y")>0;"Pasó un Año";"")
en A1 estaría la fecha.

Invitado
Invitado


Volver arriba Ir abajo

Re: seguimientos

Mensaje por moises melgar el Lun Jul 11, 2011 12:23 pm

Para ampliar el uso de Sifecha que muestra Tatayayan:

=SIFECHA(A1,HOY(),"Y") años totales desde A1 hasta hoy
=SIFECHA(A1,HOY(),"m") meses totales desde A1 hasta hoy
=SIFECHA(A1,HOY(),"d") dias totales desde A1 hasta hoy

y combinaciones:

=SIFECHA(A1,HOY(),"Ym") Meses que no completan el año desde A1 a hoy.
=SIFECHA(A1,HOY(),"md") Dias que no completan un mes desde A1 a hoy.
avatar
moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 557
Edad : 29
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: seguimientos

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.