............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

BUSCARV ITERATIVO

Ver el tema anterior Ver el tema siguiente Ir abajo

BUSCARV ITERATIVO

Mensaje por GalileoGali el Jue Mayo 01, 2008 3:50 pm

Supongamos queremos BUSCARV, todas las apariciones y su valor asociado, veamos que es mas facil ver que explicar:
Hoja1

 ABCDE
1A7 A 
2S22   
3A13  7
4S45  13
5A11  11
6F6  7
7A7  0
8G56   
9A0   
Spreadsheet Formulas
CellFormula
E3{=SI(CONTAR($E$2:E2)>=CONTAR.SI($A$1:$A$9;D$1);"";INDICE($B$1:$B$9;K.ESIMO.MENOR(SI($A$1:$A$9=D$1;FILA($A$1:$A$9)-FILA($A$1)+1);FILA()-FILA($E$3)+1)))}
E4{=SI(CONTAR($E$2:E3)>=CONTAR.SI($A$1:$A$9;D$1);"";INDICE($B$1:$B$9;K.ESIMO.MENOR(SI($A$1:$A$9=D$1;FILA($A$1:$A$9)-FILA($A$1)+1);FILA()-FILA($E$3)+1)))}
E5{=SI(CONTAR($E$2:E4)>=CONTAR.SI($A$1:$A$9;D$1);"";INDICE($B$1:$B$9;K.ESIMO.MENOR(SI($A$1:$A$9=D$1;FILA($A$1:$A$9)-FILA($A$1)+1);FILA()-FILA($E$3)+1)))}
E6{=SI(CONTAR($E$2:E5)>=CONTAR.SI($A$1:$A$9;D$1);"";INDICE($B$1:$B$9;K.ESIMO.MENOR(SI($A$1:$A$9=D$1;FILA($A$1:$A$9)-FILA($A$1)+1);FILA()-FILA($E$3)+1)))}
E7{=SI(CONTAR($E$2:E6)>=CONTAR.SI($A$1:$A$9;D$1);"";INDICE($B$1:$B$9;K.ESIMO.MENOR(SI($A$1:$A$9=D$1;FILA($A$1:$A$9)-FILA($A$1)+1);FILA()-FILA($E$3)+1)))}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


Última edición por GalileoGali el Miér Feb 18, 2009 6:00 pm, editado 1 vez (Razón : REVISE Y CORREGI LAS FORMULAS)

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.