............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Referenciar celdas traspuestas

Ver el tema anterior Ver el tema siguiente Ir abajo

Referenciar celdas traspuestas

Mensaje por moctezuma48 el Vie Ago 12, 2011 4:47 am

¡Hola!

Solicito vuestra ayuda para el siguiente problema:

Tengo una columna de datos que para simplificar digamos que son valores consecutivos del 1 al 100 en la columna A


Lo que quiero es colocarlos de 5 en 5 en columnas aparte así:

1 6
2 7
3 8
4 9
5 10 .....

Lo que quisiera saber es la forma de referenciar las celdas para que yo pueda copiar y pegar la primera columna y no tener que referenciar las celdas una por una.

Muchas gracias por la ayuda





moctezuma48

Masculino Cantidad de envíos : 43
Edad : 48
Ciudad - Pais : ESPAÑA
Version de Excel : 2007
Fecha de inscripción : 29/06/2011

Volver arriba Ir abajo

Re: Referenciar celdas traspuestas

Mensaje por Cacho R el Vie Ago 12, 2011 11:22 am

Tienes que "jugar" con las funciones FILA y COLUMNA.
Si, por ejemplo, tus datos comenzacen en A2 entonces podrías intentar en B2 con:

= INDIRECTO("A" & 2 + FILA() - FILA($A$2) + 5*(COLUMNA() - COLUMNA($A$2) ))

y copiar según describes.

También puedes intentar en B2 con:

= DESREF($A$2; FILA() - FILA($A$2) + 5*(COLUMNA() - COLUMNA($A$2) ); 0)


Saludos, Cacho R.
avatar
Cacho R
Moderador
Moderador

Masculino Cantidad de envíos : 210
Ciudad - Pais : Buenos Aires
Version de Excel : Desde Multiplan (pre-Excel) hasta 2010
Fecha de inscripción : 29/06/2011

Volver arriba Ir abajo

Re: Referenciar celdas traspuestas

Mensaje por moctezuma48 el Vie Ago 12, 2011 6:00 pm

Muchas gracias por la ayuda

Ya lo he estado probando y funciona perfectamente.

moctezuma48

Masculino Cantidad de envíos : 43
Edad : 48
Ciudad - Pais : ESPAÑA
Version de Excel : 2007
Fecha de inscripción : 29/06/2011

Volver arriba Ir abajo

Re: Referenciar celdas traspuestas

Mensaje por Cacho R el Vie Ago 12, 2011 7:08 pm

¡Pero qué bueno!...
avatar
Cacho R
Moderador
Moderador

Masculino Cantidad de envíos : 210
Ciudad - Pais : Buenos Aires
Version de Excel : Desde Multiplan (pre-Excel) hasta 2010
Fecha de inscripción : 29/06/2011

Volver arriba Ir abajo

Re: Referenciar celdas traspuestas

Mensaje por GalileoGali el Sáb Ago 13, 2011 8:30 pm

Otra version con INDICE

=SI.ERROR(INDICE($A$1:$A$31;COLUMNA()-COLUMNA($B$1)+5*(FILA()-FILA($A$1)));"")
EN eXCEL 2007 Y POSTERIOR

=SI(ESERROR(INDICE($A$1:$A$31;COLUMNA()-COLUMNA($B$1)+5*(FILA()-FILA($A$1))));"";INDICE($A$1:$A$31;COLUMNA()-COLUMNA($B$1)+5*(FILA()-FILA($A$1))))

En todo Excel que conozco.... 97 a 2010

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Referenciar celdas traspuestas

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.