............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Quiero verificar la secuencia de los números de código

Ver el tema anterior Ver el tema siguiente Ir abajo

Quiero verificar la secuencia de los números de código

Mensaje por Invitado el Dom Oct 23, 2011 5:35 am

¡Hola
En el trabajo que desea comprobar los números de secuencia en la columna A ¿Ven por aquí
1 2 3 4 5 6 7
Vamos, si esta forma es un mensaje de alerta que la secuencia de errores de

Invitado
Invitado


Volver arriba Ir abajo

Re: Quiero verificar la secuencia de los números de código

Mensaje por Tatayayan el Dom Oct 23, 2011 11:57 am

hola, supongamos que los numeros empiezan en A1 y se van colocando uno debajo del otro, en B2 (si B2) ponés =SI(A2-A1<>1;"Falla";"") y copiás para hacia abajo.
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: Quiero verificar la secuencia de los números de código

Mensaje por Invitado el Dom Oct 23, 2011 2:25 pm

Gracias Tatayayan
He llegado a la siguiente código

Código:
 Sub alidroos_1()
Application.EnableEvents = False
last1 = Sheets("data").Range("a2000").End(xlUp).Row
For R = 4 To last1
If Application.WorksheetFunction.CountIf([a4:a512], Cells(R, 1)) > 1 Then
Sheets("data").Range("bx2") = Sheets("data").Cells(R, 1)
Else
Sheets("data").Range("bx2:bx200").ClearContents
End If
Next R
Set sht1 = Sheets("data")
If Application.WorksheetFunction.CountA(sht1.Range("bx2:bx20")) > 0 Then
MsgBox "No es un duplicado de la serie no puede completar la impresi?n"
Exit Sub
Else:
MsgBox "Estoy seguro de que no hay duplicados en la serie de éxito"
End If
Dim MYLIST(1000)
Dim MYRNG1 As Range
Application.ScreenUpdating = False
LastRow = Sheets("data").Range("A" & Rows.Count).End(xlUp).Row
Dim I As Long
For I = Sheets("data").Range("A4") To Sheets("data").Range("A" & LastRow)
MYLIST(I) = I
Next I
Set MYRNG1 = Sheets("data").Range("A4:A" & LastRow)
k = 4
For x = 1 To UBound(MYLIST)
If Application.WorksheetFunction.CountIf(MYRNG1, MYLIST(x)) = 0 Then
Sheets("data").Range("by2:by200").ClearContents
Range("by" & k) = MYLIST(x)
k = k + 1
End If
Next x
Set so = Sheets("data")
ter = Application.WorksheetFunction.Max(so.Range("by2:by20"))
If ter > 1 Then
MsgBox "Hay series que no existe no puede completar la letra"
Exit Sub
Else:
MsgBox "Cyril se ha comprobado con éxito la serie"
End If
Set Sh = Sheets("data")
ek = Sheets("data").Range("a1500").End(xlUp).Row
e = Row = 4
ser = Application.WorksheetFunction.CountBlank(Sh.Range("a4:a" & ek))
If ser > 0 Then
MsgBox "Hay algunas células desocupados durante largo tiempo no se puede completar la impresi?n"
Exit Sub
Else:
MsgBox "تM Compruebe que no hay celdas en blanco en la serie de éxito"
End If
Application.EnableEvents = True
Application.ScreenUpdating = True
End Sub
 

Invitado
Invitado


Volver arriba Ir abajo

Re: Quiero verificar la secuencia de los números de código

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.