............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

buscar valores dependiendo de otra celda

Ver el tema anterior Ver el tema siguiente Ir abajo

buscar valores dependiendo de otra celda

Mensaje por moctezuma48 el Jue Oct 27, 2011 9:54 am

Hola buenas tardes a tod@s

Mi consulta es la siguiente:

Tengo dos filas de valores. La segunda fila puede tomar unos valores del 0 al 12, ambos inclusive.
Por cada valor que pueda tomar dicha fila le he puesto unos valores máximos y mínimos que puede tomar la primera fila.

Quiero crear una tercera fila que me diga si los valores de la primera fila están dentro de los valores máximos y mínimos que dependen de la
segunda.

Por ejemplo para el valor 12 el máximo son 3 y el mínimo es 1. Si el valor es 4 ó 0 que me diga "NO", y si está entre 1 y 3 inclusive, que me diga "SÍ"

Muchas gracias por la ayuda



moctezuma48

Masculino Cantidad de envíos : 43
Edad : 47
Ciudad - Pais : ESPAÑA
Version de Excel : 2007
Fecha de inscripción : 29/06/2011

Volver arriba Ir abajo

Re: buscar valores dependiendo de otra celda

Mensaje por Tatayayan el Vie Oct 28, 2011 12:29 pm

Hola, no entendí mucho, pon un ejemplo adjunto (yo no sé como poner adjuntos, pero sé que se puede antes lo hac´´ia y este foro ofrece esta particularidad).
Ejemplo:
=SI(Y(A1>=0;A1<=4);"En Rango de Valores";"No")

Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: buscar valores dependiendo de otra celda

Mensaje por moctezuma48 el Vie Oct 28, 2011 2:12 pm

¡Hola!

Un ejemplo sería:

=SI (B1 = 0) --> A1 >=40 y <= 46; "SÍ";"NO")
=SI (B1 = 1) --> A1 >=29 y <= 46; "SÍ";"NO")

... y así los demás valores según tabla

para B1 = 0 --> A1 entre 46 y 40; para B1 = 1 --> A1 entre 46 y 29;
para B1 = 2 --> A1 entre 45 y 24; para B1 = 3 --> A1 entre 44 y 20;
para B1 = 4 --> A1 entre 18 y 40; para B1 = 5 --> A1 entre 16 y 34;
para B1 = 6 --> A1 entre 13 y 32; para B1 = 7 --> A1 entre 12 y 30;
para B1 = 8 --> A1 entre 9 y 22; para B1 = 9--> A1 entre 8 y 17;
para B1 = 10 --> A1 entre 6 y 13; para B1 = 11 --> A1 entre 4 y 7;
para B1 = 0 --> A1 entre 40 y 46; para B1 = 0 --> A1 entre 40 y 46;
para B1 = 0 --> A1 entre 40 y 46; para B1 = 0 --> A1 entre 40 y 46;
para B1 = 12 --> A1 entre 1 y 3


Un saludo,


(Ya mandé un archivo adjunto, pero no sé por qué no salió)

moctezuma48

Masculino Cantidad de envíos : 43
Edad : 47
Ciudad - Pais : ESPAÑA
Version de Excel : 2007
Fecha de inscripción : 29/06/2011

Volver arriba Ir abajo

Re: buscar valores dependiendo de otra celda

Mensaje por moctezuma48 el Dom Oct 30, 2011 1:36 pm

Mirando por un lado y por otro, al final he conseguido dar con la solución que yo quería:

Poniendo los valores que puede tomar la fila 2 en una columna, los máximos y los mínimos de la fila 1 en otras dos columnas, con la función buscarV:

12 3 1
11 7 4
10 13 6
9 17 8
8 22 9
7 30 12
6 32 13
5 34 16
4 40 18
3 44 20
2 45 24
1 46 29
0 46 40

la solución me quedaría como sigue:

=SI(Y(BUSCARV(A2;$K$1:$M$13;2;FALSO)>=A1)*Y(BUSCARV(A2;$K$1:$M$13;3;FALSO)<=A1);"BIEN";"MAL")

Un saludo y muchas gracias.

moctezuma48

Masculino Cantidad de envíos : 43
Edad : 47
Ciudad - Pais : ESPAÑA
Version de Excel : 2007
Fecha de inscripción : 29/06/2011

Volver arriba Ir abajo

Re: buscar valores dependiendo de otra celda

Mensaje por Contenido patrocinado Hoy a las 1:55 am


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.