............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Variar la formula JERARQUIA

Ir abajo

Variar la formula JERARQUIA

Mensaje por felipedominguez el Miér Nov 09, 2011 12:39 pm

Buenas tardes,

Después de mucho intentarlo, pido ayuda a ver a alguien se le ocurre como hacer.

Ejemplo, tengo un listado de personas con una puntuación cada una, ya la quiero ordenar con la formula jerarquia…. Hasta aquí todo bien.

El problema es que cuando dos personas tienen la misma puntuación, quiero que salga con la misma jerarquia (esto lo hace la formula), pero que la siguiente jerarquia sea la justamente siguiente.

Me explico, si las dos personas que tienen la misma puntuación tienen la jerarquia 5, quiero que la siguiente persona tenga la jerarquia 6, y no la 7 como hace la formula.

Gracias
Archivos
duda jerarquia.xls No tienes los permisos para descargar los archivos.(14 KB) Descargado 16 veces

felipedominguez

Masculino Cantidad de envíos : 2
Edad : 45
Ciudad - Pais : Barcelona-España
Version de Excel : 2003
Fecha de inscripción : 09/11/2011

Volver arriba Ir abajo

Re: Variar la formula JERARQUIA

Mensaje por GalileoGali el Miér Nov 09, 2011 5:48 pm

a ver si te interpretamos

Hoja1

 ABCD
1NombrePuntosJerarquíaRectificada
2Alejandra6,8888
3Carlos9,0033
4Fernando31,4011
5Jose6,80109
6Juan8,7344
7Pedro6,8888
8Simon7,7166
9Leonardo7,9155
10David7,0677
11Jorge9,1822
Spreadsheet Formulas
CellFormula
C2=JERARQUIA(B2;$B$2:$B$11;0)
D2=SI(O(JERARQUIA(B2;$B$2:$B$11;0)=1;ESNUMERO(COINCIDIR(C2-1;$C$2:$C$11;0)));JERARQUIA(B2;$B$2:$B$11;0);JERARQUIA(B2;$B$2:$B$11;0)-1)
C3=JERARQUIA(B3;$B$2:$B$11;0)
D3=SI(O(JERARQUIA(B3;$B$2:$B$11;0)=1;ESNUMERO(COINCIDIR(C3-1;$C$2:$C$11;0)));JERARQUIA(B3;$B$2:$B$11;0);JERARQUIA(B3;$B$2:$B$11;0)-1)
C4=JERARQUIA(B4;$B$2:$B$11;0)
D4=SI(O(JERARQUIA(B4;$B$2:$B$11;0)=1;ESNUMERO(COINCIDIR(C4-1;$C$2:$C$11;0)));JERARQUIA(B4;$B$2:$B$11;0);JERARQUIA(B4;$B$2:$B$11;0)-1)
C5=JERARQUIA(B5;$B$2:$B$11;0)
D5=SI(O(JERARQUIA(B5;$B$2:$B$11;0)=1;ESNUMERO(COINCIDIR(C5-1;$C$2:$C$11;0)));JERARQUIA(B5;$B$2:$B$11;0);JERARQUIA(B5;$B$2:$B$11;0)-1)
C6=JERARQUIA(B6;$B$2:$B$11;0)
D6=SI(O(JERARQUIA(B6;$B$2:$B$11;0)=1;ESNUMERO(COINCIDIR(C6-1;$C$2:$C$11;0)));JERARQUIA(B6;$B$2:$B$11;0);JERARQUIA(B6;$B$2:$B$11;0)-1)
C7=JERARQUIA(B7;$B$2:$B$11;0)
D7=SI(O(JERARQUIA(B7;$B$2:$B$11;0)=1;ESNUMERO(COINCIDIR(C7-1;$C$2:$C$11;0)));JERARQUIA(B7;$B$2:$B$11;0);JERARQUIA(B7;$B$2:$B$11;0)-1)
C8=JERARQUIA(B8;$B$2:$B$11;0)
D8=SI(O(JERARQUIA(B8;$B$2:$B$11;0)=1;ESNUMERO(COINCIDIR(C8-1;$C$2:$C$11;0)));JERARQUIA(B8;$B$2:$B$11;0);JERARQUIA(B8;$B$2:$B$11;0)-1)
C9=JERARQUIA(B9;$B$2:$B$11;0)
D9=SI(O(JERARQUIA(B9;$B$2:$B$11;0)=1;ESNUMERO(COINCIDIR(C9-1;$C$2:$C$11;0)));JERARQUIA(B9;$B$2:$B$11;0);JERARQUIA(B9;$B$2:$B$11;0)-1)
C10=JERARQUIA(B10;$B$2:$B$11;0)
D10=SI(O(JERARQUIA(B10;$B$2:$B$11;0)=1;ESNUMERO(COINCIDIR(C10-1;$C$2:$C$11;0)));JERARQUIA(B10;$B$2:$B$11;0);JERARQUIA(B10;$B$2:$B$11;0)-1)
C11=JERARQUIA(B11;$B$2:$B$11;0)
D11=SI(O(JERARQUIA(B11;$B$2:$B$11;0)=1;ESNUMERO(COINCIDIR(C11-1;$C$2:$C$11;0)));JERARQUIA(B11;$B$2:$B$11;0);JERARQUIA(B11;$B$2:$B$11;0)-1)


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Variar la formula JERARQUIA

Mensaje por ioyama el Miér Nov 09, 2011 7:11 pm

Hola Felipe (Gali)

Aporto otra opción usando una columna auxiliar.

Falsa jerarquia, descargable desde el botón archivo (en color verde) de skydrive).

Un saludo desde Vitoria

ioyama
Moderador
Moderador

Masculino Cantidad de envíos : 128
Edad : 55
Ciudad - Pais : Vitoria (España)
Fecha de inscripción : 03/03/2008

Volver arriba Ir abajo

Re: Variar la formula JERARQUIA

Mensaje por GalileoGali el Miér Nov 09, 2011 8:19 pm

Io otra variante basada en tu propuesta


Hoja1

 FGHI
1NombrePuntosAuxiliarJerarquía
2Alejandra6,886,887
3Carlos9,0093
4Fernando31,4031,41
5Jose6,806,88
6Juan8,738,734
7Pedro6,88 7
8Simon7,717,716
9Leonardo7,917,915
10David6,88 7
11Jorge9,189,182
Spreadsheet Formulas
CellFormula
H2=SI(CONTAR.SI($G$1:G1;G2)=0;G2;"")
I2=SI(H2="";BUSCARV(G2;$C$2:$D$11;2;0);JERARQUIA(H2;$C$2:$C$11;0))
H3=SI(CONTAR.SI($G$1:G2;G3)=0;G3;"")
I3=SI(H3="";BUSCARV(G3;$C$2:$D$11;2;0);JERARQUIA(H3;$C$2:$C$11;0))
H4=SI(CONTAR.SI($G$1:G3;G4)=0;G4;"")
I4=SI(H4="";BUSCARV(G4;$C$2:$D$11;2;0);JERARQUIA(H4;$C$2:$C$11;0))
H5=SI(CONTAR.SI($G$1:G4;G5)=0;G5;"")
I5=SI(H5="";BUSCARV(G5;$C$2:$D$11;2;0);JERARQUIA(H5;$C$2:$C$11;0))
H6=SI(CONTAR.SI($G$1:G5;G6)=0;G6;"")
I6=SI(H6="";BUSCARV(G6;$C$2:$D$11;2;0);JERARQUIA(H6;$C$2:$C$11;0))
H7=SI(CONTAR.SI($G$1:G6;G7)=0;G7;"")
I7=SI(H7="";BUSCARV(G7;$C$2:$D$11;2;0);JERARQUIA(H7;$C$2:$C$11;0))
H8=SI(CONTAR.SI($G$1:G7;G8)=0;G8;"")
I8=SI(H8="";BUSCARV(G8;$C$2:$D$11;2;0);JERARQUIA(H8;$C$2:$C$11;0))
H9=SI(CONTAR.SI($G$1:G8;G9)=0;G9;"")
I9=SI(H9="";BUSCARV(G9;$C$2:$D$11;2;0);JERARQUIA(H9;$C$2:$C$11;0))
H10=SI(CONTAR.SI($G$1:G9;G10)=0;G10;"")
I10=SI(H10="";BUSCARV(G10;$C$2:$D$11;2;0);JERARQUIA(H10;$C$2:$C$11;0))
H11=SI(CONTAR.SI($G$1:G10;G11)=0;G11;"")
I11=SI(H11="";BUSCARV(G11;$C$2:$D$11;2;0);JERARQUIA(H11;$C$2:$C$11;0))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Variar la formula JERARQUIA

Mensaje por felipedominguez el Jue Nov 10, 2011 5:14 am

Muchisimas gracias por vuestras soluciones.

Un saludo

felipedominguez

Masculino Cantidad de envíos : 2
Edad : 45
Ciudad - Pais : Barcelona-España
Version de Excel : 2003
Fecha de inscripción : 09/11/2011

Volver arriba Ir abajo

Re: Variar la formula JERARQUIA

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.