............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

condicionar una celda para obtener valor con 3 decimales

Ver el tema anterior Ver el tema siguiente Ir abajo

condicionar una celda para obtener valor con 3 decimales

Mensaje por Mangue el Vie Ene 20, 2012 9:02 am

Hola, perdonad el título pq no es nada explicativo. Bajo datos numéricos diariamente de internet, estos números son un porcentaje de 1 a 100 con dos o 3 decimales. Los decimales se separan por el punto no por coma, El problema esta en que unos días el valor viene con dos decimales (94.10) y el excel lo entiende como texto y otros días viene con tres decimales (94.125) y el excel lo entiende como un numero de 5 digitos (94125).
Intente solucionarlo a traves de la siguientes funciones:
=+SI($B1>0;$B1/1000;SUSTITUIR($B1;".";",")) pero claro cuando se trata de texto (94.10) la celda me da error. He querido probarlo al reves: =+SI(B1=TEXT;sustituir(b1;".";",");b1/1000) pero también me da error.
¿alguna sugerencia para reslover el problema?
Gracias,
Miguel

Mangue

Masculino Cantidad de envíos : 6
Edad : 54
Ciudad - Pais : España
Version de Excel : 2003
Fecha de inscripción : 30/03/2009

Volver arriba Ir abajo

Re: condicionar una celda para obtener valor con 3 decimales

Mensaje por Mangue el Sáb Ene 21, 2012 6:52 pm

Solucionado, el amigo Canapone me dío la solución en otro foro y la pongo aquí por si a alguien le interesa:

=SI(ESTEXTO(B1);SUSTITUIR(B1;".";",");B1/1000)

Saludos,

Mangue

Masculino Cantidad de envíos : 6
Edad : 54
Ciudad - Pais : España
Version de Excel : 2003
Fecha de inscripción : 30/03/2009

Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.