............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

ayuda con promedios y un grafico

Ver el tema anterior Ver el tema siguiente Ir abajo

ayuda con promedios y un grafico

Mensaje por tenteck el Jue Mayo 08, 2008 3:22 pm

Hola necesito saber como poner una formula que me entregue el promedio de una columna.

en la columna hay 1000 datos pero necesito que me haga el promedio de 5 en 5 pero que sean los primeros 5 y que despues comience desde el 6 al 10 el otro promedio.

lo otro es saber como graficar esos 1000 datos pero por ejemplo si esos 5 datos representan 1 hora yo quiero que en el rotulo de los datos del eje x tenga las 24 horas osea 1 dia, pero que se vean los puntos que representan el dia, por ahora lo que tengo en el rotulo son numeros del 1 al 1000 pero necesito que aparezcan como dias, ojala y alguien me pueda ayudar, desde ya se lo agradezco

tenteck

Cantidad de envíos : 2
Fecha de inscripción : 08/05/2008

Volver arriba Ir abajo

Re: ayuda con promedios y un grafico

Mensaje por ioyama el Vie Mayo 09, 2008 3:34 am

Hola tenteck

La parte de los promedios la he solucionado añadiendo una columna con la siguiente fórmula =SI((FILA()-1)/5-ENTERO((FILA()-1)/5)=0;PROMEDIO(B2:B6);NOD())
(el número a restar a FILA() dependera de donde esté situado el quinto valor de la tabla (primer promedio). Le he puesto un formato condicional
usando la opción de Fórmula y =ESERROR($C2)=VERDADERO con texto en blanco (soló a efectos de visualización).

Para el eje X del gráfico he usado otra columna auxiliar con =SI(A2/60-ENTERO(A2/60)=0;A2/60;"")

Hoja1

 ABCD
1MinutosDatosPromedio horario 
2126  
3246  
4368  
5481  
66014,41
7729#N/A 
8847#N/A 
9966#N/A 
101089#N/A 
1112016,42
Spreadsheet Formulas
CellFormula
C6=SI((FILA()-1)/5-ENTERO((FILA()-1)/5)=0;PROMEDIO(B2:B6);NOD())
D6=SI(A6/60-ENTERO(A6/60)=0;A6/60;"")
C7=SI((FILA()-1)/5-ENTERO((FILA()-1)/5)=0;PROMEDIO(B3:B7);NOD())
D7=SI(A7/60-ENTERO(A7/60)=0;A7/60;"")
C8=SI((FILA()-1)/5-ENTERO((FILA()-1)/5)=0;PROMEDIO(B4:B8);NOD())
D8=SI(A8/60-ENTERO(A8/60)=0;A8/60;"")
C9=SI((FILA()-1)/5-ENTERO((FILA()-1)/5)=0;PROMEDIO(B5:B9);NOD())
D9=SI(A9/60-ENTERO(A9/60)=0;A9/60;"")
C10=SI((FILA()-1)/5-ENTERO((FILA()-1)/5)=0;PROMEDIO(B6:B10);NOD())
D10=SI(A10/60-ENTERO(A10/60)=0;A10/60;"")
C11=SI((FILA()-1)/5-ENTERO((FILA()-1)/5)=0;PROMEDIO(B7:B11);NOD())
D11=SI(A11/60-ENTERO(A11/60)=0;A11/60;"")


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

Intento adjuntar archivo pero algo hago mal, no obstante copia/pega el enlace siguiente y deberías llegar al fichero
[Tienes que estar registrado y conectado para ver este vínculo]

Un saludo desde Vitoria

ioyama
Moderador
Moderador

Masculino Cantidad de envíos : 128
Edad : 54
Ciudad - Pais : Vitoria (España)
Fecha de inscripción : 03/03/2008

Volver arriba Ir abajo

Re: ayuda con promedios y un grafico

Mensaje por tenteck el Miér Mayo 14, 2008 12:49 pm

Muchas gracias ioyama, gracias por tu tiempo y buena voluntad

tenteck

Cantidad de envíos : 2
Fecha de inscripción : 08/05/2008

Volver arriba Ir abajo

Re: ayuda con promedios y un grafico

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.