............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Formula para calculo Horas extras544

Formula para calculo Horas extras

Ver el tema anterior Ver el tema siguiente Ir abajo

Formula para calculo Horas extras

Mensaje por Jose BN el Sáb Abr 07, 2012 1:10 pm

Amigos quisiera solicitar la colaboración para tratar de encontrar un formula que me permita calcular la cantidad de horas extras, tomando como referencia que la jornada de trabajo es de 07:30 a.m hasta las 16:30 p.m. cuando la persona ingrese antes de las 07:30 a.m y/o después de las 16:30 me indique la cantidad de horas extras que realizó.

Ejemplo:
1. Si la persona ingresa a las 06:00 a.m. hasta las 16:30 p.m el resultado será 1.5 hrs extras
2. Si la persona labora de 07:30 a.m hasta las 21:00 p.m el resultado será 4.5 hrs extras

Agradezco la ayuda que me puedan brindar.

Saludes,

Jose
Archivos
Boleta Horas Extras1.xlsx No tienes los permisos para descargar los archivos.(18 KB) Descargado 135 veces

Jose BN

Masculino Cantidad de envíos: 56
Edad: 34
Ciudad - Pais: Costa Rica-San Jose
Version de Excel: 2003, Vista, 2007
Fecha de inscripción: 16/05/2011

Volver arriba Ir abajo

Re: Formula para calculo Horas extras

Mensaje por Cacho R el Sáb Abr 07, 2012 1:33 pm

Hola! Jose. Intenta en la celda E10 con:

= SI(B10=""; (C10<--"7:30") * ("7:30" - C10) + (D10>--"16:30") * (D10 - "16:30"); D10 - C10)

Además cambia el formato de las celdas de la columna E. En lugar del que tiene, pon:
[hh]:mm

De este modo cuando la suma del total de horas extras exceda las 24 no tendrás problemas por visualización incorrecta de dicho total.

Saludos, Cacho R.


Última edición por Cacho R el Sáb Abr 07, 2012 6:11 pm, editado 1 vez

Cacho R
Moderador
Moderador

Masculino Cantidad de envíos: 210
Ciudad - Pais: Buenos Aires
Version de Excel: Desde Multiplan (pre-Excel) hasta 2010
Fecha de inscripción: 29/06/2011

Volver arriba Ir abajo

Re: Formula para calculo Horas extras

Mensaje por Jose BN el Sáb Abr 07, 2012 4:48 pm

Hola! Cacho tu formula funciona muy bien, como recomiendas usar el formato (hh:mm) y como necesitaba expresar el resultado en numero lo he multiplicado por 24 esto por una necesidad de visualización:

=SI(C10="";"";SI(B10="x";D10-C10;(C10<--"7:30")*("7:30"-C10)+(D10>--"16:30")*(D10-"16:30"))*24)

Agradezco tu ayuda Cacho.

Saludes,

Jose BN

Jose BN

Masculino Cantidad de envíos: 56
Edad: 34
Ciudad - Pais: Costa Rica-San Jose
Version de Excel: 2003, Vista, 2007
Fecha de inscripción: 16/05/2011

Volver arriba Ir abajo

Re: Formula para calculo Horas extras

Mensaje por Cacho R el Sáb Abr 07, 2012 6:12 pm

¡Fue un gusto!

Cacho R
Moderador
Moderador

Masculino Cantidad de envíos: 210
Ciudad - Pais: Buenos Aires
Version de Excel: Desde Multiplan (pre-Excel) hasta 2010
Fecha de inscripción: 29/06/2011

Volver arriba Ir abajo

Re: Formula para calculo Horas extras

Mensaje por Jose BN el Miér Abr 11, 2012 8:04 pm

Hola! Cacho nuevamente solicito tu generosa colaboración.

Me resulta una nueva necesidad con la formula que me haz recomendado y esta debe cumplir la siguiente el siguiente escenario:

1. Cuando la persona ingresa antes de las 05:00 a.m. su jornada es de 7 horas laborales de lo contrario si ingresa de las 05:01 en adelante su jornada será de 8 hrs laborales. Actualmente estoy utilizando la siguiente formula para identificar la cantidad de hora laborales: =((D7-C7)*24)-SI(C7>=HORANUMERO("05:00:00 AM");8;7) por lo que mi dilema está en que no logro incorporarlo a la formula que recomiendas.



Agradezco los comentarios.

Saludes,

Jose

Jose BN

Masculino Cantidad de envíos: 56
Edad: 34
Ciudad - Pais: Costa Rica-San Jose
Version de Excel: 2003, Vista, 2007
Fecha de inscripción: 16/05/2011

Volver arriba Ir abajo

Re: Formula para calculo Horas extras

Mensaje por Cacho R el Sáb Abr 14, 2012 2:13 pm

Disculpa, José: ¡No había visto tu ampliación de consulta!...

Me confunde -de tu descripción- que estés hablando de jornadas laborales de 7 u 8 horas, cuando en lo inicialmente analizado, veíamos 9 horas (de 7:30 a 16:30 hs).

¿Resulta la presente, entonces, algo que no tiene relación con lo visto al comienzo de tu consulta?

Saludos, Cacho R.

Cacho R
Moderador
Moderador

Masculino Cantidad de envíos: 210
Ciudad - Pais: Buenos Aires
Version de Excel: Desde Multiplan (pre-Excel) hasta 2010
Fecha de inscripción: 29/06/2011

Volver arriba Ir abajo

Re: Formula para calculo Horas extras

Mensaje por Jose BN el Mar Abr 17, 2012 4:17 pm

Hola! Cacho lo que sucede es que por ejemplo, para efectos de mi práctica: si una persona ingresa a las 04:00 a.m. y terminar de laborar a las 16:30, el tiempo extra que debo compensarle a esta persona son 4.5 hrs, calculo que actulamente no logró que la formula que muy amablemente me facilitaste.

Para estos casos la jornada es de de 8 hrs y no de 9 como se planteó inicialmente, por lo que acudo a tu generosa ayuda para que la formula pueda identificar que si la hora de ingreso es antes de las 05:00 a.m calcule con base a una jornada de 8 y posterior a las 05:00 a.m contemple la jornada de 9.

Agradezco si esta a tu disposición colaborarme.

Saludes!

Jose

Jose BN

Masculino Cantidad de envíos: 56
Edad: 34
Ciudad - Pais: Costa Rica-San Jose
Version de Excel: 2003, Vista, 2007
Fecha de inscripción: 16/05/2011

Volver arriba Ir abajo

Re: Formula para calculo Horas extras

Mensaje por jqueralez04 el Jue Mayo 02, 2013 12:39 am

Hola! Buenas Noches!
necesito ayuda..., quiero calcular las horas extras diurnas que no pasen de las 7:00pm.
Ya tengo la formula para calcular las nocturnas(las empieza a contar despues de las 7;00pm

jqueralez04

Masculino Cantidad de envíos: 2
Edad: 32
Ciudad - Pais: Porlamar - Venezuela
Version de Excel: 2013
Fecha de inscripción: 02/05/2013

Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


Permisos de este foro:
No puedes responder a temas en este foro.