............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

BUSCARV "N aparición"

Ver el tema anterior Ver el tema siguiente Ir abajo

BUSCARV "N aparición"

Mensaje por Tatayayan el Mar Mayo 01, 2012 2:02 pm

Hola, la verdad no sé si se si alguien ya lo resolvió, se trata de lo siguiente: un “BUSCARV”, al cual le podamos indicar que aparición del dato buscado se requiere además lo que frecuentemente se indica.
En el adjunto se puede indicar el valor a buscar, columna deseada y LA APARICIÓN DESEADA (primera, o segunda o según se requiera).

Espero sea de utilidad.

Tatayayan
(Adrián Colazo)
Archivos
Buscarv N Aparición.xlsx No tienes los permisos para descargar los archivos.(10 KB) Descargado 21 veces
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: BUSCARV "N aparición"

Mensaje por GalileoGali el Mar Mayo 01, 2012 11:28 pm

BUSCARV MÚLTIPLE

 ABCDEFGHIJ
1NroAux1Aux2Aux3   Valor A Buscar Resultado
2b123   d 20
37234   Indique Columna  
4c345   4 Gali
57456   Indique Aparición 20
63567   2  
7d678      
85789      
958910      
10291011      
11f101112      
127111213      
134121314      
1410131415      
151141516      
161151617      
172161718      
182171819      
19d181920      
207192021      
219202122      
222212223      
237222324      
2410232425      
251242526      
2610252627      
Spreadsheet Formulas
CellFormula
J2=BUSCARV(H2;INDIRECTO("A"&SUMAPRODUCTO(K.ESIMO.MENOR(--((A2:A26=H2)*FILA(A1:A25));SUMAPRODUCTO(--(A2:A26<>H2))+H6)+1)&":D26");H4;FALSO)
J5=INDICE(A2:D26;K.ESIMO.MENOR(INDICE((A2:A26=H2)*(FILA(A2:A26)-FILA(A2)+1););CONTAR.SI(A2:A26;"<>"&H2)+H6);H4)


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

Otro aporte

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: BUSCARV "N aparición"

Mensaje por Tatayayan el Miér Mayo 02, 2012 10:04 am

Otra más:
=DESREF(A1;K.ESIMO.MENOR(INDICE(--(A2:A26=H2)*FILA(A1:A25);0);CONTAR.SI(A2:A26;"<>"&H2)+H6);H4-1)
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: BUSCARV "N aparición"

Mensaje por sailepaty el Jue Mayo 03, 2012 11:26 pm

Otra mas,

=INDICE(A2:D26;K.ESIMO.MENOR(SI(A2:A26=H2;FILA(A2:A26));H6)-FILA(A1);H4)

Saludos

_________________
I didn't ask to be Mexican I just got lucky!!!
avatar
sailepaty
Moderador
Moderador

Masculino Cantidad de envíos : 135
Edad : 54
Ciudad - Pais : Dallas, TX
Version de Excel : 2007 y 2010
Fecha de inscripción : 04/03/2008

Volver arriba Ir abajo

Re: BUSCARV "N aparición"

Mensaje por Tatayayan el Vie Mayo 04, 2012 1:12 pm

Hola sailepaty, la unica forma de "hacerla funcionar" a tu formula es introduciendo en forma matricial? por que de otra forma no puedo.
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: BUSCARV "N aparición"

Mensaje por Cacho R el Vie Mayo 04, 2012 8:02 pm

Quizás con un "retoque", Adrián:

=INDICE(A1:D26;K.ESIMO.MENOR(SI(A1:A26=H2;FILA(A1:A26));H6);H4)

Saludos, Cacho R.
avatar
Cacho R
Moderador
Moderador

Masculino Cantidad de envíos : 210
Ciudad - Pais : Buenos Aires
Version de Excel : Desde Multiplan (pre-Excel) hasta 2010
Fecha de inscripción : 29/06/2011

Volver arriba Ir abajo

Re: BUSCARV "N aparición"

Mensaje por sailepaty el Vie Mayo 04, 2012 8:07 pm

Tatayayan escribió:Hola sailepaty, la unica forma de "hacerla funcionar" a tu formula es introduciendo en forma matricial? por que de otra forma no puedo.

Efectivamente Adrian es matricial. Se me olvido hacer el comentario.

Saludos

_________________
I didn't ask to be Mexican I just got lucky!!!
avatar
sailepaty
Moderador
Moderador

Masculino Cantidad de envíos : 135
Edad : 54
Ciudad - Pais : Dallas, TX
Version de Excel : 2007 y 2010
Fecha de inscripción : 04/03/2008

Volver arriba Ir abajo

Re: BUSCARV "N aparición"

Mensaje por GalileoGali el Vie Mayo 04, 2012 11:47 pm

=INDICE(A2:D26;FILAS(A2:A26)-K.ESIMO.MAYOR(INDICE((A2:A26=H2)*(FILAS(A2:A26)-FILA(A1:A25)););H6);H4)

otra "sin entrada matricial", pero con algun recursos poco elegante para evitar contar "0" zeros.

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: BUSCARV "N aparición"

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.