............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Problema error en BUSCARV

Ver el tema anterior Ver el tema siguiente Ir abajo

Problema error en BUSCARV

Mensaje por palmacure el Miér Mayo 14, 2008 10:54 am

Hay alguien que pudiera ayudarme sobre el tema del Asunto.
He echo un pequeño archivo de excel, aqui dejo el enlace, no se cual de los dos funcionara, es la primera vez que utilizó esnips y apenas tengo idea de ingles.

[Tienes que estar registrado y conectado para ver este vínculo]

[Tienes que estar registrado y conectado para ver este vínculo]

Gracias.
Un saludo desde Córdoba.

palmacure

Cantidad de envíos : 24
Fecha de inscripción : 28/04/2008

Volver arriba Ir abajo

Re: Problema error en BUSCARV

Mensaje por palmacure el Miér Mayo 14, 2008 1:17 pm

no funcionan los llink, añado el siguiente, perdon pero mi ingles es muy corto.

[Tienes que estar registrado y conectado para ver este vínculo]

palmacure

Cantidad de envíos : 24
Fecha de inscripción : 28/04/2008

Volver arriba Ir abajo

Re: Problema error en BUSCARV

Mensaje por sailepaty el Miér Mayo 14, 2008 3:15 pm

No estoy seguro de haber entendido pero intenta con esto.

[D2] =Y($A2>0;ESNUMERO(COINCIDIR($B2;DATOS!$E$1:$E$3;0)))+0

Saludos

sailepaty
Moderador
Moderador

Masculino Cantidad de envíos : 135
Edad : 53
Ciudad - Pais : Dallas, TX
Version de Excel : 2007 y 2010
Fecha de inscripción : 04/03/2008

Volver arriba Ir abajo

Re: Problema error en BUSCARV

Mensaje por palmacure el Miér Mayo 14, 2008 3:57 pm

Muchas gracias Sailepaty, me sirve la función que has posteado.
Un saludo.

palmacure

Cantidad de envíos : 24
Fecha de inscripción : 28/04/2008

Volver arriba Ir abajo

Re: Problema error en BUSCARV

Mensaje por palmacure el Miér Mayo 14, 2008 4:32 pm

Al introducir la formula en los cuatro registro que tengo como prueba, ha ido perfecta, pero cuando copio la formula a las casillas donde no tengo ningún tipo de datos, me pone "0", e interesaría que dejara la celda en blanco, debido a que el maximo de registros a utilizar sería 500 y si solo utilizara 100, me imprimiría el resto de las hojas donde he copiado la formula.
Habría alguna manera para que mostrara el valor si se cumple

palmacure

Cantidad de envíos : 24
Fecha de inscripción : 28/04/2008

Volver arriba Ir abajo

Re: Problema error en BUSCARV

Mensaje por sailepaty el Miér Mayo 14, 2008 4:51 pm

Haber así,

=SI(Y($A2>0;ESNUMERO(COINCIDIR($B2;DATOS!$E$1:$E$3;0))),1,"")

Saludos

sailepaty
Moderador
Moderador

Masculino Cantidad de envíos : 135
Edad : 53
Ciudad - Pais : Dallas, TX
Version de Excel : 2007 y 2010
Fecha de inscripción : 04/03/2008

Volver arriba Ir abajo

Re: Problema error en BUSCARV

Mensaje por ioyama el Jue Mayo 15, 2008 2:33 am

Hola palmacure

Tu fórmula para evitar los FALSO y los #N/A

=SI(ESERROR(SI($A2>0;BUSCARV($B2;DATOS!$E$1:$F$3;2;0);""));"";SI($A2>0;BUSCARV($B2;DATOS!$E$1:$F$3;2;0);""))

puedes ver que añadiendo el tercer término a BUSCARV (en este caso las comillas, "") te evitas la aparición del texto FALSO y con la función ESERROR, combinada con SI evitamos los errores (en tu caso #N/A), simplemente a modo didáctico, ya que la opción del compañero Sailepaty funciona estupendamente.

Un saludo desde Vitoria

ioyama
Moderador
Moderador

Masculino Cantidad de envíos : 128
Edad : 53
Ciudad - Pais : Vitoria (España)
Fecha de inscripción : 03/03/2008

Volver arriba Ir abajo

Re: Problema error en BUSCARV

Mensaje por palmacure el Jue Mayo 15, 2008 4:38 am

Gracias Sailepaty y ioyama, funcionan ambas a la perfección.

Había intentado con ambas antes de postear, pero aún no domino las funciones anidadas y por lo que veo, añadiendo unas simples comillas, un 1, etc., da el resultado deseado.

No se que haría si no fuera por la labor desinteresada de los colaboradores de este foro, y es que a veces para una simple formula estoy muchas horas intentando que funcione.

Voy a ver si encuentro por ahí algo sobre las funciones anidadas, y a empollar un poco, porque veo que la ayuda de excel no esta para mucho.

Nuevamente gracias.

palmacure

Cantidad de envíos : 24
Fecha de inscripción : 28/04/2008

Volver arriba Ir abajo

Re: Problema error en BUSCARV

Mensaje por Contenido patrocinado Hoy a las 11:28 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.