............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

RELLENAR TABLA CON 2 VARIABLES

Ver el tema anterior Ver el tema siguiente Ir abajo

RELLENAR TABLA CON 2 VARIABLES

Mensaje por arturo2000 el Miér Jun 27, 2012 6:36 am

buenas a tod@s,

necesito rellenar la tabla del excel, de tal manera:
que me diga cada día lo que hace cada trabajador, teniendo en cuenta que no todos los trabajadores están todos los días.
lo he intentado con buscarv, anidando buscarv con un coincidir...pero no me sale.

gracias de antemano

[Tienes que estar registrado y conectado para ver este vínculo]

arturo2000

Masculino Cantidad de envíos : 5
Edad : 37
Ciudad - Pais : burgos
Version de Excel : 2007
Fecha de inscripción : 26/06/2012

Volver arriba Ir abajo

Re: RELLENAR TABLA CON 2 VARIABLES

Mensaje por GalileoGali el Miér Jun 27, 2012 7:06 am

En E2 podes pegar esta fòrmula...
=SI(E$1=$C2;$D2;"")

para luego estirarla hacia abajo y hacia la derecha

Hoja1

 ABCDEFG
1Nº VENDGUERRAFECHAHACE07/01/201214/01/201221/01/2012
211969ALEJANDRO07/01/2012TT  
311969ALEJANDRO14/01/2012T T 
44651AVELINO14/01/2012IT IT 
52917FERNANDEZ14/01/2012D D 
611969ALEJANDRO21/01/2012T  T
712838AMORIN21/01/2012V  V
84651AVELINO21/01/2012IT  IT
92917FERNANDEZ21/01/2012D  D
Spreadsheet Formulas
CellFormula
E2=SI(E$1=$C2;$D2;"")
F2=SI(F$1=$C2;$D2;"")
G2=SI(G$1=$C2;$D2;"")
E3=SI(E$1=$C3;$D3;"")
F3=SI(F$1=$C3;$D3;"")
G3=SI(G$1=$C3;$D3;"")
E4=SI(E$1=$C4;$D4;"")
F4=SI(F$1=$C4;$D4;"")
G4=SI(G$1=$C4;$D4;"")
E5=SI(E$1=$C5;$D5;"")
F5=SI(F$1=$C5;$D5;"")
G5=SI(G$1=$C5;$D5;"")
E6=SI(E$1=$C6;$D6;"")
F6=SI(F$1=$C6;$D6;"")
G6=SI(G$1=$C6;$D6;"")
E7=SI(E$1=$C7;$D7;"")
F7=SI(F$1=$C7;$D7;"")
G7=SI(G$1=$C7;$D7;"")
E8=SI(E$1=$C8;$D8;"")
F8=SI(F$1=$C8;$D8;"")
G8=SI(G$1=$C8;$D8;"")
E9=SI(E$1=$C9;$D9;"")
F9=SI(F$1=$C9;$D9;"")
G9=SI(G$1=$C9;$D9;"")


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: RELLENAR TABLA CON 2 VARIABLES

Mensaje por arturo2000 el Miér Jun 27, 2012 7:52 am

OK.
esto me valdría si lo necesitase por columnas.
yo tengo 1300 filas con estos datos, y necesito volcar esos datos a modo de tabla dinámica, es decir, tener todos los trabajdores listados en una columna, luego los días de trabajo, y en las celdas loq ue hace.

no sé subir un excel nuevo!!

arturo2000

Masculino Cantidad de envíos : 5
Edad : 37
Ciudad - Pais : burgos
Version de Excel : 2007
Fecha de inscripción : 26/06/2012

Volver arriba Ir abajo

Re: RELLENAR TABLA CON 2 VARIABLES

Mensaje por GalileoGali el Jue Jun 28, 2012 8:55 pm

tAL VEZ UN POCO TARDE, PERO
VEAMOS AHORA

Hoja1

 EFGHIJKL
1Nº VENDGUERRA07/01/201214/01/201221/01/201228/01/201204/02/201211/02/2012
211969ALEJANDROTTT   
34651AVELINO ITITITACOMPACOMP
42917FERNANDEZ DDDCUBRE 
512838AMORIN  VVTT
Spreadsheet Formulas
CellFormula
G2{=SI(ESNUMERO(COINCIDIR($F2&G$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F2&G$1;$B$2:$B$17&$C$2:$C$17;));"")}
H2{=SI(ESNUMERO(COINCIDIR($F2&H$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F2&H$1;$B$2:$B$17&$C$2:$C$17;));"")}
I2{=SI(ESNUMERO(COINCIDIR($F2&I$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F2&I$1;$B$2:$B$17&$C$2:$C$17;));"")}
J2{=SI(ESNUMERO(COINCIDIR($F2&J$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F2&J$1;$B$2:$B$17&$C$2:$C$17;));"")}
K2{=SI(ESNUMERO(COINCIDIR($F2&K$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F2&K$1;$B$2:$B$17&$C$2:$C$17;));"")}
L2{=SI(ESNUMERO(COINCIDIR($F2&L$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F2&L$1;$B$2:$B$17&$C$2:$C$17;));"")}
G3{=SI(ESNUMERO(COINCIDIR($F3&G$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F3&G$1;$B$2:$B$17&$C$2:$C$17;));"")}
H3{=SI(ESNUMERO(COINCIDIR($F3&H$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F3&H$1;$B$2:$B$17&$C$2:$C$17;));"")}
I3{=SI(ESNUMERO(COINCIDIR($F3&I$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F3&I$1;$B$2:$B$17&$C$2:$C$17;));"")}
J3{=SI(ESNUMERO(COINCIDIR($F3&J$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F3&J$1;$B$2:$B$17&$C$2:$C$17;));"")}
K3{=SI(ESNUMERO(COINCIDIR($F3&K$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F3&K$1;$B$2:$B$17&$C$2:$C$17;));"")}
L3{=SI(ESNUMERO(COINCIDIR($F3&L$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F3&L$1;$B$2:$B$17&$C$2:$C$17;));"")}
G4{=SI(ESNUMERO(COINCIDIR($F4&G$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F4&G$1;$B$2:$B$17&$C$2:$C$17;));"")}
H4{=SI(ESNUMERO(COINCIDIR($F4&H$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F4&H$1;$B$2:$B$17&$C$2:$C$17;));"")}
I4{=SI(ESNUMERO(COINCIDIR($F4&I$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F4&I$1;$B$2:$B$17&$C$2:$C$17;));"")}
J4{=SI(ESNUMERO(COINCIDIR($F4&J$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F4&J$1;$B$2:$B$17&$C$2:$C$17;));"")}
K4{=SI(ESNUMERO(COINCIDIR($F4&K$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F4&K$1;$B$2:$B$17&$C$2:$C$17;));"")}
L4{=SI(ESNUMERO(COINCIDIR($F4&L$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F4&L$1;$B$2:$B$17&$C$2:$C$17;));"")}
G5{=SI(ESNUMERO(COINCIDIR($F5&G$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F5&G$1;$B$2:$B$17&$C$2:$C$17;));"")}
H5{=SI(ESNUMERO(COINCIDIR($F5&H$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F5&H$1;$B$2:$B$17&$C$2:$C$17;));"")}
I5{=SI(ESNUMERO(COINCIDIR($F5&I$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F5&I$1;$B$2:$B$17&$C$2:$C$17;));"")}
J5{=SI(ESNUMERO(COINCIDIR($F5&J$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F5&J$1;$B$2:$B$17&$C$2:$C$17;));"")}
K5{=SI(ESNUMERO(COINCIDIR($F5&K$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F5&K$1;$B$2:$B$17&$C$2:$C$17;));"")}
L5{=SI(ESNUMERO(COINCIDIR($F5&L$1;$B$2:$B$17&$C$2:$C$17;));INDICE($D$2:$D$17;COINCIDIR($F5&L$1;$B$2:$B$17&$C$2:$C$17;));"")}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: RELLENAR TABLA CON 2 VARIABLES

Mensaje por arturo2000 el Lun Jul 02, 2012 7:01 am

ok. gracias!!

probaré a ver si soy capaz de reproducirla con mis datos.
lo de las fórmulas matriciales es igual para todos los excel??, es que no me sale.

arturo2000

Masculino Cantidad de envíos : 5
Edad : 37
Ciudad - Pais : burgos
Version de Excel : 2007
Fecha de inscripción : 26/06/2012

Volver arriba Ir abajo

Re: RELLENAR TABLA CON 2 VARIABLES

Mensaje por arturo2000 el Mar Jul 03, 2012 5:04 am

MIL GRACIAS
MIL MILLONES DE GRACIAS

VIVA TÚ Y TU SABIDURÍA!!!!!!!!!!

OLE Y OLE!

arturo2000

Masculino Cantidad de envíos : 5
Edad : 37
Ciudad - Pais : burgos
Version de Excel : 2007
Fecha de inscripción : 26/06/2012

Volver arriba Ir abajo

Re: RELLENAR TABLA CON 2 VARIABLES

Mensaje por arturo2000 el Mar Jul 03, 2012 11:31 am

teóricamente lo tengo claro, sé lo que hacen las fómulas que has utilizado y el hecho de anidarlas para que no den como resultado algún tipo de error...
lo que me tiene perplejo es la fórmula ESNUMERO dentro de un SI y sin compararla dentro de la premisa con nada.
sé que lo has hecho para que no dé #n/a...

en fin aún voy en pañales en el excel.

arturo2000

Masculino Cantidad de envíos : 5
Edad : 37
Ciudad - Pais : burgos
Version de Excel : 2007
Fecha de inscripción : 26/06/2012

Volver arriba Ir abajo

Re: RELLENAR TABLA CON 2 VARIABLES

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.