............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Evaluar frecuencia de aparicion

Ver el tema anterior Ver el tema siguiente Ir abajo

Evaluar frecuencia de aparicion

Mensaje por Rasputín el Sáb Mayo 17, 2008 9:05 pm

Saludos,
Soy nuevo en Excel 2007 y estoy intentando conseguir unas fórmulas, pero no sé muy bien cómo hacerlo, a ver si me podríais ayudar con las formulas que necesito para sacar lo siguiente:

Tengo una serie de elementos que se repiten en la lista:

A
D
D
A
C
A
D
C
C

Lo que quiero es obtener el número de celdas que hay entre la repetición de un elemento, es decir, entre la primera A y la segunda A hay 2 celdas intermedias, mientras que entre la tercera A y la segunda A hay 1 celda. Sin embargo entre la primera D y la segunda D hay 0 celdas, y entre la tercera D y la segunda D hay 3 celdas:

A
D
D 0
A 2
C
A 1
D 3
C 2
C 0

Una vez que tengo estos resultados,

0
2
1
3
2
0

vemos que el 0 y el 2 han salido dos veces, mientras que el 1 y el 3 han salido una vez.

Ahora quiero ordenarlos, o sacarlos en otra columna como resultados,

0
1
2
3





e indicar el número de veces que ha salido cada número:

0 2 (veces)
1 1
2 2
3 1


Y ya con estos resultados sacar un porcentaje:

0 2 33'3%
1 1 16'6%
2 2 33'3%
3 1 16'6%

Muchas gracias de antemano a cualquier ayuda o idea que me puedan aportar.

Un saludo,
Rasputin

Rasputín

Cantidad de envíos : 1
Fecha de inscripción : 17/02/2008

Volver arriba Ir abajo

Re: Evaluar frecuencia de aparicion

Mensaje por GalileoGali el Sáb Mayo 17, 2008 9:30 pm

Hoja1

 ABCDE
3Elementos1era EvalListaCant Veces%
4A 1125%
5D 2250%
6D03125%
7A2   
8C    
9A1   
10D3   
11C2   
12C0   
13    100%
Spreadsheet Formulas
CellFormula
C4=SI(CONTAR($C$3:C3)>=MAX($B$4:$B$12);"";FILA()-FILA($A$3))
D4=SI(N(C4);CONTAR.SI($B$4:$B$12;C4);"")
E4=SI(N(D4);D4/SUMA($D$4:$D$12);"")
B5=SI(CONTAR.SI($A$4:A4;A5)>0;FILA(A5)-MAX(INDICE(($A$4:A4=A5)*FILA($A$4:A4);0))-1;"")
C5=SI(CONTAR($C$3:C4)>=MAX($B$4:$B$12);"";FILA()-FILA($A$3))
D5=SI(N(C5);CONTAR.SI($B$4:$B$12;C5);"")
E5=SI(N(D5);D5/SUMA($D$4:$D$12);"")
B6=SI(CONTAR.SI($A$4:A5;A6)>0;FILA(A6)-MAX(INDICE(($A$4:A5=A6)*FILA($A$4:A5);0))-1;"")
C6=SI(CONTAR($C$3:C5)>=MAX($B$4:$B$12);"";FILA()-FILA($A$3))
D6=SI(N(C6);CONTAR.SI($B$4:$B$12;C6);"")
E6=SI(N(D6);D6/SUMA($D$4:$D$12);"")
B7=SI(CONTAR.SI($A$4:A6;A7)>0;FILA(A7)-MAX(INDICE(($A$4:A6=A7)*FILA($A$4:A6);0))-1;"")
C7=SI(CONTAR($C$3:C6)>=MAX($B$4:$B$12);"";FILA()-FILA($A$3))
D7=SI(N(C7);CONTAR.SI($B$4:$B$12;C7);"")
E7=SI(N(D7);D7/SUMA($D$4:$D$12);"")
B8=SI(CONTAR.SI($A$4:A7;A8)>0;FILA(A8)-MAX(INDICE(($A$4:A7=A8)*FILA($A$4:A7);0))-1;"")
C8=SI(CONTAR($C$3:C7)>=MAX($B$4:$B$12);"";FILA()-FILA($A$3))
D8=SI(N(C8);CONTAR.SI($B$4:$B$12;C8);"")
E8=SI(N(D8);D8/SUMA($D$4:$D$12);"")
B9=SI(CONTAR.SI($A$4:A8;A9)>0;FILA(A9)-MAX(INDICE(($A$4:A8=A9)*FILA($A$4:A8);0))-1;"")
C9=SI(CONTAR($C$3:C8)>=MAX($B$4:$B$12);"";FILA()-FILA($A$3))
D9=SI(N(C9);CONTAR.SI($B$4:$B$12;C9);"")
E9=SI(N(D9);D9/SUMA($D$4:$D$12);"")
B10=SI(CONTAR.SI($A$4:A9;A10)>0;FILA(A10)-MAX(INDICE(($A$4:A9=A10)*FILA($A$4:A9);0))-1;"")
C10=SI(CONTAR($C$3:C9)>=MAX($B$4:$B$12);"";FILA()-FILA($A$3))
D10=SI(N(C10);CONTAR.SI($B$4:$B$12;C10);"")
E10=SI(N(D10);D10/SUMA($D$4:$D$12);"")
B11=SI(CONTAR.SI($A$4:A10;A11)>0;FILA(A11)-MAX(INDICE(($A$4:A10=A11)*FILA($A$4:A10);0))-1;"")
C11=SI(CONTAR($C$3:C10)>=MAX($B$4:$B$12);"";FILA()-FILA($A$3))
D11=SI(N(C11);CONTAR.SI($B$4:$B$12;C11);"")
E11=SI(N(D11);D11/SUMA($D$4:$D$12);"")
B12=SI(CONTAR.SI($A$4:A11;A12)>0;FILA(A12)-MAX(INDICE(($A$4:A11=A12)*FILA($A$4:A11);0))-1;"")
C12=SI(CONTAR($C$3:C11)>=MAX($B$4:$B$12);"";FILA()-FILA($A$3))
D12=SI(N(C12);CONTAR.SI($B$4:$B$12;C12);"")
E12=SI(N(D12);D12/SUMA($D$4:$D$12);"")
E13=SUMA(E4:E12)


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Evaluar frecuencia de aparicion

Mensaje por GalileoGali el Sáb Mayo 17, 2008 9:33 pm

Esta otra Evaluacion, anticipa la proxima pregunta, de Rasputin....

Hoja1

 AB
16Elementos2da Eval
17A1
18D1
19D1
20A3
21C1
22A2
23D4
24C3
25C1
Spreadsheet Formulas
CellFormula
B17=SI(CONTAR.SI($A$17:A17;A17)=1;1;K.ESIMO.MAYOR(INDICE(($A$17:A17=A17)*(FILA($A$17:A17)-FILA($A$17)+1););1)-K.ESIMO.MAYOR(INDICE(($A$17:A17=A17)*(FILA($A$17:A17)-FILA($A$17)+1););2))
B18=SI(CONTAR.SI($A$17:A18;A18)=1;1;K.ESIMO.MAYOR(INDICE(($A$17:A18=A18)*(FILA($A$17:A18)-FILA($A$17)+1););1)-K.ESIMO.MAYOR(INDICE(($A$17:A18=A18)*(FILA($A$17:A18)-FILA($A$17)+1););2))
B19=SI(CONTAR.SI($A$17:A19;A19)=1;1;K.ESIMO.MAYOR(INDICE(($A$17:A19=A19)*(FILA($A$17:A19)-FILA($A$17)+1););1)-K.ESIMO.MAYOR(INDICE(($A$17:A19=A19)*(FILA($A$17:A19)-FILA($A$17)+1););2))
B20=SI(CONTAR.SI($A$17:A20;A20)=1;1;K.ESIMO.MAYOR(INDICE(($A$17:A20=A20)*(FILA($A$17:A20)-FILA($A$17)+1););1)-K.ESIMO.MAYOR(INDICE(($A$17:A20=A20)*(FILA($A$17:A20)-FILA($A$17)+1););2))
B21=SI(CONTAR.SI($A$17:A21;A21)=1;1;K.ESIMO.MAYOR(INDICE(($A$17:A21=A21)*(FILA($A$17:A21)-FILA($A$17)+1););1)-K.ESIMO.MAYOR(INDICE(($A$17:A21=A21)*(FILA($A$17:A21)-FILA($A$17)+1););2))
B22=SI(CONTAR.SI($A$17:A22;A22)=1;1;K.ESIMO.MAYOR(INDICE(($A$17:A22=A22)*(FILA($A$17:A22)-FILA($A$17)+1););1)-K.ESIMO.MAYOR(INDICE(($A$17:A22=A22)*(FILA($A$17:A22)-FILA($A$17)+1););2))
B23=SI(CONTAR.SI($A$17:A23;A23)=1;1;K.ESIMO.MAYOR(INDICE(($A$17:A23=A23)*(FILA($A$17:A23)-FILA($A$17)+1););1)-K.ESIMO.MAYOR(INDICE(($A$17:A23=A23)*(FILA($A$17:A23)-FILA($A$17)+1););2))
B24=SI(CONTAR.SI($A$17:A24;A24)=1;1;K.ESIMO.MAYOR(INDICE(($A$17:A24=A24)*(FILA($A$17:A24)-FILA($A$17)+1););1)-K.ESIMO.MAYOR(INDICE(($A$17:A24=A24)*(FILA($A$17:A24)-FILA($A$17)+1););2))
B25=SI(CONTAR.SI($A$17:A25;A25)=1;1;K.ESIMO.MAYOR(INDICE(($A$17:A25=A25)*(FILA($A$17:A25)-FILA($A$17)+1););1)-K.ESIMO.MAYOR(INDICE(($A$17:A25=A25)*(FILA($A$17:A25)-FILA($A$17)+1););2))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Evaluar frecuencia de aparicion

Mensaje por GalileoGali el Sáb Mayo 17, 2008 9:36 pm

Hoja1

 ABCDE
16Elementos2da EvalListaCant Veces%
17A11556%
18D12111%
19D13222%
20A34111%
21C1   
22A2   
23D4   
24C3   
25C1   
26    100%
Spreadsheet Formulas
CellFormula
C17=SI(CONTAR($C$16:C16)>=MAX($B$17:$B$25);"";FILA()-FILA($A$16))
D17=SI(N(C17);CONTAR.SI($B$17:$B$25;C17);"")
E17=SI(N(D17);D17/SUMA($D$17:$D$25);"")
C18=SI(CONTAR($C$16:C17)>=MAX($B$17:$B$25);"";FILA()-FILA($A$16))
D18=SI(N(C18);CONTAR.SI($B$17:$B$25;C18);"")
E18=SI(N(D18);D18/SUMA($D$17:$D$25);"")
C19=SI(CONTAR($C$16:C18)>=MAX($B$17:$B$25);"";FILA()-FILA($A$16))
D19=SI(N(C19);CONTAR.SI($B$17:$B$25;C19);"")
E19=SI(N(D19);D19/SUMA($D$17:$D$25);"")
C20=SI(CONTAR($C$16:C19)>=MAX($B$17:$B$25);"";FILA()-FILA($A$16))
D20=SI(N(C20);CONTAR.SI($B$17:$B$25;C20);"")
E20=SI(N(D20);D20/SUMA($D$17:$D$25);"")
C21=SI(CONTAR($C$16:C20)>=MAX($B$17:$B$25);"";FILA()-FILA($A$16))
D21=SI(N(C21);CONTAR.SI($B$17:$B$25;C21);"")
E21=SI(N(D21);D21/SUMA($D$17:$D$25);"")
C22=SI(CONTAR($C$16:C21)>=MAX($B$17:$B$25);"";FILA()-FILA($A$16))
D22=SI(N(C22);CONTAR.SI($B$17:$B$25;C22);"")
E22=SI(N(D22);D22/SUMA($D$17:$D$25);"")
C23=SI(CONTAR($C$16:C22)>=MAX($B$17:$B$25);"";FILA()-FILA($A$16))
D23=SI(N(C23);CONTAR.SI($B$17:$B$25;C23);"")
E23=SI(N(D23);D23/SUMA($D$17:$D$25);"")
C24=SI(CONTAR($C$16:C23)>=MAX($B$17:$B$25);"";FILA()-FILA($A$16))
D24=SI(N(C24);CONTAR.SI($B$17:$B$25;C24);"")
E24=SI(N(D24);D24/SUMA($D$17:$D$25);"")
C25=SI(CONTAR($C$16:C24)>=MAX($B$17:$B$25);"";FILA()-FILA($A$16))
D25=SI(N(C25);CONTAR.SI($B$17:$B$25;C25);"")
E25=SI(N(D25);D25/SUMA($D$17:$D$25);"")
E26=SUMA(E17:E25)


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

Resuelta la Primera columna, las otras...

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Evaluar frecuencia de aparicion

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.