............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Comparar Listas y devolver datos cruzados

Ver el tema anterior Ver el tema siguiente Ir abajo

Comparar Listas y devolver datos cruzados

Mensaje por Patoruzú el Dom Mayo 18, 2008 11:33 am

Espero que alguien pueda echarme una mano con esta fórmula.

Lo que necesito es:


Por un lado, una fórmula que me compare las columnas A y C y busque si una referencia de la columna A está también el columna C, y si es así, que me ponga, la referencia de la columna A y el precio de la columna B asociado a la referencia de la columna A.
Por otro, lado, sería lo mismo, es decir que localice las referencias comunes (columna A y C), pero en este caso, cuando localice dos referencias iguales, entonces que multiplique los precios asociados de ambas columnas. Ej:ref 1423 Pvp 10+10

Patoruzú

Cantidad de envíos : 2
Fecha de inscripción : 17/02/2008

Volver arriba Ir abajo

Re: Comparar Listas y devolver datos cruzados

Mensaje por GalileoGali el Dom Mayo 18, 2008 11:35 am

A ver esto:


Hoja1

 ABCDEFG
1DescripciónPVPPVPa+PVPb DescripciónPVPValor paraA
214231020 123470 
3142220  567880 
4554630  78914040
578914080 77775050
6777750100 88886060
7888860120 14231010
8999970  55558080
9555580160    
Spreadsheet Formulas
CellFormula
C2=SI(ESNUMERO(COINCIDIR(A2;$E$2:$E$9;));INDICE($F$2:$F$9;COINCIDIR(A2;$E$2:$E$9;))+B2;"")
G2=SI(ESNUMERO(COINCIDIR(E2;$A$2:$A$9;));INDICE($B$2:$B$9;COINCIDIR(E2;$A$2:$A$9;));"")
C3=SI(ESNUMERO(COINCIDIR(A3;$E$2:$E$9;));INDICE($F$2:$F$9;COINCIDIR(A3;$E$2:$E$9;))+B3;"")
G3=SI(ESNUMERO(COINCIDIR(E3;$A$2:$A$9;));INDICE($B$2:$B$9;COINCIDIR(E3;$A$2:$A$9;));"")
C4=SI(ESNUMERO(COINCIDIR(A4;$E$2:$E$9;));INDICE($F$2:$F$9;COINCIDIR(A4;$E$2:$E$9;))+B4;"")
G4=SI(ESNUMERO(COINCIDIR(E4;$A$2:$A$9;));INDICE($B$2:$B$9;COINCIDIR(E4;$A$2:$A$9;));"")
C5=SI(ESNUMERO(COINCIDIR(A5;$E$2:$E$9;));INDICE($F$2:$F$9;COINCIDIR(A5;$E$2:$E$9;))+B5;"")
G5=SI(ESNUMERO(COINCIDIR(E5;$A$2:$A$9;));INDICE($B$2:$B$9;COINCIDIR(E5;$A$2:$A$9;));"")
C6=SI(ESNUMERO(COINCIDIR(A6;$E$2:$E$9;));INDICE($F$2:$F$9;COINCIDIR(A6;$E$2:$E$9;))+B6;"")
G6=SI(ESNUMERO(COINCIDIR(E6;$A$2:$A$9;));INDICE($B$2:$B$9;COINCIDIR(E6;$A$2:$A$9;));"")
C7=SI(ESNUMERO(COINCIDIR(A7;$E$2:$E$9;));INDICE($F$2:$F$9;COINCIDIR(A7;$E$2:$E$9;))+B7;"")
G7=SI(ESNUMERO(COINCIDIR(E7;$A$2:$A$9;));INDICE($B$2:$B$9;COINCIDIR(E7;$A$2:$A$9;));"")
C8=SI(ESNUMERO(COINCIDIR(A8;$E$2:$E$9;));INDICE($F$2:$F$9;COINCIDIR(A8;$E$2:$E$9;))+B8;"")
G8=SI(ESNUMERO(COINCIDIR(E8;$A$2:$A$9;));INDICE($B$2:$B$9;COINCIDIR(E8;$A$2:$A$9;));"")
C9=SI(ESNUMERO(COINCIDIR(A9;$E$2:$E$9;));INDICE($F$2:$F$9;COINCIDIR(A9;$E$2:$E$9;))+B9;"")


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.