............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Ayuda con Pesos y Dolares

Ver el tema anterior Ver el tema siguiente Ir abajo

Ayuda con Pesos y Dolares

Mensaje por cecp el Mar Oct 23, 2012 8:54 pm

Com podria diferenciar Pesos de Dolares que se encuentran en una misma columna numerica con formato Moneda

Algunas celdas de la columna estan formatiadas en $ y otras celdas en USD.

cecp

Masculino Cantidad de envíos : 2
Edad : 36
Ciudad - Pais : Santiago
Version de Excel : 2007
Fecha de inscripción : 23/10/2012

Volver arriba Ir abajo

Re: Ayuda con Pesos y Dolares

Mensaje por GalileoGali el Sáb Oct 27, 2012 7:58 am

Disponer datos en columnas en Excel, no implica ninguna conclusión, pero la práctica lleva a pensar que esa "agrupación" contiene elementos homogéneos, dispuestos así, para facilitar las operaciones.
Dolares y pesos no son homogeneos (salvo aplicar la algun coeficiente de conversion basado en cotizacion). Ahora bien, a la hora de distinguir que celdas son pasibles de la conversion y cuales no, la diferencia de formato, no deviene en distintor apreciable via formulas. (se podria agregar una columna para yuxtaponer el simbolo de moneda y de tal manera, sí contar con un distintor con que operar)-


Última edición por GalileoGali el Lun Oct 29, 2012 10:20 pm, editado 1 vez

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Ayuda con Pesos y Dolares

Mensaje por cecp el Lun Oct 29, 2012 10:11 pm

Clarisimo GalileoGali

Muchas Gracias

cecp

Masculino Cantidad de envíos : 2
Edad : 36
Ciudad - Pais : Santiago
Version de Excel : 2007
Fecha de inscripción : 23/10/2012

Volver arriba Ir abajo

Re: Ayuda con Pesos y Dolares

Mensaje por moises melgar el Mar Nov 06, 2012 8:35 pm

Saludos

Las columnas Auxiliares es lo mas adecuado por la facilidad para poder diferenciarlos durante los cálculos.

Pero para aportar al tema, una manera de diferenciar los distintos formatos (formato de celdas) que le designamos a las celdas, es por medio del código:

Código:
range("aquí el rango").NumberFormat

por ejemplo:
el siguientes código crea una formula la cual devuelve el formato de celda de la celda seleccionada.

Código:
Function Formato(celda)
Formato = celda.NumberFormat
End Function
Por ejemplo si en A1 escribe algún valor y en B1 escribe =Formato(A1),en B1 le aparecerá el formato en el que se encuentra la celda A1, pero hay que re calcular la hoja para que se actualizan sus valores.

También en un bucle para recoger un rango de celdas y los datos obtenidos usarlas para X función, etc, etc.

moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 512
Edad : 28
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: Ayuda con Pesos y Dolares

Mensaje por GalileoGali el Mar Nov 06, 2012 9:34 pm

Ya que moises trae esta posibilidad, traigo otra con la volatilidad necesaria

Hoja1

 ABCD
12345 Dol 2690,21Dol
215567 Pes 15577,56Pes
310,56 Pes   
4345,21 Dol   
5    
Spreadsheet Formulas
CellFormula
C1=SUMAPRODUCTO((DERECHA($A$1:$A$4;3)=D1)*IZQUIERDA($A$1:$A$4;LARGO($A$1:$A$4)-4))
C2=SUMAPRODUCTO((DERECHA($A$1:$A$4;3)=D2)*IZQUIERDA($A$1:$A$4;LARGO($A$1:$A$4)-4))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


A fin de hacer más versátil la fórmula convendria complementarla con la creacion de una Referencia a Rango Dinámico, para el rango a sumar. De todas formas si se requiere que haya celdas vacias intermedias, habra que recurrir a un SI(


_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Ayuda con Pesos y Dolares

Mensaje por Contenido patrocinado Hoy a las 3:15 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.