............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

BUSCARV con Dos condiciones (o mas)

Ver el tema anterior Ver el tema siguiente Ir abajo

BUSCARV con Dos condiciones (o mas)

Mensaje por GalileoGali el Mar Mayo 27, 2008 6:27 pm

Hoja1

 ABCDEF
1A134   
2S135   
3D136 S38
4F237 2 
5S238   
6H239   
Spreadsheet Formulas
CellFormula
F3{=BUSCARV(E3;INDICE(SI(B1:B6=E4;A1:C6);0);3;)}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

Si alguno entiende como funciona la formula, pregunte....

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: BUSCARV con Dos condiciones (o mas)

Mensaje por light2953 el Mar Jun 10, 2008 3:00 pm

No me ha funcionado y lo he copiado exactamente igual. El error parece que está en la fórmula INDICE, ¿tiene algo que ver que la versión sea la 2003?

Gracias por adelantado

light2953

Cantidad de envíos : 1
Fecha de inscripción : 10/06/2008

Volver arriba Ir abajo

Re: BUSCARV con Dos condiciones (o mas)

Mensaje por samros el Mar Jun 10, 2008 5:41 pm

Esta misma formula funciona con =SUMAPRODUCTO((A1:A6=E3)*(B1:B6=E4)*(C1:C6))
En realidad le he encontrado mucha utilidad a SUMAPRODUCTO, antes usaba mucho las matriciales pero las he sustituido con muy buenos resultados.

samros

Masculino Cantidad de envíos : 115
Edad : 39
Ciudad - Pais : Guadalajara Jalisco Mexico
Version de Excel : 2003
Fecha de inscripción : 15/05/2008

http://accessam@mejorforo.net

Volver arriba Ir abajo

Re: BUSCARV con Dos condiciones (o mas)

Mensaje por GalileoGali el Mar Jun 10, 2008 5:56 pm

Para Light2953: te pediria que subas (upload) tu archivo Test, a algun servidor publico gratuito, como rapidshare o esnips y despues pegues el vinculo en este hilo, asi podremos ver tus formulas y tratar de aportarte alguna solucion.
Hasta Pronto
y Bienvenido
o Bienvenido y hasta Pronto, tal vez mejor....

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: BUSCARV con Dos condiciones (o mas)

Mensaje por FGALVIS el Lun Jun 16, 2008 9:47 pm

Galileo, tengo una duda como se haria para utilizar esta formula con 3 condiciones, si me puedes ayudar te lo agradeceria...

FG

FGALVIS

Cantidad de envíos : 1
Fecha de inscripción : 16/06/2008

Volver arriba Ir abajo

Re: BUSCARV con Dos condiciones (o mas)

Mensaje por jbf99 el Mar Jun 17, 2008 4:34 am

samros escribió:Esta misma formula funciona con =SUMAPRODUCTO((A1:A6=E3)*(B1:B6=E4)*(C1:C6))
En realidad le he encontrado mucha utilidad a SUMAPRODUCTO, antes usaba mucho las matriciales pero las he sustituido con muy buenos resultados.

Ojo , esa formula no devuelve el mismo resultado , ahi que especificar que solo es valida cuando no existe posibilidad de resultados repetidos , buscarv devuelve el primer valor que encuentra que cumple con las condiciones mientras q sumaproducto suma el resultado de todos los que lo cumplen. Cada uno tiene una utilidad y uso diferente.


=BUSCARV(E3;SI(B1:B6=E4;A1:C6);3;)

Es matricial , Se introduce con CTRL+SHIFT+ENTER

Un saludo

jbf99
Moderador
Moderador

Masculino Cantidad de envíos : 4
Edad : 47
Ciudad - Pais : Madrid (España)
Fecha de inscripción : 02/06/2008

Volver arriba Ir abajo

Re: BUSCARV con Dos condiciones (o mas)

Mensaje por sailepaty el Mar Jun 17, 2008 9:56 am

FGALVIS escribió:Galileo, tengo una duda como se haria para utilizar esta formula con 3 condiciones, si me puedes ayudar te lo agradeceria...
FG

Establezcamos algunos parámetros.

Tabla de datos A2:D500
Primer valor a comparar en E2
Segundo valor a comparar F2
Tercer valor a comparar en G2
# de columna del valor a devolver 4

Matricial confirmar con Ctrl+Shift+Enter
=BUSCARV(E2,IF((B2:B500=F2)*(C2:C500=G2),A2:D500),4)


No Matricial confirmar solo con Enter
=INDICE(D2:D500,COINCIDIR(1,INDICE((A2:A500=E2)*(B2:B500=F2)*(C2:C500=G2),0),0))


Saludos

sailepaty
Moderador
Moderador

Masculino Cantidad de envíos : 135
Edad : 53
Ciudad - Pais : Dallas, TX
Version de Excel : 2007 y 2010
Fecha de inscripción : 04/03/2008

Volver arriba Ir abajo

Re: BUSCARV con Dos condiciones (o mas)

Mensaje por Joel Bertín Murrieta Domí el Vie Jun 27, 2008 9:08 pm

ES CUESTION DE SUSUTITUIR ";" POR "," EDITAR LA FORMULA Y DARLE ENTRADA CON CTRL+SHIFT+ENTER

Joel Bertín Murrieta Domí

Masculino Cantidad de envíos : 2
Edad : 50
Ciudad - Pais : Navojoa, Sonora, México
Version de Excel : xp 2003-2007
Fecha de inscripción : 27/06/2008

Volver arriba Ir abajo

Re: BUSCARV con Dos condiciones (o mas)

Mensaje por Joel Bertín Murrieta Domí el Vie Jun 27, 2008 9:10 pm

light2953 escribió:No me ha funcionado y lo he copiado exactamente igual. El error parece que está en la fórmula INDICE, ¿tiene algo que ver que la versión sea la 2003?

Gracias por adelantado

ES CUESTION DE SUSUTITUIR ";" POR "," EDITAR LA FORMULA Y DARLE ENTRADA CON CTRL+SHIFT+ENTER

Joel Bertín Murrieta Domí

Masculino Cantidad de envíos : 2
Edad : 50
Ciudad - Pais : Navojoa, Sonora, México
Version de Excel : xp 2003-2007
Fecha de inscripción : 27/06/2008

Volver arriba Ir abajo

Re: BUSCARV con Dos condiciones (o mas)

Mensaje por Contenido patrocinado Hoy a las 11:27 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.