............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Introducir fórmulas mediante código

Ver el tema anterior Ver el tema siguiente Ir abajo

Introducir fórmulas mediante código

Mensaje por Aretradeser el Miér Abr 09, 2014 3:04 pm

Buenas tardes,
Utilizo un formulario para el registro de datos (de las columnas "A" a la "N"). Pero necesito añedirle que, a la vez que va ingresando estos datos, ingrese unas fórmulas en unas columnas determinas cada vez que se ingresa un registro. Las fórmulas son las siguientes:
1º.- =SI(A2="";"";SI(Y($O$1-$I2>=0;$O$1-$I2<=15;$J2="");"X";"")) Debe ir en la columna "Q"
2ª.- =SI(A2="";"";SI(Y($O$1-$I2>15;$O$1-$I2<=20;$J2="");"X";"")) Debe ir en la columna "P"
3ª.- =SI(A2="";"";SI(Y($O$1-$I2>20;$J2="");"X";"")) Debe ir en la columna "O"
4ª.-=SI(Y($J2-$I2>=0;$J2-$I2<=15;$J2<>"");"X";"") Debe ir en la columna "R"
5ª.- =SI(Y($J2-$I2>15;$J2-$I2<=20;$J2<>"");"X";"") Debe ir en la columna "S"
6ª.- =SI(Y($J2-$I2>20;$J2<>"");"X";"") Debe ir en la columna "T"
Muchas gracias.
Saludos

Aretradeser

Masculino Cantidad de envíos : 6
Edad : 59
Ciudad - Pais : España
Version de Excel : 2003
Fecha de inscripción : 26/12/2012

Volver arriba Ir abajo

Re: Introducir fórmulas mediante código

Mensaje por Tatayayan el Jue Abr 10, 2014 12:40 pm

Hola, por ejemplo éste código inserta la fórmula en Q2

Sub InsertarFormula()
Range("Q2").FormulaLocal = "=SI(A2="""";"""";SI(Y($O$1-$I2>=0;$O$1-$I2<=15;$J2="""");""X"";""""))"
End Sub
avatar
Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: Introducir fórmulas mediante código

Mensaje por Aretradeser el Vie Abr 11, 2014 1:59 pm

Muchas gracias. Me ha servido perfectamente. Pdemos dar la consulta por cerrada y contestada a plena satisfacción.

Aretradeser

Masculino Cantidad de envíos : 6
Edad : 59
Ciudad - Pais : España
Version de Excel : 2003
Fecha de inscripción : 26/12/2012

Volver arriba Ir abajo

Re: Introducir fórmulas mediante código

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.