............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Busqueda por Coordenadas

Ver el tema anterior Ver el tema siguiente Ir abajo

Busqueda por Coordenadas

Mensaje por samros el Miér Jun 11, 2008 2:23 pm

Anexo estas formulas para hacer busquedas como si fueran coordenadas.
De seguro a mas de alguno le será util.

Se trata de hace una busqueda en la tabla con tan solo cambiar las letras que estan en J8 y J9

Saludos.



Excel Jeanie HTMLHoja1

 BCDEFGHIJK
5 Buscar por coordenadas.  
6          
7          
8 ABCDE  I 
9F9284133681  D 
10G97615393  15 
11H566728078    
12I5384771587    
13J13287520100    
14          
15          
Spreadsheet Formulas
CellFormula
J10=INDICE(C9:G13,COINCIDIR(J8,B9:B13,0),COINCIDIR(J9,C8:G8,0))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


samros

Masculino Cantidad de envíos : 115
Edad : 39
Ciudad - Pais : Guadalajara Jalisco Mexico
Version de Excel : 2003
Fecha de inscripción : 15/05/2008

http://accessam@mejorforo.net

Volver arriba Ir abajo

Re: Busqueda por Coordenadas

Mensaje por GalileoGali el Miér Jun 11, 2008 7:00 pm

Muy bueno samros, ya que este caso lo permite, por tratarse de devolver Numeros, tambien puede recurrirse a SUMAPRODUCTO y otra variante con INDICE CON SUMA, pero sin COINCIDIR, Aclaremos que la version con INDICE COINCIDIR permite devolver tanto Numeros como texto.

Hoja1

 BCDEFGHI
3 ABCDE I
4F9284133681 D
5G97615393 15
6H566728078 15
7I5384771587  
8J13287520100  
Spreadsheet Formulas
CellFormula
I5=SUMAPRODUCTO((C3:G3=I4)*(B4:B8=I3)*(C4:G8))
I6=SUMA(INDICE((C3:G3=I4)*(B4:B8=I3)*(C4:G8);0))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Busqueda por Coordenadas

Mensaje por samros el Jue Jun 12, 2008 11:29 am

Efectivamente, este mismo efecto lo he logrado con fechas y productos.
Tambien se puede hacer con matriciales, en fin de que hay diversidad la hay.

Saludos.

Excel Jeanie HTMLRolling Forecast

 ABCDEFGHIJKL
111-Jun   w/25/08w/26/08w/27/08w/28/08w/29/08w/30/08w/31/08w/32/08
2MaterialDescriptionMaquinasInventarios22-Jun29-Jun06-Jul13-Jul20-Jul27-Jul03-Ago10-Ago
395539266xW2           1,920             960       
495584111xxMK         
595611980xxxMK                7,200            1,440
695667599xxxxW2         25,600        11,840        22,720        48,640        38,400        54,720        39,040        52,800
795750964xxxxxMK           7,680          2,880        21,120        28,800        30,720        31,680        40,320        12,480
895771377xxxxxxMK                1,920            3,840
9            
10            
11         486,720 6789   
12    W2               40,320              164,480                91,840                         -      
13    MK                10,560               121,440               58,080                         -      
Spreadsheet Formulas
CellFormula
E11=SUMA(F12:I13)
F12=SUMAPRODUCTO(($C$3:$C$8=$E12)*(MES($E$2:$L$2)=F$11)*($E$3:$L$8))
G12=SUMAPRODUCTO(($C$3:$C$8=$E12)*(MES($E$2:$L$2)=G$11)*($E$3:$L$8))
H12=SUMAPRODUCTO(($C$3:$C$8=$E12)*(MES($E$2:$L$2)=H$11)*($E$3:$L$8))
I12=SUMAPRODUCTO(($C$3:$C$8=$E12)*(MES($E$2:$L$2)=I$11)*($E$3:$L$8))
F13=SUMAPRODUCTO(($C$3:$C$8=$E13)*(MES($E$2:$L$2)=F$11)*($E$3:$L$8))
G13=SUMAPRODUCTO(($C$3:$C$8=$E13)*(MES($E$2:$L$2)=G$11)*($E$3:$L$8))
H13=SUMAPRODUCTO(($C$3:$C$8=$E13)*(MES($E$2:$L$2)=H$11)*($E$3:$L$8))
I13=SUMAPRODUCTO(($C$3:$C$8=$E13)*(MES($E$2:$L$2)=I$11)*($E$3:$L$8))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


samros

Masculino Cantidad de envíos : 115
Edad : 39
Ciudad - Pais : Guadalajara Jalisco Mexico
Version de Excel : 2003
Fecha de inscripción : 15/05/2008

http://accessam@mejorforo.net

Volver arriba Ir abajo

Re: Busqueda por Coordenadas

Mensaje por Contenido patrocinado Hoy a las 11:26 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.