............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Asignacion de valores

Ver el tema anterior Ver el tema siguiente Ir abajo

Asignacion de valores

Mensaje por EU el Jue Ago 14, 2014 5:15 pm

Tengo en una columna "X" una lista de valores
24.26
25.26
24.26
25.33

que deseo comparar con los siguientes valores, dependiendo del intervalo donde caigan:
Valores "Y"
<19.5 -0.06
19.51-21.49 0.7
21.5-22.49 0.14
22.5-23.49 0.21
23.5-24.49 0.28
24.5-25.49 0.36
25.5-26.49 0.43
26.5-27.49 0.52
27.5-28.49 0.6
28.5-29.49 0.68
29.5 o mayor 0.77

Como puedo hacer una formula para que en la celda de al lado asigne el valor "Y" que corresponde de acuerdo al intervalo donde se encuentre el valor.

Muchas gracias por el apoyo



EU

Masculino Cantidad de envíos : 1
Edad : 40
Ciudad - Pais : GDL
Version de Excel : 2010
Fecha de inscripción : 14/08/2014

Volver arriba Ir abajo

Re: Asignacion de valores

Mensaje por squispe amasifuen el Vie Ago 15, 2014 8:33 pm

Hola EU

Suponiendo que la tabla la tienes a partir de
A11=19.5 B11=0.06
A12=19.51-21.49 B12= 0.7
A13=21.5-22.49 B13=0.14
y así sucesivamente.. (en a11 quita el signo menor que < que antecede a 19.5)

Ahora, supongamos que en :
A2= 15 , A3=22.75 ...A5=25.33

b2=SI(A2<=19.5,B11,BUSCARV(A2,--(EXTRAE($A$11:$B$21,1,4)),2,1))
la formula es matricial, ingresala con CONTROL+SHIFT+ENTER
y arrastras hasta b5.

ahora, si puedes o tienes tus base de búsqueda separado por columna, sería optimo:
A11= 19.5 En C11=0.06
A12=19.51 C12=0.7
A13=22.5 C13=0.14
Solo interesan los números en donde comienza el rango...(columna A), por eso no coloco los datos de B, pero los puedes colocar.

Entonces, solo debes usar la formula en B2 quedaría así
=SI(A2<=19.5,C11,BUSCARV(A2,$A$11:$C$21,3,1))

espero haberme dejado entender..

saludos
Silvia



squispe amasifuen

Femenino Cantidad de envíos : 33
Edad : 50
Ciudad - Pais : peru
Version de Excel : excel 2003
Fecha de inscripción : 05/11/2010

Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.