............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Ayuda con control de stock

Ver el tema anterior Ver el tema siguiente Ir abajo

Ayuda con control de stock

Mensaje por KAWORUFIFTH el Sáb Mar 21, 2015 8:51 pm

Hola, quisiera saber si podrían ayudarme con el siguiente problema.
Cuento con la siguiente tabla:

A B C D
1 Producto Ingreso Salida Existencia actual
2

Necesitaría lograr que cada vez que agrego un ingreso o una salida el campo existencia actual se vaya modificando en tiempo real. Los ingresos y salidas los iría cargando sobre si mismos. Es esto posible? de ser así agradecería mucho su ayuda.

KAWORUFIFTH

Masculino Cantidad de envíos : 3
Edad : 31
Ciudad - Pais : Argentina
Version de Excel : 2010
Fecha de inscripción : 21/03/2015

Volver arriba Ir abajo

Re: Ayuda con control de stock

Mensaje por moises melgar el Sáb Mar 21, 2015 11:14 pm

Buenas noches

use el sumar.si() combinado con indirecto() y fila()
ASi indirecto("A2:A"&fila()) me arroja un rango de celdas que puede leer sumar.si que dependa de la fila en que se ande calculando (asi se excluyen los valores siguientes y la formula se pude seguir copiando segun se vayan agregando datos)
mostraria un historial de existencias
adjunto el ejemplo
ojala sea esto lo que andes buscando
saludos

CORREJIDO:
Código:
D2=SUMAR.SI(A$2:A2,A2,B$2:B2)-SUMAR.SI(A$2:A2,A2,C$2:C2)



Última edición por moises melgar el Dom Mar 22, 2015 12:27 am, editado 1 vez

moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 512
Edad : 28
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: Ayuda con control de stock

Mensaje por KAWORUFIFTH el Sáb Mar 21, 2015 11:45 pm

Buenas noches, antes que nada muchas gracias por tu tiempo.
Copie la tabla tal cual la pusiste para intentar comprender como funciona la formula pero al momento de poner la formula en la celda D2 me sale error de formula. Alguna idea de por que puede ser. Esto es lo que escibi en la celda D2:

=SUMAR.SI(INDIRECTO("A2:A"&FILA()),A2,INDIRECTO("B2:B"&FILA()))-SUMAR.SI(INDIRECTO("A2:A"&FILA()),A2,INDIRECTO("C2:C"&FILA()))

KAWORUFIFTH

Masculino Cantidad de envíos : 3
Edad : 31
Ciudad - Pais : Argentina
Version de Excel : 2010
Fecha de inscripción : 21/03/2015

Volver arriba Ir abajo

Re: Ayuda con control de stock

Mensaje por moises melgar el Dom Mar 22, 2015 12:01 am

Puedes descargar el archivo adjunto (lo subi a one driver)

Si colocas estas formulas en esas celdas.. ¿te dan esos valores?
E2 =SUMAR.SI(A2:A2,A2,B2:B2) = 50
F2 =INDIRECTO("A2:A"&FILA()) = "Escritorios"

moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 512
Edad : 28
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: Ayuda con control de stock

Mensaje por moises melgar el Dom Mar 22, 2015 12:23 am

Me corrijo una disculpa

Código:
D2=SUMAR.SI(A$2:A2,A2,B$2:B2)-SUMAR.SI(A$2:A2,A2,C$2:C2)

checa si en vez de "," usas ";"

moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 512
Edad : 28
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: Ayuda con control de stock

Mensaje por KAWORUFIFTH el Dom Mar 22, 2015 12:31 am

Ahora que pude descargar el ejemplo ya puedo ver como funciona, es la formula que estaba buscando para incorporar en mi planilla. Muchas gracias por tu tiempo y tu información.

KAWORUFIFTH

Masculino Cantidad de envíos : 3
Edad : 31
Ciudad - Pais : Argentina
Version de Excel : 2010
Fecha de inscripción : 21/03/2015

Volver arriba Ir abajo

Re: Ayuda con control de stock

Mensaje por moises melgar el Dom Mar 22, 2015 12:36 am

si la otra usaba indirecto pero aunque funciona igual esta muy larga
y se consigue el mismo resultado usando solo referencias absolutas

D2=SUMAR.SI(A$2:A2,A2,B$2:B2)-SUMAR.SI(A$2:A2,A2,C$2:C2)

hasta es mas entendible XD

saludos

moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 512
Edad : 28
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: Ayuda con control de stock

Mensaje por Contenido patrocinado Hoy a las 1:33 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.