............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Ordenar la mayor y menos cantidad de Valor

Ver el tema anterior Ver el tema siguiente Ir abajo

Ordenar la mayor y menos cantidad de Valor

Mensaje por 6luishao6 el Sáb Abr 29, 2017 12:18 pm

Buenas una consulta quisiera saber cómo puedo hacer para que en una lista de trabajadores lo ordene de acuerdo a la mayor venta y menor venta que realizo.
Tengo 30 vendedores de los cuales debe saber rápidamente en que lugar o posición se encuentran para darles su bono de venta.
Lo explico aquí:
En A1: esta la lista del 1 al 30.
En B1: están los nombres de los vendedores.
En C1: Esta el monto de dinero que a realizado durante todo el mes.

Ahora es obvio que la fila de A no va cambiar solo la fila B y la Fila C.
Como podría hacer; hay alguna macro, función o condición para que lo ordene por nombre y el monto de venta.
Gracias.

6luishao6

Masculino Cantidad de envíos : 24
Edad : 30
Ciudad - Pais : venezuela
Version de Excel : 2007 - 2010
Fecha de inscripción : 18/04/2015

Volver arriba Ir abajo

Re: Ordenar la mayor y menos cantidad de Valor

Mensaje por moises melgar el Sáb Abr 29, 2017 7:09 pm

Buenas tardes
Espero que esta sea la respuesta que buscas
adjunto archivo con dos formas de hacerlo

Pestaña 1.Con formulas que utiliza una columna auxiliar
Se modifican los datos de la columna "C" y se ordenan en las columnas F a H
Código:
D2=JERARQUIA(C2,C$2:C$31)+CONTAR.SI(C$1:C1,C2) <---colunma auxiliar (posicion de los datos)
G2=INDICE($B$2:$B$31,COINCIDIR(K.ESIMO.MENOR($D$2:$D$31,F2),$D$2:$D$31,))<--devulve el valor (nombre) segun columna "F"
H2=INDICE($C$2:$C$31,COINCIDIR(K.ESIMO.MENOR($D$2:$D$31,F2),$D$2:$D$31,))<---en vez de buscar el nombre, busca el importe
si los nombres son unicos funcionaria bien la formula buscarv para la busqueda del importe
I2=BUSCARV(G2,$B$2:$C$31,2)

Pestaña 2.Macro
Se modifican los datos de la columna "C" y se ordenan en las mismas columnas A a C
Use la grabadora de macros y la coloque dentro de Worksheet_Change, para que cuando cambie un valor el rango se ordene automaticamente
nota: al ejecutarse no se puede deshacer (ctr +z)
Código:
Private Sub Worksheet_Change(ByVal Target As Range)
Application.ScreenUpdating = False
    ActiveWorkbook.ActiveSheet.Sort.SortFields.Clear  '<--en vez Sheets("Hoja2"), use ActiveSheet para que no dependa del nombre de la hoja
    ActiveWorkbook.ActiveSheet.Sort.SortFields.Add Key:=Range("C2"), _
        SortOn:=xlSortOnValues, Order:=xlDescending, DataOption:= _
        xlSortTextAsNumbers
    With ActiveWorkbook.Worksheets("Macro").Sort
        .SetRange Range("B2:C31") '<--rango de los datos
        .Orientation = xlTopToBottom
        .SortMethod = xlPinYin
        .Apply
    End With
End Sub

avatar
moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 557
Edad : 29
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: Ordenar la mayor y menos cantidad de Valor

Mensaje por 6luishao6 el Dom Abr 30, 2017 6:03 pm

hola moises melgar pero que pasa su tengo celdas combinadas.
probe con celdas convinadas y no me funciona.
saludos

6luishao6

Masculino Cantidad de envíos : 24
Edad : 30
Ciudad - Pais : venezuela
Version de Excel : 2007 - 2010
Fecha de inscripción : 18/04/2015

Volver arriba Ir abajo

Re: Ordenar la mayor y menos cantidad de Valor

Mensaje por moises melgar el Dom Abr 30, 2017 11:57 pm

todas las filas tienen celdas combinadas?
o solo algunas celdas

sube un archivo de ejemplo de como tienes tus datos Combinados y como tienen que verse al final, para tener una mejor idea de lo que sucede
avatar
moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 557
Edad : 29
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: Ordenar la mayor y menos cantidad de Valor

Mensaje por 6luishao6 el Lun Mayo 01, 2017 9:55 pm

Hola Moises melgar hay te adjunto el archivo:
[Tienes que estar registrado y conectado para ver este vínculo]

6luishao6

Masculino Cantidad de envíos : 24
Edad : 30
Ciudad - Pais : venezuela
Version de Excel : 2007 - 2010
Fecha de inscripción : 18/04/2015

Volver arriba Ir abajo

Re: Ordenar la mayor y menos cantidad de Valor

Mensaje por moises melgar el Lun Mayo 01, 2017 11:03 pm

Las formulas son las mismas, solo adaptadas para los mensajes de error que son los que ocacionan la falla en la primera formula:

columna auxiliar:
N2=SI.ERROR(JERARQUIA(L2,$L$1:$L$31)+CONTAR.SI(L$1:L1,L2),"")
Agrege si.error para que las celdas que se encuentren vacias no muestren el error #N/A y con esto evitamos que las formulas que dependen de este rango muentren error tambien

Celdas de columna ranking
Q2=SI.ERROR(INDICE($B$2:$B$31,COINCIDIR(K.ESIMO.MENOR($N$2:$N$31,P2),$N$2:$N$31,)),"")
R2=SI.ERROR(INDICE($L$2:$L$31,COINCIDIR(K.ESIMO.MENOR($N$2:$N$31,P2),$N$2:$N$31,)),0)
Agrege si.error para que las celdas que se encuentren vacias no muestren el error #¡NUM! y con esto evitamos que las formulas que dependen de este rango muentren error tambien

Macro:
con respecto a la macro le agrege la condicion de que para que se ordene automaticamente, el nombre y el importe no deben estar vacios al momento de agregar nuevos datos
Nota de macros: cuando se ejecuta la macro ya no se puede deshacer los cambios efectuados (al modificar la pestaña macro)

Código:
Private Sub Worksheet_Change(ByVal Target As Range)
Application.ScreenUpdating = False
If Range("B" & Target.Row) = "" Or Range("L" & Target.Row) = "" Then'<---condicion de nombre e importes no vacias
Exit Sub'<---si falto nombre o importe no ejecuta la macro
Else:'cuando se agrega el nombre y el importe se ejecuta la macro
    ActiveWorkbook.ActiveSheet.Sort.SortFields.Clear
    ActiveWorkbook.ActiveSheet.Sort.SortFields.Add Key:=Range("L2"), _
        SortOn:=xlSortOnValues, Order:=xlDescending, DataOption:= _
        xlSortTextAsNumbers
    With ActiveWorkbook.Worksheets("Macro").Sort
        .SetRange Range("B2:L31")
        .Orientation = xlTopToBottom
        .SortMethod = xlPinYin
        .Apply
    End With
End If
End Sub

adjunto archivo por onedrive
avatar
moises melgar
Jr_Moderator

Masculino Cantidad de envíos : 557
Edad : 29
Ciudad - Pais : Coatzacoalcos - Mexico
Version de Excel : 2007 - 2010
Fecha de inscripción : 25/05/2010

Volver arriba Ir abajo

Re: Ordenar la mayor y menos cantidad de Valor

Mensaje por 6luishao6 el Dom Mayo 07, 2017 12:05 pm

Gracias moises por la ayuda me sirvio.

6luishao6

Masculino Cantidad de envíos : 24
Edad : 30
Ciudad - Pais : venezuela
Version de Excel : 2007 - 2010
Fecha de inscripción : 18/04/2015

Volver arriba Ir abajo

Re: Ordenar la mayor y menos cantidad de Valor

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.