............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

SUMAR.SI.CONJUNTO

Ver el tema anterior Ver el tema siguiente Ir abajo

SUMAR.SI.CONJUNTO

Mensaje por GalileoGali el Sáb Oct 04, 2008 9:02 am

Entre las novedades de Excel 2007 esta esta funcion SUMAR.SI.CONJUNTO, que en principio pareciera no aportar demasiado estando la tradicional y multifacetica SUMAPRODUCTO, sin embargo, el trabajo que hacia SUMAR.SI (la simple), por ejemplo con la manipulacion de cadenas para definir criterios, le permtia "salvar" algunas situaciones que SUMAPRODUCTO no podia sortear como es por ejemplo la existencia de valores de error #¡N/A! y #¡REF!. Ahora bien, SUMAR.SI maneja un CRITERIO, en cambio SUMAR.SI.CONJUNTO, puede manejar hasta 127 criterios (Wowowowow!!!!). Como se ve en este ejemplo resuelve el tema de tomar cietros registros basada en los valores de la primera columna y saltearse los errores, aun cuando el registro que los contenia debiera incluirse a juzgar por la primera defincion de criterio.

Hoja1

 ABCD
123  
2-1#¡REF!  
311 16
454  
5-512  
6117  
Spreadsheet Formulas
CellFormula
B2=DESREF(C2;0;-3)
D3=SUMAR.SI.CONJUNTO(B1:B6;A1:A6;"<=2";B1:B6;"<>#¡REF!")


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


Ahora bien, seria interesante, ver si podemos o no enlazar Operaciones entre los rangos filtrados: por ejemplo Productos, no porque no haya soluciones con SUMAPRODUCTO, como esta que propone IOYAMA:

=SUMAPRODUCTO((A1:A6)*(SI(ESERROR(B1:B6);0;(B1:B6) ))) ,
desde ya que apuntando hacia un resultado distinto del que me estuve refiriendo en mi ejemplo, pero tratando de ver el comportamiento de esta ampliacion de SUMAR.SI, que va "mostrando sus bondades" en forma paulatina

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos: 1962
Edad: 58
Ciudad - Pais: QUIROGA, Argentina
Version de Excel: 2000-2003-2007-2010
Fecha de inscripción: 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: SUMAR.SI.CONJUNTO

Mensaje por Gerson Pineda-El Catracho el Miér Oct 08, 2008 5:30 pm

Hola Gali
Muy interesante la funcion, esperemos que sea mas efectiva con el pasar de los dias, gracias por tu bondad de explicarnos pequeños pero significativos detalles

Saludos

Gerson Pineda-El Catracho

Masculino Cantidad de envíos: 102
Ciudad - Pais: SPS - Honduras
Version de Excel: 2003/2007/2010
Fecha de inscripción: 02/04/2008

http://gerson-pineda-el-catracho.blogspot.com/

Volver arriba Ir abajo

Re: SUMAR.SI.CONJUNTO

Mensaje por GalileoGali el Miér Oct 08, 2008 5:53 pm

gerson, gracias.
Pregunto ya viste la Hoja dedicada a BUSCARV?, EN EL portal LAS FUNCIONES ESTRELLA DE EXCEL"?

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos: 1962
Edad: 58
Ciudad - Pais: QUIROGA, Argentina
Version de Excel: 2000-2003-2007-2010
Fecha de inscripción: 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: SUMAR.SI.CONJUNTO

Mensaje por Gerson Pineda-El Catracho el Miér Oct 08, 2008 6:09 pm

No he visto tal hoja, ahorita le entro

Gracias

Gerson Pineda-El Catracho

Masculino Cantidad de envíos: 102
Ciudad - Pais: SPS - Honduras
Version de Excel: 2003/2007/2010
Fecha de inscripción: 02/04/2008

http://gerson-pineda-el-catracho.blogspot.com/

Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


Permisos de este foro:
No puedes responder a temas en este foro.