............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Desplazar Impares a segunda columna y filtrar

Ver el tema anterior Ver el tema siguiente Ir abajo

Desplazar Impares a segunda columna y filtrar

Mensaje por GalileoGali el Dom Oct 19, 2008 10:51 am

En otro foro consultan:
Buenos dias,

Aqui va una consultilla aparentemenete facil pero no consigo encontrar la solución, el ejemplo es el siguiente, yo tengo en una columna muchos valores del estilo:

2
65
4
78
93
2
7
34
21

estos valores los quiere separa con una formula un macro o como sea en dos columnas de tal manera que los que estan en un fila par vayan a una columna y los que estan en un fila impar vayan ha otra, quedando mas o menos asi:

2 65
4 78
93 2
7 34
21

Espero puedan ayudarme.

Muchas gracias de antemano

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Desplazar Impares a segunda columna y filtrar

Mensaje por GalileoGali el Dom Oct 19, 2008 11:01 am

Hoja1

 AB
2245
345 
4671
51 
6225
75 
86677
977 
1012
Spreadsheet Formulas
CellFormula
B2=A3
B4=SI(B3="";A5;"")
B5=SI(B4="";A6;"")
B6=SI(B5="";A7;"")
B7=SI(B6="";A8;"")
B8=SI(B7="";A9;"")
B9=SI(B8="";A10;"")
B10=SI(B9="";A11;"")


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

Hoja1

 F
21) ver formula en B2
32) ver Formula en B4
43) Copio la formula de B4 toda la columna hasta completar
54)Me posiciono en cualquier celda del rango
65) datos >>Autofiltro
76) Filtro en segunda columna las "No vacias"
87) copio y pego en donde quiera
9 Desactivo el Autofiltro.


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]
Puede ocurrir que la ultima fila haya que agregarla "a mano" en caso de Numero Impar de filas en la columna inicial.

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Desplazar Impares a segunda columna y filtrar

Mensaje por GalileoGali el Dom Oct 19, 2008 12:14 pm

Hoja1

 ABCD
14 47
27 2211
322 38
411 15 
53   
68   
715   
Spreadsheet Formulas
CellFormula
C1=SI(ESERROR(INDICE($A$1:$A$7;2*FILA(C1)-1+RESIDUO(COLUMNA(C1)-1;2)));"";INDICE($A$1:$A$7;2*FILA(C1)-1+RESIDUO(COLUMNA(C1)-1;2)))
D1=SI(ESERROR(INDICE($A$1:$A$7;2*FILA(D1)-1+RESIDUO(COLUMNA(D1)-1;2)));"";INDICE($A$1:$A$7;2*FILA(D1)-1+RESIDUO(COLUMNA(D1)-1;2)))
C2=SI(ESERROR(INDICE($A$1:$A$7;2*FILA(C2)-1+RESIDUO(COLUMNA(C2)-1;2)));"";INDICE($A$1:$A$7;2*FILA(C2)-1+RESIDUO(COLUMNA(C2)-1;2)))
D2=SI(ESERROR(INDICE($A$1:$A$7;2*FILA(D2)-1+RESIDUO(COLUMNA(D2)-1;2)));"";INDICE($A$1:$A$7;2*FILA(D2)-1+RESIDUO(COLUMNA(D2)-1;2)))
C3=SI(ESERROR(INDICE($A$1:$A$7;2*FILA(C3)-1+RESIDUO(COLUMNA(C3)-1;2)));"";INDICE($A$1:$A$7;2*FILA(C3)-1+RESIDUO(COLUMNA(C3)-1;2)))
D3=SI(ESERROR(INDICE($A$1:$A$7;2*FILA(D3)-1+RESIDUO(COLUMNA(D3)-1;2)));"";INDICE($A$1:$A$7;2*FILA(D3)-1+RESIDUO(COLUMNA(D3)-1;2)))
C4=SI(ESERROR(INDICE($A$1:$A$7;2*FILA(C4)-1+RESIDUO(COLUMNA(C4)-1;2)));"";INDICE($A$1:$A$7;2*FILA(C4)-1+RESIDUO(COLUMNA(C4)-1;2)))
D4=SI(ESERROR(INDICE($A$1:$A$7;2*FILA(D4)-1+RESIDUO(COLUMNA(D4)-1;2)));"";INDICE($A$1:$A$7;2*FILA(D4)-1+RESIDUO(COLUMNA(D4)-1;2)))
C5=SI(ESERROR(INDICE($A$1:$A$7;2*FILA(C5)-1+RESIDUO(COLUMNA(C5)-1;2)));"";INDICE($A$1:$A$7;2*FILA(C5)-1+RESIDUO(COLUMNA(C5)-1;2)))
D5=SI(ESERROR(INDICE($A$1:$A$7;2*FILA(D5)-1+RESIDUO(COLUMNA(D5)-1;2)));"";INDICE($A$1:$A$7;2*FILA(D5)-1+RESIDUO(COLUMNA(D5)-1;2)))
C6=SI(ESERROR(INDICE($A$1:$A$7;2*FILA(C6)-1+RESIDUO(COLUMNA(C6)-1;2)));"";INDICE($A$1:$A$7;2*FILA(C6)-1+RESIDUO(COLUMNA(C6)-1;2)))
D6=SI(ESERROR(INDICE($A$1:$A$7;2*FILA(D6)-1+RESIDUO(COLUMNA(D6)-1;2)));"";INDICE($A$1:$A$7;2*FILA(D6)-1+RESIDUO(COLUMNA(D6)-1;2)))
C7=SI(ESERROR(INDICE($A$1:$A$7;2*FILA(C7)-1+RESIDUO(COLUMNA(C7)-1;2)));"";INDICE($A$1:$A$7;2*FILA(C7)-1+RESIDUO(COLUMNA(C7)-1;2)))
D7=SI(ESERROR(INDICE($A$1:$A$7;2*FILA(D7)-1+RESIDUO(COLUMNA(D7)-1;2)));"";INDICE($A$1:$A$7;2*FILA(D7)-1+RESIDUO(COLUMNA(D7)-1;2)))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

Version con formulas

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Desplazar Impares a segunda columna y filtrar

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.