............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Como Generar El codigo ?

Ver el tema anterior Ver el tema siguiente Ir abajo

Como Generar El codigo ?

Mensaje por Marco Paez el Jue Oct 30, 2008 2:04 am

En base a la siguiente informacion, como puedo hacer para que se me genere el codigo compuesto de 10 digitos ( PARA LA COLUMNA CODIGO )

LA PREGUNTA ES : QUIERO QUE SE GENERE EL CODIGO AUTOMATICAMENTE AL MOMENTO DE INTRODUCIR EN LA COLUMNAS LOS DATOS DE PRODUCTO , TALLA , COLOR Y MODELO ?

CODIGO PRODUCTO TALLA COLOR MODELO PRECIO
0102130622 BLUSA 02 AQUA 0622 $90.00
0204130622 FALDA 04 AQUA 0622 $90.00
0306130622 VESTIDO 06 AQUA 0622 $90.00
0408130622 PANTALON 08 AQUA 0622 $90.00
0510130622 BLUSA 10 AQUA 0622 $90.00

LOS CODIGOS PARA EL PRODUCTO SON :
01 BLUSA
02 FALDA
03 VESTIDO
04 PANTALON
05 BLUSA

LAS TALLAS SON:
02
04
06
08
10
12
14
16

PARA EL COLOR SON:
01 BLANCO
02 AQUA
03 AZUL
04 CAFE
05 ROJO

Y EL MODELO UNO LO DETERMINA DE ACUERDO A LA TIPO DE PRODUCTO QUE SERIAN (4 DIGITOS )

Marco Paez

Masculino Cantidad de envíos : 16
Edad : 52
Ciudad - Pais : Monterrey Nuevo León, México
Fecha de inscripción : 29/10/2008

Volver arriba Ir abajo

Re: Como Generar El codigo ?

Mensaje por GalileoGali el Jue Oct 30, 2008 6:51 am

A ver esto:
Hoja1

 ABCDEF
1PRODUCTOTALLACOLORMODELOPRECIOCODIGO
2BLUSA2AQUA622$90.000102020622
3FALDA4AQUA622$90.000204020622
4VESTIDO6AQUA622$90.000306020622
5PANTALON8AQUA622$90.000408020622
6BLUSA10AQUA622$90.000110020622
7      
8      
9BLUSA1    
10FALDA2    
11VESTIDO3    
12PANTALON4    
13BLUSA5    
14      
15BLANCO1    
16AQUA2    
17AZUL3    
18CAFE4    
19ROJO5    
Spreadsheet Formulas
CellFormula
F2=TEXTO(BUSCARV(A2;$A$9:$B$13;2;0);"00")&TEXTO(B2;"00")&TEXTO(BUSCARV(C2;$A$15:$B$19;2;0);"00")&TEXTO(D2;"0000")
F3=TEXTO(BUSCARV(A3;$A$9:$B$13;2;0);"00")&TEXTO(B3;"00")&TEXTO(BUSCARV(C3;$A$15:$B$19;2;0);"00")&TEXTO(D3;"0000")
F4=TEXTO(BUSCARV(A4;$A$9:$B$13;2;0);"00")&TEXTO(B4;"00")&TEXTO(BUSCARV(C4;$A$15:$B$19;2;0);"00")&TEXTO(D4;"0000")
F5=TEXTO(BUSCARV(A5;$A$9:$B$13;2;0);"00")&TEXTO(B5;"00")&TEXTO(BUSCARV(C5;$A$15:$B$19;2;0);"00")&TEXTO(D5;"0000")
F6=TEXTO(BUSCARV(A6;$A$9:$B$13;2;0);"00")&TEXTO(B6;"00")&TEXTO(BUSCARV(C6;$A$15:$B$19;2;0);"00")&TEXTO(D6;"0000")


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

En tu codigo aparece un "13", del que no das ninguna explicacion, asi que falta considerarlo.....

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Como Generar El codigo ?

Mensaje por Marco Paez el Vie Oct 31, 2008 11:15 am

Buenos Dias estimado : GalileoGali.
Ya probe y si me funciono, la combinacion de funciones que sugeriste para llevar a cabo dicho proceso.. con respecto al codigo 13 al que haces referencia no le prestes importancia ya que en parte de los codigos de colores. Te comento que un servidor se le dificulta aplicar la combinacion de funciones de excel, no se cuando hacer la combinacion y si todas las funciones se pueden combinar entre si .
Existe alguna regla que seguir ?..
Que recomiendas de literatura para aprender hacer dichas aplicaciones.?
Saludos y Gracias..

Desde Monterrey Mexico

Marco Paez

Marco Paez

Masculino Cantidad de envíos : 16
Edad : 52
Ciudad - Pais : Monterrey Nuevo León, México
Fecha de inscripción : 29/10/2008

Volver arriba Ir abajo

Re: Como Generar El codigo ?

Mensaje por GalileoGali el Vie Oct 31, 2008 12:54 pm

Marco: En le portal hay un Link a una pagina de nuestro sitio que dice "Manuales Y Tutoriales", puedes ingresar, y seleccionar, son todos gratuitos......

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Como Generar El codigo ?

Mensaje por dimao+ el Lun Nov 10, 2014 6:33 pm

buenas tardes,

Por favor requiero de su ayuda, tengo la fuente para cpnvertir nuemros a codigo de barra pero en el momento de imprimir la lectora no lo lee, use los astericos pero igual no lee, alguien sabe como hacerlo..?

dimao+

Masculino Cantidad de envíos : 1
Edad : 35
Ciudad - Pais : cali- colombia
Version de Excel : 2010
Fecha de inscripción : 10/11/2014

Volver arriba Ir abajo

Re: Como Generar El codigo ?

Mensaje por Contenido patrocinado Hoy a las 1:33 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.