............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Funcion Suma Producto en Autofiltro

Ver el tema anterior Ver el tema siguiente Ir abajo

Funcion Suma Producto en Autofiltro

Mensaje por Marco Paez el Dom Nov 02, 2008 7:05 pm

CATALOGO

 BCDEFGHI
3TEMPORADACODIGODESCRIPCION DE PRODUCTOTALLACOLORMODELOPRECIO UNITARIOEXISTENCIA ACTUAL
4PRIMA-VERANO0502130622BLUSA2AQUA622 $              90.00 1
5PRIMA-VERANO0504130622BLUSA4AQUA622 $              90.00 1
6PRIMA-VERANO0506130622BLUSA6AQUA622 $              90.00 1
7PRIMA-VERANO0508130622BLUSA8AQUA622 $              90.00 1
8 No. De Partidas4  EXISTENCIA$360.004
Spreadsheet Formulas
CellFormula
C4=TEXTO(BUSCARV(D4,LISTAS!$G$2:$H$100,2,0),"00")&TEXTO(BUSCARV(E4,LISTAS!$A$2:$B$38,2,0),"00")&TEXTO(BUSCARV(F4,LISTAS!$I$2:$J$100,2,0),"00")&TEXTO(G4,"0000")
I4=SUMAR.SI(MOVIMIENTOS!$A$5:$A$1000,A4&"ENTRADA",MOVIMIENTOS!$F$5:$F$1000)-SUMAR.SI(MOVIMIENTOS!$A$5:$A$1000,A4&"SALIDA",MOVIMIENTOS!$G$5:$G$1000)
C5=TEXTO(BUSCARV(D5,LISTAS!$G$2:$H$100,2,0),"00")&TEXTO(BUSCARV(E5,LISTAS!$A$2:$B$38,2,0),"00")&TEXTO(BUSCARV(F5,LISTAS!$I$2:$J$100,2,0),"00")&TEXTO(G5,"0000")
C6=TEXTO(BUSCARV(D6,LISTAS!$G$2:$H$100,2,0),"00")&TEXTO(BUSCARV(E6,LISTAS!$A$2:$B$38,2,0),"00")&TEXTO(BUSCARV(F6,LISTAS!$I$2:$J$100,2,0),"00")&TEXTO(G6,"0000")
C7=TEXTO(BUSCARV(D7,LISTAS!$G$2:$H$100,2,0),"00")&TEXTO(BUSCARV(E7,LISTAS!$A$2:$B$38,2,0),"00")&TEXTO(BUSCARV(F7,LISTAS!$I$2:$J$100,2,0),"00")&TEXTO(G7,"0000")
D8=SUBTOTALES(3,D4:D7)
H8=SUMAPRODUCTO(H4:H7,I4:I7)
I8=SUBTOTALES(9,I4:I7)


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


En la celda H8 tengo la funcion sumaproducto que da el resultado la suma de los producto con respecto a la cantidad en existencia el cual es correcto (360.00) , pero al monento de poner un filtro por talla(2) que solo me filtre los de talla 2 ,me sigue dejando el mismo resultado de 360.00 , y me deberia dejar 90.00 pesos , que me recomendian que utilize para que el resultado de la celda h8 sea de 90.00

Marco Paez

Masculino Cantidad de envíos : 16
Edad : 52
Ciudad - Pais : Monterrey Nuevo León, México
Fecha de inscripción : 29/10/2008

Volver arriba Ir abajo

Re: Funcion Suma Producto en Autofiltro

Mensaje por GalileoGali el Dom Nov 02, 2008 9:51 pm

Podes probar esto:
=SUMAPRODUCTO((E4:E7=2)*(H4:H7)*I4:I7)

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Funcion Suma Producto en Autofiltro

Mensaje por Marco Paez el Mar Nov 04, 2008 4:49 pm

Estimado Galileogali la formula que tu me suguieres no me funciona, Creo que no me di antender,,.en el ejemplo anterior tengo activados los autofiltros , al momento de filtrar ya sea por talla y/ o modelo me deja los mismos 360.00 pesos , de antemano se que la funcion sumaproducto realiza su funcion al rango seleccionado y pasa por alto las filas ocultas al momento de filtrar , la pregunta es ? al momento de filtrar que la funcion sumaproducto me realice la operacion de las cantidades en existencia x el precio unitario y estas a la vez me sume el total de las misma (celda H8)

Marco Paez

Masculino Cantidad de envíos : 16
Edad : 52
Ciudad - Pais : Monterrey Nuevo León, México
Fecha de inscripción : 29/10/2008

Volver arriba Ir abajo

Re: Funcion Suma Producto en Autofiltro

Mensaje por GalileoGali el Mar Nov 04, 2008 5:27 pm

A ver ahora:
[Tienes que estar registrado y conectado para ver este vínculo]
[Tienes que estar registrado y conectado para ver este vínculo]

Hoja1

 ABCDEFGH
1TEMPORADACODIGODESCRIPCION DE PRODUCTOTALLACOLORMODELOPRECIO UNITARIOEXISTENCIA ACTUAL
2PRIMA-VERANO0502130622BLUSA2AQUA622 $       90,00 1
3PRIMA-VERANO0504130622BLUSA4AQUA622 $       90,00 2
4PRIMA-VERANO0506130622BLUSA6AQUA622 $       90,00 1
5PRIMA-VERANO0508130622BLUSA8AQUA622 $       90,00 3
6        
7 No. De Partidas4  EXISTENCIA $     630,00 4
Spreadsheet Formulas
CellFormula
G7=SUMAPRODUCTO(SUBTOTALES(9;DESREF(G2:G5;FILA(F2:F5)-FILA($F$2);0;1))*H2:H5)


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Funcion Suma Producto en Autofiltro

Mensaje por Marco Paez el Miér Nov 05, 2008 2:12 am

Te Felicito Maestro Galileogali , ya estuve viendo la formula aplicada y funciona, es lo que necesitaba, veo que eres un excelente maestro en la aplicacion de la combinacion de formulas , creo que voy aprender mucho de usted... Saludos cordiales...

Marco Paez

Masculino Cantidad de envíos : 16
Edad : 52
Ciudad - Pais : Monterrey Nuevo León, México
Fecha de inscripción : 29/10/2008

Volver arriba Ir abajo

Re: Funcion Suma Producto en Autofiltro

Mensaje por Contenido patrocinado Hoy a las 3:16 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.