............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Listar Unicos (series de numeros y de texto)

Ver el tema anterior Ver el tema siguiente Ir abajo

Listar Unicos (series de numeros y de texto)

Mensaje por GalileoGali el Sáb Nov 08, 2008 8:12 am

Tengo una columna de numeros y pretendo en una segunda columna devolver, unicos valores de esa columna, es decir la columna depurada de repetidos....

Hoja1

 AB
13232
22424
32422
424 
522 
622 
Spreadsheet Formulas
CellFormula
B1{=SI(ESERROR(K.ESIMO.MAYOR(SI(FRECUENCIA($A$1:$A$6;$A$1:$A$6)>0;$A$1:$A$6);FILA(B1)-FILA(B$1)+1));"";K.ESIMO.MAYOR(SI(FRECUENCIA($A$1:$A$6;$A$1:$A$6)>0;$A$1:$A$6);FILA(B1)-FILA(B$1)+1))}
B2{=SI(ESERROR(K.ESIMO.MAYOR(SI(FRECUENCIA($A$1:$A$6;$A$1:$A$6)>0;$A$1:$A$6);FILA(B2)-FILA(B$1)+1));"";K.ESIMO.MAYOR(SI(FRECUENCIA($A$1:$A$6;$A$1:$A$6)>0;$A$1:$A$6);FILA(B2)-FILA(B$1)+1))}
B3{=SI(ESERROR(K.ESIMO.MAYOR(SI(FRECUENCIA($A$1:$A$6;$A$1:$A$6)>0;$A$1:$A$6);FILA(B3)-FILA(B$1)+1));"";K.ESIMO.MAYOR(SI(FRECUENCIA($A$1:$A$6;$A$1:$A$6)>0;$A$1:$A$6);FILA(B3)-FILA(B$1)+1))}
B4{=SI(ESERROR(K.ESIMO.MAYOR(SI(FRECUENCIA($A$1:$A$6;$A$1:$A$6)>0;$A$1:$A$6);FILA(B4)-FILA(B$1)+1));"";K.ESIMO.MAYOR(SI(FRECUENCIA($A$1:$A$6;$A$1:$A$6)>0;$A$1:$A$6);FILA(B4)-FILA(B$1)+1))}
B5{=SI(ESERROR(K.ESIMO.MAYOR(SI(FRECUENCIA($A$1:$A$6;$A$1:$A$6)>0;$A$1:$A$6);FILA(B5)-FILA(B$1)+1));"";K.ESIMO.MAYOR(SI(FRECUENCIA($A$1:$A$6;$A$1:$A$6)>0;$A$1:$A$6);FILA(B5)-FILA(B$1)+1))}
B6{=SI(ESERROR(K.ESIMO.MAYOR(SI(FRECUENCIA($A$1:$A$6;$A$1:$A$6)>0;$A$1:$A$6);FILA(B6)-FILA(B$1)+1));"";K.ESIMO.MAYOR(SI(FRECUENCIA($A$1:$A$6;$A$1:$A$6)>0;$A$1:$A$6);FILA(B6)-FILA(B$1)+1))}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


Última edición por GalileoGali el Sáb Nov 22, 2008 8:35 pm, editado 1 vez

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Listar Unicos (series de numeros y de texto)

Mensaje por GalileoGali el Sáb Nov 22, 2008 8:23 pm

Estos aportes me los envio por CORRERO PRIVADO Tatayayan y aqui ya van (me salio un versito)

Extraer_Únicos

 AB
152
223
355
42 
53 
62 
75 
83 
93 
Spreadsheet Formulas
CellFormula
B1{=SI(ESERROR(K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)));"";K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)))}
B2{=SI(ESERROR(K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)));"";K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)))}
B3{=SI(ESERROR(K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)));"";K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)))}
B4{=SI(ESERROR(K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)));"";K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)))}
B5{=SI(ESERROR(K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)));"";K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)))}
B6{=SI(ESERROR(K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)));"";K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)))}
B7{=SI(ESERROR(K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)));"";K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)))}
B8{=SI(ESERROR(K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)));"";K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)))}
B9{=SI(ESERROR(K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)));"";K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:9));A1:A9)=1;A1:A9;"");FILA(1:9)))}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Listar Unicos (series de numeros y de texto)

Mensaje por GalileoGali el Sáb Nov 22, 2008 8:34 pm

y tambien de TATAYAYAN, esta vez para TEXTO.....

Extrae Únicos

 ABC
1NombreFunciónFunción
2anaanajuan
3pablopabloana
4juanjuanpablo
5ana 0
6pablo  
Spreadsheet Formulas
CellFormula
B2{=SI(ESERROR(INDICE(A2:A11;K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:10));A2:A11)>0;"";FILA(1:10));FILA(1:10))));"";INDICE(A2:A11;K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:10));A2:A11)>0;"";FILA(1:10));FILA(1:10))))}
C2{=SI(ESERROR(K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A"&FILA(3:12)&":A$12");A2:A10)>0;"";FILA(1:10));FILA(1:10)));"";INDICE(A2:A11;K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A"&FILA(3:12)&":A$12");A2:A10)>0;"";FILA(1:10));FILA(1:10))))}
B3{=SI(ESERROR(INDICE(A2:A11;K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:10));A2:A11)>0;"";FILA(1:10));FILA(1:10))));"";INDICE(A2:A11;K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:10));A2:A11)>0;"";FILA(1:10));FILA(1:10))))}
C3{=SI(ESERROR(K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A"&FILA(3:12)&":A$12");A2:A10)>0;"";FILA(1:10));FILA(1:10)));"";INDICE(A2:A11;K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A"&FILA(3:12)&":A$12");A2:A10)>0;"";FILA(1:10));FILA(1:10))))}
B4{=SI(ESERROR(INDICE(A2:A11;K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:10));A2:A11)>0;"";FILA(1:10));FILA(1:10))));"";INDICE(A2:A11;K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A1:A"&FILA(1:10));A2:A11)>0;"";FILA(1:10));FILA(1:10))))}
C4{=SI(ESERROR(K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A"&FILA(3:12)&":A$12");A2:A10)>0;"";FILA(1:10));FILA(1:10)));"";INDICE(A2:A11;K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A"&FILA(3:12)&":A$12");A2:A10)>0;"";FILA(1:10));FILA(1:10))))}
C5{=SI(ESERROR(K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A"&FILA(3:12)&":A$12");A2:A10)>0;"";FILA(1:10));FILA(1:10)));"";INDICE(A2:A11;K.ESIMO.MENOR(SI(CONTAR.SI(INDIRECTO("A"&FILA(3:12)&":A$12");A2:A10)>0;"";FILA(1:10));FILA(1:10))))}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Gracias

Mensaje por Tatayayan el Mar Nov 25, 2008 10:19 am

Gracias Gali por poner mis aportes.

Tatayayan

Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos : 319
Ciudad - Pais : Chamical- La Rioja - ARG
Fecha de inscripción : 20/11/2008

Volver arriba Ir abajo

Re: Listar Unicos (series de numeros y de texto)

Mensaje por Contenido patrocinado Hoy a las 1:57 am


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.