............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

BuscarV Multiple con Mas de un criterio o condicion

Ver el tema anterior Ver el tema siguiente Ir abajo

BuscarV Multiple con Mas de un criterio o condicion

Mensaje por GalileoGali el Jue Nov 20, 2008 7:17 am

Ya que me preguntan en otro foro tomé un resultado que creo es de Ozgrid para Busquedas Múltiples y lo adapte para que maneje más de una condicion.....
Sheet1

 ABCDEFG
1NameReg1Code Reg1NameCode
2Frank1A1 2FrankA2
3Frank2A2   A3
4Frank2A3   A5
5Joe1A4   A8
6Frank2A5    
7Joe3A6    
8John1A7    
9Frank2A8    
10John3A9    
Spreadsheet Formulas
CellFormula
G2{=SI(FILAS(G$2:G2)<=SUMAPRODUCTO((A$2:A$10=F$2)*($B$2:$B$10=$E$2));INDICE(C$2:C$10;K.ESIMO.MENOR(SI((A$2:A$10=F$2)*($B$2:$B$10=$E$2);FILA(A$1:A$9));FILA(G1)));"")}
G3{=SI(FILAS(G$2:G3)<=SUMAPRODUCTO((A$2:A$10=F$2)*($B$2:$B$10=$E$2));INDICE(C$2:C$10;K.ESIMO.MENOR(SI((A$2:A$10=F$2)*($B$2:$B$10=$E$2);FILA(A$1:A$9));FILA(G2)));"")}
G4{=SI(FILAS(G$2:G4)<=SUMAPRODUCTO((A$2:A$10=F$2)*($B$2:$B$10=$E$2));INDICE(C$2:C$10;K.ESIMO.MENOR(SI((A$2:A$10=F$2)*($B$2:$B$10=$E$2);FILA(A$1:A$9));FILA(G3)));"")}
G5{=SI(FILAS(G$2:G5)<=SUMAPRODUCTO((A$2:A$10=F$2)*($B$2:$B$10=$E$2));INDICE(C$2:C$10;K.ESIMO.MENOR(SI((A$2:A$10=F$2)*($B$2:$B$10=$E$2);FILA(A$1:A$9));FILA(G4)));"")}
G6{=SI(FILAS(G$2:G6)<=SUMAPRODUCTO((A$2:A$10=F$2)*($B$2:$B$10=$E$2));INDICE(C$2:C$10;K.ESIMO.MENOR(SI((A$2:A$10=F$2)*($B$2:$B$10=$E$2);FILA(A$1:A$9));FILA(G5)));"")}
G7{=SI(FILAS(G$2:G7)<=SUMAPRODUCTO((A$2:A$10=F$2)*($B$2:$B$10=$E$2));INDICE(C$2:C$10;K.ESIMO.MENOR(SI((A$2:A$10=F$2)*($B$2:$B$10=$E$2);FILA(A$1:A$9));FILA(G6)));"")}
G8{=SI(FILAS(G$2:G8)<=SUMAPRODUCTO((A$2:A$10=F$2)*($B$2:$B$10=$E$2));INDICE(C$2:C$10;K.ESIMO.MENOR(SI((A$2:A$10=F$2)*($B$2:$B$10=$E$2);FILA(A$1:A$9));FILA(G7)));"")}
G9{=SI(FILAS(G$2:G9)<=SUMAPRODUCTO((A$2:A$10=F$2)*($B$2:$B$10=$E$2));INDICE(C$2:C$10;K.ESIMO.MENOR(SI((A$2:A$10=F$2)*($B$2:$B$10=$E$2);FILA(A$1:A$9));FILA(G8)));"")}
G10{=SI(FILAS(G$2:G10)<=SUMAPRODUCTO((A$2:A$10=F$2)*($B$2:$B$10=$E$2));INDICE(C$2:C$10;K.ESIMO.MENOR(SI((A$2:A$10=F$2)*($B$2:$B$10=$E$2);FILA(A$1:A$9));FILA(G9)));"")}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


Última edición por GalileoGali el Jue Nov 20, 2008 5:36 pm, editado 1 vez (Razón : Corregi copiado de formulas erroneo)

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

BuscarV Multiple con Mas de un criterio o condicion

Mensaje por charly2007 el Jue Nov 20, 2008 1:32 pm

Gali, estuve viendo este tema y me surgió el sigiente inconveiente al modiicar algunos datos:

A B C D E F G
1 Name Reg1 Code Reg1 Name Code
2 Frank 1 A1 2 Frank A2
3 Frank 2 A2 A3
4 Frank 2 A3 A5
5 Joe 1 A4 A5
6 Frank 2 A5 A8
7 Joe 3 A6
8 John 1 A7
9 Frank 2 A8
10 John 3 A9

Es decir: en lugar de devolverme 4 respuestas, me devuelve 5 (repite el Code A5).

Agradeceré que veas cuál puede ser el incinveniente.
Muchas gracias

charly2007

Masculino Cantidad de envíos : 10
Edad : 65
Ciudad - Pais : Ciudad Autónoma de Buenos Aires - Argentina
Version de Excel : Excel 2007
Fecha de inscripción : 16/11/2008

Volver arriba Ir abajo

Re: BuscarV Multiple con Mas de un criterio o condicion

Mensaje por charly2007 el Jue Nov 20, 2008 1:38 pm

Disculpen si no quedo claro los datos de mi correo anterior:

en el rango G2:G6 como resultado me arroja A2; A3; A5; A5 y A8 (es decir cinco resultados, pero repitiendo el Code A5)

charly2007

Masculino Cantidad de envíos : 10
Edad : 65
Ciudad - Pais : Ciudad Autónoma de Buenos Aires - Argentina
Version de Excel : Excel 2007
Fecha de inscripción : 16/11/2008

Volver arriba Ir abajo

Re: BuscarV Multiple con Mas de un criterio o condicion

Mensaje por GalileoGali el Jue Nov 20, 2008 5:40 pm

charly2007 escribió:Disculpen si no quedo claro los datos de mi correo anterior:

en el rango G2:G6 como resultado me arroja A2; A3; A5; A5 y A8 (es decir cinco resultados, pero repitiendo el Code A5)

Buena Observacion quese agradece: Lo que ocurrio es que en algun momento "prueba va, prueba viene" corregi la Priemra formula, pero omiti arrastrar estirandola hacia abajo, con lo cual las formulas siguientes mantenian mi error original. Ahora para evitar traslacion de erorres y confusion, corregi las formulas en el mensaje anterior, dejando constancia de haberlo editado..
Gracias Charly

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: BuscarV Multiple con Mas de un criterio o condicion

Mensaje por charly2007 el Jue Nov 20, 2008 5:58 pm

Gali, el agradecido soy yo por el continuo aporte de conocimientos y soluciones que nos brindas.
Charly

charly2007

Masculino Cantidad de envíos : 10
Edad : 65
Ciudad - Pais : Ciudad Autónoma de Buenos Aires - Argentina
Version de Excel : Excel 2007
Fecha de inscripción : 16/11/2008

Volver arriba Ir abajo

Re: BuscarV Multiple con Mas de un criterio o condicion

Mensaje por Contenido patrocinado Hoy a las 11:28 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.