............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Funcion INDICE COINCIDIR + SUMA

Ver el tema anterior Ver el tema siguiente Ir abajo

Funcion INDICE COINCIDIR + SUMA

Mensaje por T_tortilla el Lun Mar 09, 2009 11:23 am

Saludos al foro

Hace poco he descubierto este foro y la verdad es de lo mejorcito en cuanto al interes por ayudar y no comercializar.

Paso a mi pregunta, mediante esta formula pretendo verificar que cantidad corresponde a la condicion COINCIDIR

=SI(AY3="Vacio";0;SI(SI.ERROR(AV3;0)=0;0;-INDICE($AW$3:$AX$21;COINCIDIR(AY3;$AW$3:$AW$21;0);2)))

El caso es que si hay mas de una coincidencia, necesitaria que me las sumara. Algun consejo, o quizas la solucion

Gracias por adelantado por vuestra ayuda

Txomin

T_tortilla

Masculino Cantidad de envíos : 3
Edad : 57
Ciudad - Pais : España
Version de Excel : 2007
Fecha de inscripción : 04/03/2009

Volver arriba Ir abajo

Re: Funcion INDICE COINCIDIR + SUMA

Mensaje por GalileoGali el Mar Mar 10, 2009 7:02 am

Resulta bastante complicado imaginar tu tabla pero, de todas maneras, mas alla de tus condicionales, para sumar con condiciones nada mejor que SUMAPRODUCTO, lo probaste?
Cuelga un archivo en skydrive y pega el link
o Utiliza ExcelJeannie

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Funcion INDICE COINCIDIR + SUMA

Mensaje por T_tortilla el Mar Mar 10, 2009 1:14 pm

Pues no, GalileoGali, me pongo a ello.

Los condicionales son ... quizas por mi inexperiencia ... para verificar la condicion y en caso error no estropear la legilibilidad del resulatado.

Soy autodidacta en esto y probablemente los que estais habituados seais capaces de simplificar por vuestra capacidad espacial.

Lo cierto es que mis libros 'pesan' mucho y tardan cierto tiempo en actualizar. Y eso con doble nucleo a 2400+. Vengo de Quatro y tengo malos vicios.

Un saludo muy cordial.


PD Por cierto mejor Excel 2007 con SO 64 bits o da igual

".. todos somos ignorantes, lo que ocurre es que no ignoramos las mismas cosas."

T_tortilla

Masculino Cantidad de envíos : 3
Edad : 57
Ciudad - Pais : España
Version de Excel : 2007
Fecha de inscripción : 04/03/2009

Volver arriba Ir abajo

Re: Funcion INDICE COINCIDIR + SUMA

Mensaje por Contenido patrocinado Hoy a las 12:36 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.