............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

tablas de doble entrada

Ver el tema anterior Ver el tema siguiente Ir abajo

tablas de doble entrada

Mensaje por dariobre el Jue Mayo 21, 2009 6:43 pm

Cual es la forma más facil de extraer un dato de una tabla de dos entradas ?

Lotus tiene una función @INTERSECCION(rango,titulo columna,titulo fila)
Excel tiene alguna parecida ?

Saludos.

Darío

dariobre

Masculino Cantidad de envíos : 14
Edad : 41
Ciudad - Pais : santa fe - argentina
Version de Excel : 2003
Fecha de inscripción : 19/05/2009

Volver arriba Ir abajo

Re: tablas de doble entrada

Mensaje por GalileoGali el Jue Mayo 21, 2009 7:59 pm

Con las funciones Nativas de Excel, no es tan directo. Obviamente una funcion como la que maneja Lotus se puede construir, pero con formulas algo equivalente es esto

Hoja1

 ABCDE
1 GeografiaMatemáticasQuimicaFísica
2Sanchez81018
3Ramirez07105
4Perez5278
5Alvarez5899
6Fernandez2916
7     
8BuscarRamirez   
9 Matemáticas   
10 7   
Spreadsheet Formulas
CellFormula
B10=INDICE(B2:E6;COINCIDIR(B8;A2:A6;0);COINCIDIR(B9;B1:E1;0))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: tablas de doble entrada

Mensaje por ve0475 el Vie Mayo 22, 2009 9:11 am

Muchas gracias, ante todo.
Aparentamente en "B2" si funciona, pero en el resto de celdas no consigo que funcione, adjunto ejemplo.
Plantilla

 ABCDEF
1 1111222244443333 
2710518.138.896,33  10.721.893,31 
37110     
47115#N/A    
57330#¡REF!    
6      
7      
Spreadsheet Formulas
CellFormula
B2=INDICE(datos!$B$2:$D$11;COINCIDIR(B$1;datos!$B$1:$D$1;0);COINCIDIR($A2;datos!$A$2:$A$11;0))
E2=INDICE(datos!$B$2:$D$11;COINCIDIR(E$1;datos!$B$1:$D$1;0);COINCIDIR($A2;datos!$A$2:$A$11;0))
B4=INDICE(datos!$B$2:$D$11;COINCIDIR(B$1;datos!$B$1:$D$1;0);COINCIDIR($A4;datos!$A$2:$A$11;0))
B5=INDICE(datos!$B$2:$D$11;COINCIDIR(B$1;datos!$B$1:$D$1;0);COINCIDIR($A5;datos!$A$2:$A$11;0))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

la base de datos seria esta:
datos

 ABCD
1 111133332222
2710518.138.896,33389.935.058,4640.369.085,64
3711510.721.893,3178.917.194,9618.646.471,89
473050,001.792.227,650,00
57330555.555,000,000,00
673350,000,000,00
773500,000,000,00
873550,001.792.227,650,00
97440198.178,133.179.881,31279.504,74
107450125.153,782.311.076,68279.504,74
1174550,00-870.957,190,00


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


Gracias de nuevo.

ve0475

Masculino Cantidad de envíos : 14
Edad : 36
Ciudad - Pais : madrid
Version de Excel : 2003
Fecha de inscripción : 26/03/2009

Volver arriba Ir abajo

Re: tablas de doble entrada

Mensaje por dariobre el Vie Mayo 22, 2009 10:36 am

me parece que el error es que en INDICE tomaste que consulte primero en las filas y depues en las columnas y es primero las columnas y despues las filas

=INDICE(datos!$B$2:$D$11;COINCIDIR($A2;datos!$A$2:$A$11;0);COINCIDIR(B$1;datos!$B$1:$D$1;0))

Saludos

dariobre

Masculino Cantidad de envíos : 14
Edad : 41
Ciudad - Pais : santa fe - argentina
Version de Excel : 2003
Fecha de inscripción : 19/05/2009

Volver arriba Ir abajo

Re: tablas de doble entrada

Mensaje por dariobre el Vie Mayo 22, 2009 10:38 am

perdón, la formula es para la celda B2

Saludos

dariobre

Masculino Cantidad de envíos : 14
Edad : 41
Ciudad - Pais : santa fe - argentina
Version de Excel : 2003
Fecha de inscripción : 19/05/2009

Volver arriba Ir abajo

Re: tablas de doble entrada

Mensaje por dariobre el Vie Mayo 22, 2009 11:51 am

Existe alguna forma haciendo mención solo al rango de busqueda (base de datos).

Porque de esta manera le tengo que generar nombres también a la fila y a la colmna de títulos de cada rango (base de datos)

son muchos y los tengo en un archivo aparte

Saludos.

dariobre

Masculino Cantidad de envíos : 14
Edad : 41
Ciudad - Pais : santa fe - argentina
Version de Excel : 2003
Fecha de inscripción : 19/05/2009

Volver arriba Ir abajo

Re: tablas de doble entrada

Mensaje por ve0475 el Lun Mayo 25, 2009 5:14 am

Buenos días, comprobado y funciona.
Solo me queda depurar, que en caso de error, me ponga "Blanco", (en la función BUSCARV si lo hago funcionar, pero aquí se me resite).

Muchas gracias y un saludo.

ve0475

Masculino Cantidad de envíos : 14
Edad : 36
Ciudad - Pais : madrid
Version de Excel : 2003
Fecha de inscripción : 26/03/2009

Volver arriba Ir abajo

Re: tablas de doble entrada

Mensaje por GalileoGali el Lun Mayo 25, 2009 9:46 am

Escribe la formula que usas con Buscarv...

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: tablas de doble entrada

Mensaje por ve0475 el Mar Mayo 26, 2009 5:26 am

Conseguido, como bien dices, usandola igual que en Buscarv va de maravilla, al no salir la primera vez por tema de parentesis, luego se lía uno de mala manera, y me sálía por los "Cerros de Ubeda".

Gracias a todos por vuestra colaboración y mantener este FORO, os tendré presente para futuras dudas.

ve0475

Masculino Cantidad de envíos : 14
Edad : 36
Ciudad - Pais : madrid
Version de Excel : 2003
Fecha de inscripción : 26/03/2009

Volver arriba Ir abajo

Re: tablas de doble entrada

Mensaje por dariobre el Mar Mayo 26, 2009 10:30 am

ve0475: Como es la formula usas para consultar con buscarv en una tabla de 2 entradas?

Saludos.

Darío

dariobre

Masculino Cantidad de envíos : 14
Edad : 41
Ciudad - Pais : santa fe - argentina
Version de Excel : 2003
Fecha de inscripción : 19/05/2009

Volver arriba Ir abajo

Re: tablas de doble entrada

Mensaje por ve0475 el Miér Mayo 27, 2009 3:20 am

Buenos días Dariobre, te adjunto fichero con la formula en "B3" y "D2", el resto las he borrado para no recargar el fichero, lo he comprobadi y funciona en todos los casos.
Saludos.
Plantilla

 D
14 


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

ve0475

Masculino Cantidad de envíos : 14
Edad : 36
Ciudad - Pais : madrid
Version de Excel : 2003
Fecha de inscripción : 26/03/2009

Volver arriba Ir abajo

Re: tablas de doble entrada

Mensaje por ve0475 el Miér Mayo 27, 2009 3:22 am

Perdón, parece que no subí bien el fichero, creo que ahora si.


Plantilla

 ABCDE
1 1111222244443333
2710518.138.896,3340.369.085,64  
37110    
4711510.721.893,31   
57330555.555,00   
Spreadsheet Formulas
CellFormula
B2=INDICE(datos!$B$2:$D$11;COINCIDIR($A2;datos!$A$2:$A$11;0);COINCIDIR(B$1;datos!$B$1:$D$1;0))
C2=INDICE(datos!$B$2:$D$11;COINCIDIR($A2;datos!$A$2:$A$11;0);COINCIDIR(C$1;datos!$B$1:$D$1;0))
D2=SI(ESERROR(INDICE(datos!$B$2:$D$11;COINCIDIR($A2;datos!$A$2:$A$11;0);COINCIDIR(D$1;datos!$B$1:$D$1;0)));" ";INDICE(datos!$B$2:$D$11;COINCIDIR($A2;datos!$A$2:$A$11;0);COINCIDIR(D$1;datos!$B$1:$D$1;0)))
B3=SI(ESERROR(INDICE(datos!$B$2:$D$11;COINCIDIR($A3;datos!$A$2:$A$11;0);COINCIDIR(B$1;datos!$B$1:$D$1;0)));" ";INDICE(datos!$B$2:$D$11;COINCIDIR($A3;datos!$A$2:$A$11;0);COINCIDIR(B$1;datos!$B$1:$D$1;0)))
B4=INDICE(datos!$B$2:$D$11;COINCIDIR($A4;datos!$A$2:$A$11;0);COINCIDIR(B$1;datos!$B$1:$D$1;0))
B5=INDICE(datos!$B$2:$D$11;COINCIDIR($A5;datos!$A$2:$A$11;0);COINCIDIR(B$1;datos!$B$1:$D$1;0))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

ve0475

Masculino Cantidad de envíos : 14
Edad : 36
Ciudad - Pais : madrid
Version de Excel : 2003
Fecha de inscripción : 26/03/2009

Volver arriba Ir abajo

Re: tablas de doble entrada

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.