............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

función comparativa doble

Ver el tema anterior Ver el tema siguiente Ir abajo

función comparativa doble

Mensaje por Martagen el Vie Mayo 22, 2009 3:33 am

Hola, tengo una tabla como la siguiente y quisiera rellenarla de datos, los cuales estan en otra hoja excel. como lo hago?
estaciones de muestreo (en columnas) estacion 1, estacion 2 etc.
tipo de especie(en filas)
1 12 ejemplares 17
2 27 14
3 14 33
4 21 12
5 11 43


Tengo una base de datos con las estaciones, las especies que aparecen en cada estacion y el numero de especies de cada estacion. Es algo asi como que si la especie 1 aparece en la base de datos en la estacion 1 entonces quiero que me introduzca en la tabla el numero de la especie 1 que aparece en la estacion 1 (el numero de especies que hay en dicha estacion)\\

Gracias de antemano a todos!!!

Martagen

Femenino Cantidad de envíos : 11
Edad : 33
Ciudad - Pais : SPAIN
Version de Excel : 2003
Fecha de inscripción : 22/05/2009

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por GalileoGali el Vie Mayo 22, 2009 6:50 am

Mira tus explicaciones pueden lograr el propósito deseado si subes un xls (utiliza skydrive o esnips)

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por GalileoGali el Vie Mayo 22, 2009 7:05 am

Presupongo que con BUSCARV, podrias lograr lo que describes, pero seria mejor VER un xls

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por Martagen el Lun Mayo 25, 2009 4:47 am

hola!!! gracias por tu respuesta, siento la demora en contestar pero no tengo internet los fines de semana.

Aqui te envio un ejemplo de mi caso para ver si así me explico mejor.

yo lo que tengo en mi base de datos tiene este aspecto:
[Tienes que estar registrado y conectado para ver este vínculo]


Y lo que intento conseguir es esto otro:

[Tienes que estar registrado y conectado para ver este vínculo]

asi, si una especie aparece en una de las estaciones, automáticamente en la tabla del ejemplo 2 querria que me apareciese su densidad (valor que se obtiene de la tabla del ejemplo1), de no existir ningún valor para esa especie en la estación, el valor de densidad que aparecerá en la tabla del ejemplo 2 seria cero.

Muchisimas gracias de antemano por vuestra ayuda!!!

Martagen

Femenino Cantidad de envíos : 11
Edad : 33
Ciudad - Pais : SPAIN
Version de Excel : 2003
Fecha de inscripción : 22/05/2009

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por GalileoGali el Lun Mayo 25, 2009 8:42 am

Podes probar adaptando esto:
[Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por GalileoGali el Lun Mayo 25, 2009 8:48 am

Aqui encuentras otro ejemplo, quizas, mas cercano a tu caso:

[Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por Martagen el Lun Mayo 25, 2009 11:20 am

Hola, gracias por el link pero la verdad es que no consigo hacerlo porque en el caso del ejemplo el valor que te da como codigo es mas de uno y en mi caso el valor es unico, además no entiendo por que utiliza la función K.ESIMO.MENOR ya que yo no quiero el menor valor sino el unico valor que surje de la sumaproducto de dos columnas. no se que mas hacer!!!

alguna sugerencia más por favor!!!???

Martagen

Femenino Cantidad de envíos : 11
Edad : 33
Ciudad - Pais : SPAIN
Version de Excel : 2003
Fecha de inscripción : 22/05/2009

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por Martagen el Lun Mayo 25, 2009 11:22 am

no habia visto en segundo link, gracias, voy a probarlo!!!

marta

Martagen

Femenino Cantidad de envíos : 11
Edad : 33
Ciudad - Pais : SPAIN
Version de Excel : 2003
Fecha de inscripción : 22/05/2009

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por Martagen el Lun Mayo 25, 2009 12:12 pm

nada que no lo consigo, joooooo

Martagen

Femenino Cantidad de envíos : 11
Edad : 33
Ciudad - Pais : SPAIN
Version de Excel : 2003
Fecha de inscripción : 22/05/2009

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por GalileoGali el Lun Mayo 25, 2009 12:32 pm

Hoja1

 ABCDE
1Estación1Especie10  
2Estación1Especie27  
3Estación2Especie335  
4Estación2Especie448  
5Estación3Especie122  
6Estación3Especie230  
7Estación4Especie35  
8Estación4Especie438  
9     
10     
11 Especie1Especie2Especie3Especie4
12Estación10700
13Estación2003548
14Estación3223000
15Estación400538
Spreadsheet Formulas
CellFormula
B12{=SI(ESNOD(BUSCARV($A12;INDICE(SI($B$1:$B$8=B$11;$A$1:$C$8);0);3;0));0;BUSCARV($A12;INDICE(SI($B$1:$B$8=B$11;$A$1:$C$8);0);3;0))}
C12{=SI(ESNOD(BUSCARV($A12;INDICE(SI($B$1:$B$8=C$11;$A$1:$C$8);0);3;0));0;BUSCARV($A12;INDICE(SI($B$1:$B$8=C$11;$A$1:$C$8);0);3;0))}
D12{=SI(ESNOD(BUSCARV($A12;INDICE(SI($B$1:$B$8=D$11;$A$1:$C$8);0);3;0));0;BUSCARV($A12;INDICE(SI($B$1:$B$8=D$11;$A$1:$C$8);0);3;0))}
E12{=SI(ESNOD(BUSCARV($A12;INDICE(SI($B$1:$B$8=E$11;$A$1:$C$8);0);3;0));0;BUSCARV($A12;INDICE(SI($B$1:$B$8=E$11;$A$1:$C$8);0);3;0))}
B13{=SI(ESNOD(BUSCARV($A13;INDICE(SI($B$1:$B$8=B$11;$A$1:$C$8);0);3;0));0;BUSCARV($A13;INDICE(SI($B$1:$B$8=B$11;$A$1:$C$8);0);3;0))}
C13{=SI(ESNOD(BUSCARV($A13;INDICE(SI($B$1:$B$8=C$11;$A$1:$C$8);0);3;0));0;BUSCARV($A13;INDICE(SI($B$1:$B$8=C$11;$A$1:$C$8);0);3;0))}
D13{=SI(ESNOD(BUSCARV($A13;INDICE(SI($B$1:$B$8=D$11;$A$1:$C$8);0);3;0));0;BUSCARV($A13;INDICE(SI($B$1:$B$8=D$11;$A$1:$C$8);0);3;0))}
E13{=SI(ESNOD(BUSCARV($A13;INDICE(SI($B$1:$B$8=E$11;$A$1:$C$8);0);3;0));0;BUSCARV($A13;INDICE(SI($B$1:$B$8=E$11;$A$1:$C$8);0);3;0))}
B14{=SI(ESNOD(BUSCARV($A14;INDICE(SI($B$1:$B$8=B$11;$A$1:$C$8);0);3;0));0;BUSCARV($A14;INDICE(SI($B$1:$B$8=B$11;$A$1:$C$8);0);3;0))}
C14{=SI(ESNOD(BUSCARV($A14;INDICE(SI($B$1:$B$8=C$11;$A$1:$C$8);0);3;0));0;BUSCARV($A14;INDICE(SI($B$1:$B$8=C$11;$A$1:$C$8);0);3;0))}
D14{=SI(ESNOD(BUSCARV($A14;INDICE(SI($B$1:$B$8=D$11;$A$1:$C$8);0);3;0));0;BUSCARV($A14;INDICE(SI($B$1:$B$8=D$11;$A$1:$C$8);0);3;0))}
E14{=SI(ESNOD(BUSCARV($A14;INDICE(SI($B$1:$B$8=E$11;$A$1:$C$8);0);3;0));0;BUSCARV($A14;INDICE(SI($B$1:$B$8=E$11;$A$1:$C$8);0);3;0))}
B15{=SI(ESNOD(BUSCARV($A15;INDICE(SI($B$1:$B$8=B$11;$A$1:$C$8);0);3;0));0;BUSCARV($A15;INDICE(SI($B$1:$B$8=B$11;$A$1:$C$8);0);3;0))}
C15{=SI(ESNOD(BUSCARV($A15;INDICE(SI($B$1:$B$8=C$11;$A$1:$C$8);0);3;0));0;BUSCARV($A15;INDICE(SI($B$1:$B$8=C$11;$A$1:$C$8);0);3;0))}
D15{=SI(ESNOD(BUSCARV($A15;INDICE(SI($B$1:$B$8=D$11;$A$1:$C$8);0);3;0));0;BUSCARV($A15;INDICE(SI($B$1:$B$8=D$11;$A$1:$C$8);0);3;0))}
E15{=SI(ESNOD(BUSCARV($A15;INDICE(SI($B$1:$B$8=E$11;$A$1:$C$8);0);3;0));0;BUSCARV($A15;INDICE(SI($B$1:$B$8=E$11;$A$1:$C$8);0);3;0))}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por Martagen el Lun Mayo 25, 2009 1:05 pm

Hola, siento molestar de nuevo, gracias por todo el esfuerzo pero no me sale aun. Resulta que tengo los datos en otra hoja y entonces al copiar las formulas que me has escrito cambiando las hojas, no me sale. No puedo poner todo en la misma hoja porque la base de datos es muy grande y no se puede añadir.
Esto es lo que he escrito y me da error:

=SI(ESNOD(BUSCARV(Hoja1!$A1;INDICE(SI(Hoja2!$B$2:Hoja2!$B$29203=Hoja1!A$2;Hoja2!$A$2:Hoja2!$C$29203);0);3;0));0;BUSCARV(Hoja1!$A2;INDICE(SI(Hoja2!$B$2:Hoja2!$B$29203=Hoja1!A$2;Hoja2!$A$2:Hoja2!$C$29203);0;3;0))

cualquier sujerencia por favor!!!

gracias

Martagen

Femenino Cantidad de envíos : 11
Edad : 33
Ciudad - Pais : SPAIN
Version de Excel : 2003
Fecha de inscripción : 22/05/2009

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por GalileoGali el Lun Mayo 25, 2009 1:59 pm

El error es visible, pero te sugiero este truco: escribe la formula para un par de "coordenadas", e anlgun lugar de la Hoja que tiene los datos (una celda alcanza, con la fromula basica. Luego seleccionando las referencias mas la celda de la Formula, la cortas y la pegas en la otra hoja...
Excel se ocupara de acomodar tus referencias en forma automatica

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por Martagen el Lun Mayo 25, 2009 2:27 pm

pero en la formula tengo que poner las celdas y eso es lo que esta en otra hoja, sorry, no te entiendo!!!

Martagen

Femenino Cantidad de envíos : 11
Edad : 33
Ciudad - Pais : SPAIN
Version de Excel : 2003
Fecha de inscripción : 22/05/2009

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por Martagen el Lun Mayo 25, 2009 2:45 pm

lo estoy intentando , lo que me has dicho pero en la fórmula al insertar el primer SI(ESNOD(BUSCARV($A12 me dice que ese $A12 no me lo reconoce, ¿por qué puede ser? me da error y la formula se para ahi.

Gracias!!!

Martagen

Femenino Cantidad de envíos : 11
Edad : 33
Ciudad - Pais : SPAIN
Version de Excel : 2003
Fecha de inscripción : 22/05/2009

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por GalileoGali el Lun Mayo 25, 2009 3:51 pm

Lamento, pero de la adaptacion tenés / tienes que ocuparte vos /tú

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por Martagen el Miér Mayo 27, 2009 4:38 am

tras un dia entero al final lo he logrado!!! muchisimas gracias por toda tu ayuda de verdad!!! eres un crack!!! GRACIAS!!!

Martagen

Femenino Cantidad de envíos : 11
Edad : 33
Ciudad - Pais : SPAIN
Version de Excel : 2003
Fecha de inscripción : 22/05/2009

Volver arriba Ir abajo

Re: función comparativa doble

Mensaje por Contenido patrocinado Hoy a las 12:37 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.