............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Busqueda del segundo numero mayor con condicion

Ver el tema anterior Ver el tema siguiente Ir abajo

Busqueda del segundo numero mayor con condicion

Mensaje por principe24 el Jue Mayo 28, 2009 1:51 pm

Buenas tardes,
se me presento un nuevo problema y me he calentado el mate pero no lo logro... mi problema es el siguiente:
Necesito encontrar el segundo valor mayor, como lo hace la función k.esimo.mayor(X1:X10;2) pero además necesito agregar a esto una condición "a"... Eje.

___A___B

1__A___5
2__A___7
3__A___1
4__B___20
5__C___40
6__A___2

El resultado seria =7, que es el número mayor de la condición "a".

Saludos

principe24

Masculino Cantidad de envíos : 20
Edad : 32
Ciudad - Pais : Chile
Version de Excel : 97
Fecha de inscripción : 06/05/2009

Volver arriba Ir abajo

Re: Busqueda del segundo numero mayor con condicion

Mensaje por GalileoGali el Jue Mayo 28, 2009 2:13 pm

He revisado mas de una vez mi formula para ver porque no da 7, que manera de perder tiempo, pero bueno, a mi me da 5, salvo que no interprete las cosas como son......

Hoja1

 ABCD
1A5 5
2A7  
3A1  
4B20  
5C40  
6A2  
Spreadsheet Formulas
CellFormula
D1=K.ESIMO.MAYOR(INDICE((A1:A6="A")*B1:B6;0);2)


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Busqueda del segundo numero mayor con condicion

Mensaje por principe24 el Jue Mayo 28, 2009 4:02 pm

Tienes toda la razon... confundi con el maximo, perdon.
Nuevamente y como siempre muchas gracias por tus respuestas y por darte el tiempo de responder a nuetros problemas.
Eres gran aporte a las personas.

Saludos
Marcos

principe24

Masculino Cantidad de envíos : 20
Edad : 32
Ciudad - Pais : Chile
Version de Excel : 97
Fecha de inscripción : 06/05/2009

Volver arriba Ir abajo

Re: Busqueda del segundo numero mayor con condicion

Mensaje por principe24 el Miér Jun 03, 2009 11:08 am

Hola buen día...
Pregunta si el símbolo "*", que es la multiplicación, funciona como una "Y". Que símbolo se utiliza para "O"?
No se si es realmente así, pero es como lo visualizo. Utilice el "+" y "O()"pero no me funciona para dar varias condiciones validas en la función de K.esimo.mayor que me entregaste.

Saludos

principe24

Masculino Cantidad de envíos : 20
Edad : 32
Ciudad - Pais : Chile
Version de Excel : 97
Fecha de inscripción : 06/05/2009

Volver arriba Ir abajo

Re: Busqueda del segundo numero mayor con condicion

Mensaje por GalileoGali el Miér Jun 03, 2009 1:54 pm

la suma de vectores "+" resuelve muchos de los casos, pero hay que ver tu caso, en forma concreta, para poder aplicar, si corresponde....

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Busqueda del segundo numero mayor con condicion

Mensaje por principe24 el Miér Jun 03, 2009 3:19 pm

Esta es la formula que ocupo, pero no sirve, no discrimina los meses que indico...
De esta manera busco sacar el K.esimo.mayor del 1 al 30, segun las condiciones.
Intente con "+" y "O()", pero ninguna a funcionado bien.

R1 = SI(E1="q1";K.ESIMO.MAYOR(INDICE(O((A1:A9="enero");(A1:A9="febrero");(A1:A9="marzo"))*(C1:C9=9)*(D1:D9="oc")*B1:B9;0);2);"")

R2 = SI(E1="q2";K.ESIMO.MAYOR(INDICE(O((A1:A9="octubre");(A1:A9="noviembre");(A1:A9="diciembre"))*(C1:C9=8)*(D1:D9="oc")*B1:B9;0);2);"")
______A________B____C____D_____E______F

1___enero______ 10___9____oc____Q1_____R1 = 10
2___diciembre___ 8____8____oc___________R2 = 7
3___enero______ 5____9____oc
4___octubre____ 1____8____oc
5___febrero_____12___9____oc
6___mayo______ 4____9____oc
7___noviembre___7____9____oc
8___junio_______9____9____oc
9___febrero_____8____9____oc

Saludos

principe24

Masculino Cantidad de envíos : 20
Edad : 32
Ciudad - Pais : Chile
Version de Excel : 97
Fecha de inscripción : 06/05/2009

Volver arriba Ir abajo

Re: Busqueda del segundo numero mayor con condicion

Mensaje por GalileoGali el Miér Jun 03, 2009 6:45 pm

Hoja1

 ABCDEF
1enero109oc 10
2diciembre88oc  
3enero59oc 1
4octubre18oc  
5febrero129oc  
6mayo49oc  
7noviembre79oc  
8junio99oc  
9febrero89oc  
Spreadsheet Formulas
CellFormula
F1=K.ESIMO.MAYOR(INDICE((A1:A9={"enero";"febrero";"marzo"})*(C1:C9=9)*(D1:D9="oc")*B1:B9;0);2)
F3=K.ESIMO.MAYOR(INDICE((A1:A9={"octubre";"noviembre";"diciembre"})*(C1:C9=8)*(D1:D9="oc")*B1:B9;0);2)


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

Ya no perdi el tiempo tratando de ver porque no R2 = me da 1 y no 7 como a vos, simplemente porque descarto toda confiabilidad/precision en tus resultados

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Busqueda del segundo numero mayor con condicion

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.