............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Seleccion aleatoria

Ver el tema anterior Ver el tema siguiente Ir abajo

Seleccion aleatoria

Mensaje por azuki88 el Miér Jun 03, 2009 1:58 pm

buenos dias...

necesito que me ayuden...
lo ke pasa es ke tengo que hacer una encuesta... donde me dan 20 preguntas... pero...
al momento de hacer la encuesta el excel solo elija 10 de esas 20 preguntas aleatoriamente....


espero su apoyo....

azuki88

Femenino Cantidad de envíos : 2
Edad : 29
Ciudad - Pais : santiago, chile
Version de Excel : 2003
Fecha de inscripción : 03/06/2009

Volver arriba Ir abajo

Re: Seleccion aleatoria

Mensaje por GalileoGali el Miér Jun 03, 2009 7:00 pm

Hoja1

 ABC
1A953,773074 
2B680,762944 
3C356,9466759
4D953,706742 
5E392,29794110
6F984,117085 
7G727,935262 
8H868,862138 
9I89,92237793
10J787,578208 
11K30,33317791
12L860,395035 
13M282,4419238
14N67,81278512
15O431,065215 
16P135,1438835
17Q170,184616
18R876,507378 
19S241,8797267
20T134,9658154
Spreadsheet Formulas
CellFormula
B1=ALEATORIO()*1000
C1=SI(JERARQUIA(B1;$B$1:$B$20;-1)>10;"";JERARQUIA(B1;$B$1:$B$20;-1))
B2=ALEATORIO()*1000
C2=SI(JERARQUIA(B2;$B$1:$B$20;-1)>10;"";JERARQUIA(B2;$B$1:$B$20;-1))
B3=ALEATORIO()*1000
C3=SI(JERARQUIA(B3;$B$1:$B$20;-1)>10;"";JERARQUIA(B3;$B$1:$B$20;-1))
B4=ALEATORIO()*1000
C4=SI(JERARQUIA(B4;$B$1:$B$20;-1)>10;"";JERARQUIA(B4;$B$1:$B$20;-1))
B5=ALEATORIO()*1000
C5=SI(JERARQUIA(B5;$B$1:$B$20;-1)>10;"";JERARQUIA(B5;$B$1:$B$20;-1))
B6=ALEATORIO()*1000
C6=SI(JERARQUIA(B6;$B$1:$B$20;-1)>10;"";JERARQUIA(B6;$B$1:$B$20;-1))
B7=ALEATORIO()*1000
C7=SI(JERARQUIA(B7;$B$1:$B$20;-1)>10;"";JERARQUIA(B7;$B$1:$B$20;-1))
B8=ALEATORIO()*1000
C8=SI(JERARQUIA(B8;$B$1:$B$20;-1)>10;"";JERARQUIA(B8;$B$1:$B$20;-1))
B9=ALEATORIO()*1000
C9=SI(JERARQUIA(B9;$B$1:$B$20;-1)>10;"";JERARQUIA(B9;$B$1:$B$20;-1))
B10=ALEATORIO()*1000
C10=SI(JERARQUIA(B10;$B$1:$B$20;-1)>10;"";JERARQUIA(B10;$B$1:$B$20;-1))
B11=ALEATORIO()*1000
C11=SI(JERARQUIA(B11;$B$1:$B$20;-1)>10;"";JERARQUIA(B11;$B$1:$B$20;-1))
B12=ALEATORIO()*1000
C12=SI(JERARQUIA(B12;$B$1:$B$20;-1)>10;"";JERARQUIA(B12;$B$1:$B$20;-1))
B13=ALEATORIO()*1000
C13=SI(JERARQUIA(B13;$B$1:$B$20;-1)>10;"";JERARQUIA(B13;$B$1:$B$20;-1))
B14=ALEATORIO()*1000
C14=SI(JERARQUIA(B14;$B$1:$B$20;-1)>10;"";JERARQUIA(B14;$B$1:$B$20;-1))
B15=ALEATORIO()*1000
C15=SI(JERARQUIA(B15;$B$1:$B$20;-1)>10;"";JERARQUIA(B15;$B$1:$B$20;-1))
B16=ALEATORIO()*1000
C16=SI(JERARQUIA(B16;$B$1:$B$20;-1)>10;"";JERARQUIA(B16;$B$1:$B$20;-1))
B17=ALEATORIO()*1000
C17=SI(JERARQUIA(B17;$B$1:$B$20;-1)>10;"";JERARQUIA(B17;$B$1:$B$20;-1))
B18=ALEATORIO()*1000
C18=SI(JERARQUIA(B18;$B$1:$B$20;-1)>10;"";JERARQUIA(B18;$B$1:$B$20;-1))
B19=ALEATORIO()*1000
C19=SI(JERARQUIA(B19;$B$1:$B$20;-1)>10;"";JERARQUIA(B19;$B$1:$B$20;-1))
B20=ALEATORIO()*1000
C20=SI(JERARQUIA(B20;$B$1:$B$20;-1)>10;"";JERARQUIA(B20;$B$1:$B$20;-1))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

La columna "B", bien podria ocultarse, por razones de mejor presentacion....

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Seleccion aleatoria

Mensaje por azuki88 el Miér Jun 10, 2009 1:25 pm

igual me sirve, gracias...
pero se ven los numeros y necesito que se vean las preguntas en otra hoja

azuki88

Femenino Cantidad de envíos : 2
Edad : 29
Ciudad - Pais : santiago, chile
Version de Excel : 2003
Fecha de inscripción : 03/06/2009

Volver arriba Ir abajo

Re: Seleccion aleatoria

Mensaje por ioyama el Jue Jun 11, 2009 6:26 am

Hola azuki88

Es de suponer que tendrás el listado de preguntas, luego numeralas en la columna anterior (o posterior, da igual lo que cambiará será la función a utilizra) y con usar BUSCARV usando como parámetro el número aleatorio que te genera la función proporcionada por Gali te será suficiente (INDICE y COINCIDIR si pones los números a la derecha).

Ahora bien si la idea es seguir trabajando sobre la misma hoja deberas copiar las preguntas obtenidas con BUSCARV y pegralas sobresí mismas como Valores, de lo contrario cada cambio en la hoja te generará nuevos aleatorios.

Un saludo desde Vitoria

ioyama
Moderador
Moderador

Masculino Cantidad de envíos : 128
Edad : 54
Ciudad - Pais : Vitoria (España)
Fecha de inscripción : 03/03/2008

Volver arriba Ir abajo

Re: Seleccion aleatoria

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.