............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Agrupar datos que estan separados por filas vacías.

Ver el tema anterior Ver el tema siguiente Ir abajo

Agrupar datos que estan separados por filas vacías.

Mensaje por pedrosilv el Miér Jun 10, 2009 3:04 pm

Hola de nuevo a todos,

Quisiera ver quien me puede ayudar con la siguiente duda.

Por ejemplo, a lo largo de la columna B tengo varios datos, pero estan espaciados, es decir, en la celda B1 tengo el numero 5, en la celda B6 tengo el número 7, en la B10 tengo el número 2. Lo que quisiera hacer, es saber si mediante alguna fórmula o función,puedo hacer que excel me una esos datos o elimine las celdas que estan vacías, de modo que los números ya no queden separados. En este caso, quisiera que en la columna C, a partir de la celda C2, se vayan anotando los distintos números que aparecían dispersos a lo largo de la columna B.

Espero haberme dado a entender, y que alguno de ustedes me pueda ayudar a resolver dicha duda.

De antemano, muchas gracias, y saludos desde Guatemala.

Att. Pedro Silvestre
avatar
pedrosilv

Masculino Cantidad de envíos : 85
Edad : 32
Ciudad - Pais : Guatemala
Version de Excel : 2003-2007
Fecha de inscripción : 16/04/2009

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por jairga el Miér Jun 10, 2009 3:39 pm

Algo rapido:
situate en la celda B1 ta vas al menu Edición, comando Ir a...,le das en especial, seleccionas celdas en blanco y aceptar, te ha seleccionado las celdas vacias le das entonces tecla (control más el signo -) (signo menos) despues te muestra eliminar celdas , desplazar las celdas hacia arriba y aceptar y listo

espero haberte ayudado

saludos

jairga
Moderador
Moderador

Masculino Cantidad de envíos : 163
Edad : 40
Ciudad - Pais : Cartagena-Barranquilla(Colombia)
Version de Excel : XP-2003-2007
Fecha de inscripción : 11/03/2008

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por pedrosilv el Jue Jun 11, 2009 11:27 am

Gracias por el tip Jairga... ese truco no lo sabía, voy a probarlo.

Te cuento, estoy diseñañdo una hoja para hacer unos cálculos, de modo que quien haga uso de ella, solo necesite introducir sus datos, y luego ver sus resultados, pero para ello, se hacen muchos cálculos y diversos procedimientos. Y es en uno de esos pasos intermedios en el que estoy atorado, ya que necesito hacer que excel automáticamente me elimine esas celdas en blanco, para luego proseguir con el resto de procedimientos previos a llegar al resultado requerido.

MMM, no me gusta trabajar con macros, ya que no los domino, y por eso preguntaba si existe la posibilidad de hacer eso solo con combinación de fórmulas y/o funciones.

De nuevo, muchas gracias por la ayuda, y espero que alguien pueda darme otra mano..

Saludos
avatar
pedrosilv

Masculino Cantidad de envíos : 85
Edad : 32
Ciudad - Pais : Guatemala
Version de Excel : 2003-2007
Fecha de inscripción : 16/04/2009

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por jairga el Jue Jun 11, 2009 11:34 am

Creo que cuando dices que excel lo haga automaticamente no tendras otra opcion que utilizar macros y la ayuda de algun evento de la hoja. pero sin ver lo que quires conseguir es dificil darte una respuesta acertada y seguiremos lanzando dardos al blanco, hasta quizas poder dar con el objetivo.

saludos

jairga
Moderador
Moderador

Masculino Cantidad de envíos : 163
Edad : 40
Ciudad - Pais : Cartagena-Barranquilla(Colombia)
Version de Excel : XP-2003-2007
Fecha de inscripción : 11/03/2008

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por ioyama el Jue Jun 11, 2009 6:27 pm

Hola Pedro

Puedes usar algo como

=INDICE($B$1:$B$10;K.ESIMO.MENOR(SI(ESNOD(COINCIDIR($B$1:$B$10;$B$1:$B$10;0));"";COINCIDIR($A$2:$A$8;$A$2:$A$8;0));FILA(INDIRECTO("1:"&FILAS($B$1:$B$10)))))
introducida matricialmente

Una vez introducida la formula, seleccionas un rango suficente para que te entren todos tus valores (incluyendo la celda donde has puesto la fórmula, la primera del rango).
Pulsa F2 para entrar en modo edición.
Pulsas Control+Mayúsculas+Intro, la fórmula queda introducida matricialmente (te aparecerán una llaves {})

Un saludo desde Vitoria

P.S. Las matriciales tienen algunas características muy propias, ya las irás viendo

ioyama
Moderador
Moderador

Masculino Cantidad de envíos : 128
Edad : 54
Ciudad - Pais : Vitoria (España)
Fecha de inscripción : 03/03/2008

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por pedrosilv el Jue Jun 11, 2009 7:03 pm

Hola ioyama, muchas gracias por la ayuda, voy a probarla. Solo me queda una duda. Supongo que el rango B1:B10 es donde tengo mis datos dispersos (con celdas vacias), y la función la escribo a partir de C1, cierto? Ok, ahora, el rago A2:A8 a qué hace referencia??

Agradecería nuevamente tu respuesto Io para poder entender bien dicha función.

De nuevo, muchas gracias..

PD: escapa a lo previsible la forma en que trabajan las funciones matriciales en excel, respecto a las funciones "normales" por así decirlo. Voy a buscar más respecto a este tema.
avatar
pedrosilv

Masculino Cantidad de envíos : 85
Edad : 32
Ciudad - Pais : Guatemala
Version de Excel : 2003-2007
Fecha de inscripción : 16/04/2009

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por GalileoGali el Jue Jun 11, 2009 8:27 pm

Siguiendo con la idea de ioyama (segun creo apuntaba a resumir las celdas, propongo algo como esto....
Hoja1

 ABC
1Resultados Resultados
2a a
3  34
434 ert
5  17
6  FALSO
7  VERDADERO
8ert 15
9   
10   
1117  
12   
13FALSO  
14VERDADERO  
15   
Spreadsheet Formulas
CellFormula
C1{=INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A1)-FILA($A$1)+1))}
C2{=SI(CONTARA($C$1:C1)+1>CONTARA($A$1:$A$20);"";INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A2)-FILA($A$1)+1)))}
C3{=SI(CONTARA($C$1:C2)+1>CONTARA($A$1:$A$20);"";INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A3)-FILA($A$1)+1)))}
C4{=SI(CONTARA($C$1:C3)+1>CONTARA($A$1:$A$20);"";INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A4)-FILA($A$1)+1)))}
C5{=SI(CONTARA($C$1:C4)+1>CONTARA($A$1:$A$20);"";INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A5)-FILA($A$1)+1)))}
C6{=SI(CONTARA($C$1:C5)+1>CONTARA($A$1:$A$20);"";INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A6)-FILA($A$1)+1)))}
C7{=SI(CONTARA($C$1:C6)+1>CONTARA($A$1:$A$20);"";INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A7)-FILA($A$1)+1)))}
C8{=SI(CONTARA($C$1:C7)+1>CONTARA($A$1:$A$20);"";INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A8)-FILA($A$1)+1)))}
C9{=SI(CONTARA($C$1:C8)+1>CONTARA($A$1:$A$20);"";INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A9)-FILA($A$1)+1)))}
C10{=SI(CONTARA($C$1:C9)+1>CONTARA($A$1:$A$20);"";INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A10)-FILA($A$1)+1)))}
C11{=SI(CONTARA($C$1:C10)+1>CONTARA($A$1:$A$20);"";INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A11)-FILA($A$1)+1)))}
C12{=SI(CONTARA($C$1:C11)+1>CONTARA($A$1:$A$20);"";INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A12)-FILA($A$1)+1)))}
C13{=SI(CONTARA($C$1:C12)+1>CONTARA($A$1:$A$20);"";INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A13)-FILA($A$1)+1)))}
C14{=SI(CONTARA($C$1:C13)+1>CONTARA($A$1:$A$20);"";INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A14)-FILA($A$1)+1)))}
C15{=SI(CONTARA($C$1:C14)+1>CONTARA($A$1:$A$20);"";INDICE($A$1:$A$20;K.ESIMO.MENOR(SI($A$1:$A$20<>"";FILA($A$1:$A$20));FILA(A15)-FILA($A$1)+1)))}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por ioyama el Vie Jun 12, 2009 5:40 am

Hola Pedro

El rango es el de la columna B ($B$1:$B$10), sucede que monté la función para un ejemplo de A2:A8 y al pasarlo a la respuesta no corregí ese rango (inicialmente todos eran A2:A8 y para hacerlo coincidente con tu pregunta quise poner B1:B10, pero se me escapó alguno).

Mis disculpas.

Un saludo desde Vitoria

ioyama
Moderador
Moderador

Masculino Cantidad de envíos : 128
Edad : 54
Ciudad - Pais : Vitoria (España)
Fecha de inscripción : 03/03/2008

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por pedrosilv el Vie Jun 12, 2009 1:02 pm

Ufff, que puedo decir ante esta ayuda "maestros".... solo puedo decir muchas gracias... a Io y a GalileoGali.

Probe las dos metodologías y ambas funcionan a su manera. En el ejemplo que me da Io, por ejemplo, si selecciono el rango B1:B20 y el último valor aparece en la celda B16, la función me devuelve los valores pero para el resto de celdas arroja esto #¡NUM! o esto #N/A

Con la fórmula que plantea GalileoGali, en cambio, si ya no existen datos, simplemente me lo deja en blanco, por lo que me resuelve el problema de celdas vacías para todo el rango de datos. Solo me queda una pequeña interrogante. Habrá alguna forma de que junto a agrupar los datos con dicha función, se ordene automáticamente de forma ascendente a los mismos?? o será necesario trabajar lo de orden ascendente en otra columna y con otra función?? de ser necesario trabajar el orden ascendente, cual función podría utilizar??

Estoy conciente de que es mucho lo que pido, pero les agradecería toda la yuda que me puedan brindar.

De nuevo muchisimas gracias por tomarse el tiempo en responderme.

Saludos desde Guatemala
avatar
pedrosilv

Masculino Cantidad de envíos : 85
Edad : 32
Ciudad - Pais : Guatemala
Version de Excel : 2003-2007
Fecha de inscripción : 16/04/2009

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por GalileoGali el Vie Jun 12, 2009 2:11 pm

Es el momento en que resulta indispensable contar con un ejemplo en xls, de lo contrario seguimos jugando a "las escondidas". Si tienes cuenta en Hotmail, tienes ddisponible skydrive, cuelga un archivo alli y trae el link aqui

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por pedrosilv el Vie Jun 12, 2009 6:31 pm

Ok, GalileoGali.

En esta dirección subí el ejemplo, siguiendo tus instrucciones.

[Tienes que estar registrado y conectado para ver este vínculo]

En la columna B, es donde escribí las funciones que tu indicas. Luego de probarlo me ha funcionado perfectamente, ahora, lo que quisiera ver, si es que se puede, es agregar algo, de modo que los datos se ordenen ascendentemente. Si te das cuenta, veras que en el archivo, los datos se "agrupan" siguiendo el órden como se encuentran en la columna A, pero quisiera que esos datos, aparte de agruparse, se ordenaran de forma ascendente.

Espero haberme explicado, y espero de nuevo, contar con su valiosa ayuda.

De antemano, muchas gracias.

Saludos desde Guatemala
avatar
pedrosilv

Masculino Cantidad de envíos : 85
Edad : 32
Ciudad - Pais : Guatemala
Version de Excel : 2003-2007
Fecha de inscripción : 16/04/2009

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por GalileoGali el Vie Jun 12, 2009 8:35 pm

Hoja2

 AB
111
2 1
332
4 3
525
6 6
766
897
9 8
1079
11 9
126 
138 
141 
159 
165 
Spreadsheet Formulas
CellFormula
B1=K.ESIMO.MENOR(A1:A20;FILA(A1)-FILA($A$1)+1)
B2=SI(CONTARA($B$1:B1)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A2)-FILA($A$1)+1))
B3=SI(CONTARA($B$1:B2)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A3)-FILA($A$1)+1))
B4=SI(CONTARA($B$1:B3)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A4)-FILA($A$1)+1))
B5=SI(CONTARA($B$1:B4)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A5)-FILA($A$1)+1))
B6=SI(CONTARA($B$1:B5)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A6)-FILA($A$1)+1))
B7=SI(CONTARA($B$1:B6)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A7)-FILA($A$1)+1))
B8=SI(CONTARA($B$1:B7)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A8)-FILA($A$1)+1))
B9=SI(CONTARA($B$1:B8)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A9)-FILA($A$1)+1))
B10=SI(CONTARA($B$1:B9)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A10)-FILA($A$1)+1))
B11=SI(CONTARA($B$1:B10)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A11)-FILA($A$1)+1))
B12=SI(CONTARA($B$1:B11)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A12)-FILA($A$1)+1))
B13=SI(CONTARA($B$1:B12)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A13)-FILA($A$1)+1))
B14=SI(CONTARA($B$1:B13)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A14)-FILA($A$1)+1))
B15=SI(CONTARA($B$1:B14)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A15)-FILA($A$1)+1))
B16=SI(CONTARA($B$1:B15)+1>CONTARA($A$1:$A$20);"";K.ESIMO.MENOR($A$1:$A$20;FILA(A16)-FILA($A$1)+1))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por pedrosilv el Dom Jun 14, 2009 2:51 am

Que más puedo decir, simplemente MUCHISIMAS GRACIAS GalileoGali, es justo lo que buscaba.

No tengo con que agradecerte, más que utilizar estas simples palabras.

Ojalá en algún momento pueda compensar lo mucho que me has ayudado, claro, sin olvidar a Jairga y a Io, que muy gentilmente me han brindado su apoyo.

Espero que el foro día a día siga creciendo y que poco a poco nos vayamos involucrando en él.

Saludos desde Guatemala.

Att. Pedro Silvestre
avatar
pedrosilv

Masculino Cantidad de envíos : 85
Edad : 32
Ciudad - Pais : Guatemala
Version de Excel : 2003-2007
Fecha de inscripción : 16/04/2009

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por freidor3 el Dom Jun 06, 2010 8:35 am

hola galileogali
he utilizado varias fórmulas para eliminar los espacios en blanco, variantes de la que has recomendado (sin ordenación); casi todas posteadas por ti :D.

El problema es que cuando lo retoco porque no empiezan en la primera fila se me descoloca todo, y no hay manera...
Se os ocurre como?
En realidad lo que necesito son eliminar las celdas con determinado texto(el resto son números).
gracias

freidor3

Masculino Cantidad de envíos : 1
Edad : 37
Ciudad - Pais : barcelona- spain
Version de Excel : 2007
Fecha de inscripción : 04/06/2010

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por GalileoGali el Dom Jun 06, 2010 10:01 am

Sube tu ejemplo (reducido) a Skydrive y pega el vínculo, incluye aclaraciones que permitan entender tu objetivo

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1963
Edad : 62
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por hugalex el Miér Oct 16, 2013 5:27 pm

Hola Galileo, necesitaba este ejemplo, copie las formulas exactamente como están en la imagen, la formula funciona con la matrix en excel pero no me esta quintando los espacios en blanco. puedes ayudarme muchas gracias.

hugalex

Masculino Cantidad de envíos : 2
Edad : 37
Ciudad - Pais : CALI
Version de Excel : 2007
Fecha de inscripción : 16/10/2013

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por hugalex el Miér Oct 16, 2013 10:15 pm

hola, al parecer la función sirve muy bien en excel 2003, pero en el excel 2010, hay problemas de compatibilidad y ya no toma el orden quitando los espacios en blanco.

Gracias por su ayuda.

hugalex

Masculino Cantidad de envíos : 2
Edad : 37
Ciudad - Pais : CALI
Version de Excel : 2007
Fecha de inscripción : 16/10/2013

Volver arriba Ir abajo

Re: Agrupar datos que estan separados por filas vacías.

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.