............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Listas dependientes con base de datos no ordenada y rango variable

Ver el tema anterior Ver el tema siguiente Ir abajo

Listas dependientes con base de datos no ordenada y rango variable

Mensaje por pedrosilv el Miér Jul 22, 2009 4:25 pm

Buen día a todos,

Acudo de nuevo a solicitar su ayuda con el siguiente problema que tengo. Resulta que tengo una base de datos, que contínuamente se va llenando con ciertos datos, de acuerdo a las entradas de mercadería a un almacén. Pues bien, quisiera crear listas desplegables dependientes, de modo que primeramente elija a un Propietario "X", en base a esa selección en otra columna salga el Listado de años en que este productor ha vendido productos al almacen, elegir dicha opción, y en otra lista, elgir qué productos a vendido al almacén... en fin, son varios criterios de selección, pero se los indico para que se hagan una idea.

Vi varios ejemplos en la red sobre listas dependientes, pero la diferencia con dichos ejemplos radica en que esos ejemplos trabajan con datos ordenados y separados (con rangos fijos creo), cosa que no se da con esta base de datos, ya que como dije al principio, es una base que se llena diariamente y va acorde al horario de entrada del producto al almacén.

Adjunto el archivo reducido para que puedan darse una idea más concreta de lo que deseo obtener:



Ojalá me puedan dar sugerencias sobre algunos métodos para solucionar dicho problemita.

De antemano, muchas gracias por la ayuda brindad y el tiempo invertido en esto.

Saludos desde Guatemala.

Att. Pedro
avatar
pedrosilv

Masculino Cantidad de envíos : 85
Edad : 32
Ciudad - Pais : Guatemala
Version de Excel : 2003-2007
Fecha de inscripción : 16/04/2009

Volver arriba Ir abajo

Re: Listas dependientes con base de datos no ordenada y rango variable

Mensaje por GalileoGali el Dom Jul 26, 2009 10:14 am

Pedro aca te va una "punta de ovillo"....(el ejemplo creo que es de Ozgrid)

Sheet1

 ABCDE
1NombreCodigo NombreCodigo
2FrankA1 FrankA1
3FrankA2  A2
4FrankA3  A3
5JoeA4   
6JoeA5   
7JoeA6   
8JohnA7   
9JohnA8   
10JohnA9   
Spreadsheet Formulas
CellFormula
E2{=SI(FILAS(E$2:E2)<=CONTAR.SI(A$2:A$10;D$2);INDICE(B$2:B$10;K.ESIMO.MENOR(SI(A$2:A$10=D$2;FILA(A$2:A$10)-FILA(A$2)+1);FILAS(E$2:E2)));"")}
E3{=SI(FILAS(E$2:E3)<=CONTAR.SI(A$2:A$10;D$2);INDICE(B$2:B$10;K.ESIMO.MENOR(SI(A$2:A$10=D$2;FILA(A$2:A$10)-FILA(A$2)+1);FILAS(E$2:E3)));"")}
E4{=SI(FILAS(E$2:E4)<=CONTAR.SI(A$2:A$10;D$2);INDICE(B$2:B$10;K.ESIMO.MENOR(SI(A$2:A$10=D$2;FILA(A$2:A$10)-FILA(A$2)+1);FILAS(E$2:E4)));"")}
E5{=SI(FILAS(E$2:E5)<=CONTAR.SI(A$2:A$10;D$2);INDICE(B$2:B$10;K.ESIMO.MENOR(SI(A$2:A$10=D$2;FILA(A$2:A$10)-FILA(A$2)+1);FILAS(E$2:E5)));"")}
E7{=SI(FILAS(E$2:E7)<=CONTAR.SI(A$2:A$10;D$2);INDICE(B$2:B$10;K.ESIMO.MENOR(SI(A$2:A$10=D$2;FILA(A$2:A$10)-FILA(A$2)+1);FILAS(E$2:E7)));"")}
E8{=SI(FILAS(E$2:E8)<=CONTAR.SI(A$2:A$10;D$2);INDICE(B$2:B$10;K.ESIMO.MENOR(SI(A$2:A$10=D$2;FILA(A$2:A$10)-FILA(A$2)+1);FILAS(E$2:E8)));"")}
E9{=SI(FILAS(E$2:E9)<=CONTAR.SI(A$2:A$10;D$2);INDICE(B$2:B$10;K.ESIMO.MENOR(SI(A$2:A$10=D$2;FILA(A$2:A$10)-FILA(A$2)+1);FILAS(E$2:E9)));"")}
E10{=SI(FILAS(E$2:E10)<=CONTAR.SI(A$2:A$10;D$2);INDICE(B$2:B$10;K.ESIMO.MENOR(SI(A$2:A$10=D$2;FILA(A$2:A$10)-FILA(A$2)+1);FILAS(E$2:E10)));"")}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Listas dependientes con base de datos no ordenada y rango variable

Mensaje por pedrosilv el Mar Ago 04, 2009 10:40 pm

Maestro Gali:

De nuevo, muchísimas gracias por toda la ayuda, funciona muy bien. Agradezco toda la atención brindada.

Saludos desde Guatemala.

Att. Pedro
avatar
pedrosilv

Masculino Cantidad de envíos : 85
Edad : 32
Ciudad - Pais : Guatemala
Version de Excel : 2003-2007
Fecha de inscripción : 16/04/2009

Volver arriba Ir abajo

Re: Listas dependientes con base de datos no ordenada y rango variable

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.