............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Ayuda con SUMAPRODUCTO con rango de FECHAS

Ver el tema anterior Ver el tema siguiente Ir abajo

Ayuda con SUMAPRODUCTO con rango de FECHAS

Mensaje por Marco Paez el Mar Jul 28, 2009 3:51 pm

En la celda CY28 quiero totalizar las ventas por el mes de JULIO, con la formula que pongo de suma producto me toma el valor del mes de agosto , quiero hacer esto para todos los meses del año ...en la celda donde da el resultado del mes de agosto me da como resultado CERO..

para el resultado del mes de julio deberia ser $ 734.00 pesos y Agosto 605.00 pesos


Gracias por su AYUDA

SALUDOS





Venta-Mieles

 ACWCXCYCZ
5Fecha25/jul/0925/jul/0928/jul/0901/ago/09
6ClienteIvanclaudia gzzErika MorenoMarco
7Teléfono83909522 52*249027*2   
8Tamarindo 211
9Mango1  1
10Fresa  11
11Piña 111
12Limón1 11
13Chamoy  11
14Vainilla1 11
15Coco   1
16Nuez  11
17Uva  11
18Kiwi/Piña Colada 1 1
19Durazno   1
20Guayaba1  1
21Lechera  11
22Total Lts.44914
23Total Pesos$172.00$172.00$390.00$605.00
24     
25     
26  ventas   
27  x mes  
28  Julio1339 
29  Agosto0 
Spreadsheet Formulas
CellFormula
CW22=SUMA(CW8:CW21)
CX22=SUMA(CX8:CX21)
CY22=SUMA(CY8:CY21)
CZ22=SUMA(CZ8:CZ21)
CW23=SUMAPRODUCTO($B$8:$B$21,CW8:CW21)
CX23=SUMAPRODUCTO($B$8:$B$21,CX8:CX21)
CY23=SUMAPRODUCTO($B$8:$B$21,CY8:CY21)
CZ23=SUMAPRODUCTO($B$8:$B$21,CZ8:CZ21)
CY28=SUMAPRODUCTO(CW23:DA23)*(CW5:DA5>=FECHA(2009,7,1))*(BS5:DA5<=FECHA(2009,7,31))
CY29=SUMAPRODUCTO(CW23:DA23)*(CW5:DA5>=FECHA(2009,8,1))*(BS5:DA5<=FECHA(2009,8,31))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

Marco Paez

Masculino Cantidad de envíos : 16
Edad : 53
Ciudad - Pais : Monterrey Nuevo León, México
Fecha de inscripción : 29/10/2008

Volver arriba Ir abajo

Re: Ayuda con SUMAPRODUCTO con rango de FECHAS

Mensaje por ioyama el Miér Jul 29, 2009 2:59 am

Hola Marcos

Debes usar algo como

=SUMAPRODUCTO((MES($CW$5:$CZ$5)=7)*($CW$23:$CZ$23))

esto obliga a cambiar el número de mes a mano (podrías tener una tabla mes en letra y en número y usar un BUSCARV dentro de sumaproducto)

Otra opción es que en la celda CX28 en vez de Julio pongas 1/7/2009 y con formato personalizado mmmm obtendrás julio entonces podrías poner

=SUMAPRODUCTO((MES($CW$5:$CZ$5)=mes($CX28))*($CW$23:$CZ$23))
y si has usado el mismo tipo de fecha para agosto y meses siguientes (si los hubiera) con arrastrar la fórmula hacia abajo es suficiente.

Un saludo desde Vitoria

ioyama
Moderador
Moderador

Masculino Cantidad de envíos : 128
Edad : 54
Ciudad - Pais : Vitoria (España)
Fecha de inscripción : 03/03/2008

Volver arriba Ir abajo

Re: Ayuda con SUMAPRODUCTO con rango de FECHAS

Mensaje por Marco Paez el Miér Jul 29, 2009 2:41 pm

Gracias oiyama , me funciona excelente , el detalle que se me presenta , es que las ventas del producto las tengo en otra hoja etiquetada como Venta-Mieles y me hace la sumatoria de todo el año para el mes de marzo , no se que es lo que me falla ,

Marco Paez

Masculino Cantidad de envíos : 16
Edad : 53
Ciudad - Pais : Monterrey Nuevo León, México
Fecha de inscripción : 29/10/2008

Volver arriba Ir abajo

Re: Ayuda con SUMAPRODUCTO con rango de FECHAS

Mensaje por GalileoGali el Miér Jul 29, 2009 5:06 pm

Prueba de tomar las referencias usando el Mouse, usando el criterio de haber comprendido cada elemento de la formula. Nota que al cambiar de Hoja Excel automaticamente precede las referencias del Nombre de la hoja de donde las tomas, pero claro hay que entender que dato, datos, se pretneden hacer jugar en cada parte de la expresion

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Ayuda con SUMAPRODUCTO con rango de FECHAS

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.