............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

BUSCARV - MIS EXPLICACIONES

Ver el tema anterior Ver el tema siguiente Ir abajo

BUSCARV - MIS EXPLICACIONES

Mensaje por GalileoGali el Sáb Ago 01, 2009 6:57 pm

[Tienes que estar registrado y conectado para ver este vínculo]


Última edición por GalileoGali el Sáb Feb 11, 2012 9:09 pm, editado 1 vez

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: BUSCARV - MIS EXPLICACIONES

Mensaje por Alejandro62 el Vie Nov 27, 2009 2:12 pm

Bueno, una funcion muy conocida por mi. Lo que no sabia era la utilizacion de los comodines, gracias por el tip.

Saludos.

Alejandro62

Masculino Cantidad de envíos : 37
Edad : 54
Ciudad - Pais : Mexico, Estado de Mexico
Version de Excel : Excel 2010
Fecha de inscripción : 21/11/2009

Volver arriba Ir abajo

Re: BUSCARV - MIS EXPLICACIONES

Mensaje por GalileoGali el Sáb Feb 11, 2012 9:10 pm

Reemplace el link, por uno nuevo.

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: BUSCARV - MIS EXPLICACIONES

Mensaje por KL el Lun Abr 02, 2012 5:06 pm

Hola chicos,

En realidad hay unas cuantas cosas más que generalmente se desconocen de BUSCARV (y similares) y no están muy bien documentadas.

1. Se puede obtener los resultados de mas de una columna al mismo tiempo, p.ej.: suponiendo que las columnas 2, 3 y 4 del rango [C1:F10] contienen valores numéricos podríamos obtener la suma de los tres resultados mediante una formula única =SUMA(BUSCARV(A1;C1:F10;{2;3;4};0))

2. En caso de que el valor buscado en la primera columna de la tabla esté duplicado la búsqueda exacta encontrará su primera aparición desde arriba mientras que una búsqueda aproximada encontraría la última aparición del mismo en una lista ordenada de manera ascendente

3. Para indicar la Tabla en el segundo argumento de BUSCARV, además de referencias (p.ej.: A1:D10), se puede utilizar constantes matriciales o funciones anidadas. P.ej.: =BUSCARV(A1; {"Enero";10\"Febrero";20\"Marzo";30\"Abril";40};2;0) ó =BUSCARV(A1; INDICE((C1:E10;M1:P10;R5:U15);;;2);2;0) etc.

4. Cuando las tablas contienen tantos datos que la búsqueda exacta con BUSCARV se vuelve muy lenta, es mejor ordenar la tabla por la primera columna de manera ascendente y usar una búsqueda aproximada (que es rapidísima). P.ej.: =SI(BUSCAR(A1;C1:C10000)=A1;BUSCARV(A1;C1:F10000;2);””)

5. Se puede cambiar el orden de las columnas de una tabla dentro de un BUSCARV, aunque a costa de la velocidad. P.ej.: =BUSCARV(A1;ELEGIR({3;1;4;2};C1:C10;D1:D10;E1:E10;F1:F10);2)

6. BUSCAR es ligeramente más rápida que BUSCARV para búsquedas aproximadas

7. La fórmula =INDICE(D1:D10;COINCIDIR(A1;C1:C10;0)) es más flexible y más rápida que =BUSCARV(A1;C1:D10;2;0)

8. Si se utiliza BUSCARV para devolver los valores de varias columnas de la tabla original, p.ej.:
[B1]=BUSCARV(A1;Hoja1!$A$2:$D$10;2;0)
[C1]=BUSCARV(A1;Hoja1!$A$2:$D$10;3;0)
[D1]=BUSCARV(A1;Hoja1!$A$2:$D$10;4;0)

Para acelerar el re-cálculo es preferible usar una columna auxiliar con COINCIDIR para obtener la posición vertical del valor buscado en la tabla de origen y luego devolver los resultados de las distintas columnas mediante la función INDICE. P.ej.:
[B1]=COINCIDIR(A1;Hoja1!$A$2:$A$5000;0)
[C1]=INDICE(Hoja1!B$2:B$5000;B1)
[D1]=INDICE(Hoja1!C$2:C$5000;B1)
[E1]=INDICE(Hoja1!D$2:D$5000;B1)

Una otra opción de cálculo rápido sería seleccionar las celdas [B1:D1] al mismo tiempo, introducir a través de la barra de fórmulas la siguiente fórmula
=BUSCARV(A1; Hoja1!$A$2:$D$10;{2;3;4};0)
y pulsar la combinación de teclas {Ctrl+Mayus+Intro}.
Ahora se podría copiar la formula de las tres celdas hacia abajo.

9. Al igual que sus primas hermanas BUSCARH, COINCIDIR y BUSCAR, BUSCARV de búsqueda aproximada puede encontrar el último valor numérico o de texto en la primera columna de la tabla (sin la necesidad de ordenar los valores). El truco consiste en buscar un valor que es mayor (en su caso numérica o alfabéticamente) a cualquiera de los que estén en la primera columna de la tabla. P.ej.: =BUSCARV(9e307;C1:C10;1) ó =BUSCARV(“ZZZZZZ”;C1:C10;1)

Seguramente se me olvida algo


Última edición por KL el Sáb Abr 21, 2012 10:54 am, editado 1 vez

KL
MS MVP
MS MVP

Cantidad de envíos : 3
Fecha de inscripción : 23/04/2010

Volver arriba Ir abajo

Re: BUSCARV - MIS EXPLICACIONES

Mensaje por GalileoGali el Sáb Abr 21, 2012 10:41 am

Gracias KL por este material tan "apetecible". Inevitable agregar algunas glosas y comentarios, para, simplemente, ilustrar tus aportes....

[Tienes que estar registrado y conectado para ver este vínculo]







Última edición por GalileoGali el Sáb Abr 21, 2012 11:28 am, editado 1 vez

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: BUSCARV - MIS EXPLICACIONES

Mensaje por KL el Sáb Abr 21, 2012 10:57 am

Gracias Gali. Muy interesante tu ejemplo también. A ver si al final coincidimos tú y yo en el Skype Por cierto, desconocía que yo era moderador aquí

KL
MS MVP
MS MVP

Cantidad de envíos : 3
Fecha de inscripción : 23/04/2010

Volver arriba Ir abajo

Re: BUSCARV - MIS EXPLICACIONES

Mensaje por GalileoGali el Sáb Abr 21, 2012 11:33 am

KL me atrase en el envio del archivo (link) (VER "ut supra")

Por lo de enlazar en el skype, prometo tenerlo activo,
pero, no doy fe acerca de estar peinado....

No, no has sido designado moderador, sino que "el administrador del site", creyó valioso colocar tus blasones como MVP MS Excel, ya que conoce que eres reacio a aceptar cargos en los foros

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: BUSCARV - MIS EXPLICACIONES

Mensaje por kirkie666 el Lun Jul 16, 2012 12:39 pm

Hola, tengo una duda, y seguramente una muy tonta ( aunque no hay preguntas tontas, solo tontos que No preguntan.) ,
mi pregunta es:
en esta formula " =SUMA(BUSCARV(A1,INDICE((BLOQUE1,Bloque2),,,2),2,0)) " , cuando pongo el valor a buscar en A1, el resultado que me muestra es el valor del segundo bloque, por ejemplo:

A1 bloque1 bloque2
a1 2 a1 4


resultado : 4 -- cuando realmente lo que yo esperaba que sucediera era una suma de 2+4, dando un 6 como resultado, podrias explicarme o gran guru del excel, por qué? jaja, gracias, y disculpa, soy nuevo pero muy interesado en aprender

kirkie666

Masculino Cantidad de envíos : 1
Edad : 31
Ciudad - Pais : Barranquilla
Version de Excel : 2010
Fecha de inscripción : 03/06/2012

Volver arriba Ir abajo

Re: BUSCARV - MIS EXPLICACIONES

Mensaje por GalileoGali el Lun Jul 16, 2012 11:00 pm

Que tal Gracias por detectar y avisar. Si ves la formula convertida a TEXTO para mantenerla visible, no habia ninguna funcion SUMA, a diferencia de la Formula colocada en F 15 que si erroneamente la contenia, de todas maneras estoy en deuda con un BUSCARV que resuma el resultado asignado a una referencia presente en varios y diferente bloques

Nuevamente GRACIAS

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: BUSCARV - MIS EXPLICACIONES

Mensaje por Contenido patrocinado Hoy a las 3:12 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.