............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

HALLAR LOS NUMEROS QUE FALTAN EN LA SECUENCIA DE NUMEROS552

HALLAR LOS NUMEROS QUE FALTAN EN LA SECUENCIA DE NUMEROS

Ver el tema anterior Ver el tema siguiente Ir abajo

HALLAR LOS NUMEROS QUE FALTAN EN LA SECUENCIA DE NUMEROS

Mensaje por alemauro el Vie Ago 07, 2009 1:24 pm

HOLA QUERIDOS COMPAÑEROS, PRIMERAMENTE AGRADECERLES ATODOS POR SUS APORTES QUE ME HAN AYUDADO DE GRAN MANERA.

MI CONSULTA ES LA SIGUIENTE TENGO EN UNA HOJA EXCEL UNA SECUENCIA DE NUMEROS POR EJEMPLO 1,2,3,4,5,7,8,9,11,12 QUE ESTAN EN CADA CELDA DE UNA COLUMNA LLAMADA FACTURAS. NOTEN QUE FALTA EN LA SERIE EL NUMERO 6 Y 10. MI pregunta es la siguiente como puedo hacer para que me indique que me faltan estos numeros o de alguna manera MARCARLOS CON COLOR. Porfis si alguien puede ayudarme.

De antemano, les quedo agradecida

alemauro

Femenino Cantidad de envíos: 3
Edad: 36
Ciudad - Pais: bolivia
Version de Excel: 2007
Fecha de inscripción: 30/07/2009

Volver arriba Ir abajo

Re: HALLAR LOS NUMEROS QUE FALTAN EN LA SECUENCIA DE NUMEROS

Mensaje por GalileoGali el Vie Ago 07, 2009 8:20 pm

Hoja1

 ABCD
11 DESDEHASTA
22 67
33 1010
44   
55   
68   
79   
811   
Spreadsheet Formulas
CellFormula
C2{=SI(ESERROR(K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$1:$A$7);FILA(A1)));"";K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$1:$A$7);FILA(A1))+1)}
D2{=SI(C2="";"";K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$2:$A$8);FILA(A1))-1)}
C3{=SI(ESERROR(K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$1:$A$7);FILA(A2)));"";K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$1:$A$7);FILA(A2))+1)}
D3{=SI(C3="";"";K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$2:$A$8);FILA(A2))-1)}
C4{=SI(ESERROR(K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$1:$A$7);FILA(A3)));"";K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$1:$A$7);FILA(A3))+1)}
D4{=SI(C4="";"";K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$2:$A$8);FILA(A3))-1)}
C5{=SI(ESERROR(K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$1:$A$7);FILA(A4)));"";K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$1:$A$7);FILA(A4))+1)}
D5{=SI(C5="";"";K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$2:$A$8);FILA(A4))-1)}
C6{=SI(ESERROR(K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$1:$A$7);FILA(A5)));"";K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$1:$A$7);FILA(A5))+1)}
D6{=SI(C6="";"";K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$2:$A$8);FILA(A5))-1)}
C7{=SI(ESERROR(K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$1:$A$7);FILA(A6)));"";K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$1:$A$7);FILA(A6))+1)}
D7{=SI(C7="";"";K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$2:$A$8);FILA(A6))-1)}
C8{=SI(ESERROR(K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$1:$A$7);FILA(A7)));"";K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$1:$A$7);FILA(A7))+1)}
D8{=SI(C8="";"";K.ESIMO.MENOR(SI($A$2:$A$8-$A$1:$A$7>1;$A$2:$A$8);FILA(A7))-1)}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

se trata de Fórmulas MatrIciales, deben entrarse en lugar de un simple ENTER con CTRL+MAY+ENTER

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos: 1962
Edad: 58
Ciudad - Pais: QUIROGA, Argentina
Version de Excel: 2000-2003-2007-2010
Fecha de inscripción: 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: HALLAR LOS NUMEROS QUE FALTAN EN LA SECUENCIA DE NUMEROS

Mensaje por alemauro el Jue Ago 20, 2009 12:46 pm

hola galileogali
comentarte que me ha funcionado de maravilla la solucion que presentaste
quedo muy agradecida.

saludos desde BOLIVIA.

alemauro

Femenino Cantidad de envíos: 3
Edad: 36
Ciudad - Pais: bolivia
Version de Excel: 2007
Fecha de inscripción: 30/07/2009

Volver arriba Ir abajo

Re: HALLAR LOS NUMEROS QUE FALTAN EN LA SECUENCIA DE NUMEROS

Mensaje por JMAZUCARM el Mar Dic 06, 2011 8:56 pm

Es mi primer dia aqui y tengo una una funcion que me ayudo a mi hace tiempo
Public Function CompletaSerie(r As Range) As String

Dim c As Range
Dim cs, rs As Integer
Dim s As String


For Each c In r
If c.Value = "" Then
s = "La serie no debe tener celdas en blanco"
GoTo fin
End If
Next c

rs = r.Rows.Count
cs = r.Columns.Count


For i = 1 To rs
For j = 1 To cs
a = r.Item(i, j)
If i + 1 <= rs Then
b = r.Item(i + 1, j)
While b <> a + 1 And a + 1 <> ""
s = s & Str(a + 1) & ";"
a = a + 1
Wend
End If
Next j
Next i

fin:
CompletaSerie = s

End Function




JMAZUCARM

Masculino Cantidad de envíos: 5
Edad: 32
Ciudad - Pais: MEXICO
Version de Excel: 2007
Fecha de inscripción: 06/12/2011

Volver arriba Ir abajo

Re: HALLAR LOS NUMEROS QUE FALTAN EN LA SECUENCIA DE NUMEROS

Mensaje por Tatayayan el Miér Dic 07, 2011 1:09 pm

Hola, según lo aportado por Gali, esto contaría los faltantes
=SUMAPRODUCTO(INDICE(--ESERROR(FILA(INDIRECTO(MIN(A1:A8)&":"&MAX(A1:A8)))=A1:A8);0))

Tatayayan
Moderador
Moderador

Masculino Cantidad de envíos: 315
Ciudad - Pais: Chamical- La Rioja - ARG
Fecha de inscripción: 20/11/2008

Volver arriba Ir abajo

Re: HALLAR LOS NUMEROS QUE FALTAN EN LA SECUENCIA DE NUMEROS

Mensaje por JMAZUCARM el Miér Dic 07, 2011 1:54 pm

si cuenta los faltantes, la macro que utilizo te indica los numeros que faltan en un sarie de numeros consecutivos (rango), tambien tengo esta otra macro que inserta las filas y los numeros que faltan en una serie, se tiene que activar con un "control de ActiveX"

Dim Nro_Fila As Double
Dim Valor_Celda As Double
Dim Comienzo_Fila As Double
Nro_Fila = InputBox("Ingrese el Nro de Fila desde donde se Comenzará a Chequear el Consecutivo", "No de Fila Inicial")
Comienzo_Fila = Nro_Fila
Valor_Celda = Range("A" & Nro_Fila).Value 'si no es la columna A cambiar letra
Do While Val(Range("A" & Nro_Fila).Value) > 0 'si no es la columna A cambiar letra
If Nro_Fila > Comienzo_Fila Then
If Val(Range("A" & Nro_Fila).Value) > Valor_Celda Then 'si no es la columna A cambiar letra
Rows(Nro_Fila & ":" & Nro_Fila).Select
Selection.Insert Shift:=xlDown
Range("A" & Nro_Fila).Value = Valor_Celda 'si no es la columna A cambiar letra
End If
End If
Nro_Fila = Nro_Fila + 1
Valor_Celda = Valor_Celda + 1
Loop

JMAZUCARM

Masculino Cantidad de envíos: 5
Edad: 32
Ciudad - Pais: MEXICO
Version de Excel: 2007
Fecha de inscripción: 06/12/2011

Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


Permisos de este foro:
No puedes responder a temas en este foro.