............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Probema con fórmula condicional "SI"

Ver el tema anterior Ver el tema siguiente Ir abajo

Probema con fórmula condicional "SI"

Mensaje por Pedro11111 el Jue Oct 29, 2009 7:33 am

Hola buenos días,

después de muchos intentos no consigo elaborar una fórmula.

Quería poner (de forma alternativa):

en la celda A1: M y que saliera en la celda A2: 7
en la celda A1: T y que saliera en la celda A2: 7
en la celda A1: N y que saliera en la celda A2: 10
en la celda A1: L y que saliera en la celda A2: 0

Hago lo siguiente aunque sin éxito:

=SI(A1=M;"7";SI(A1=T;"7";SI(A1=N;"10";SI(A1=L;"0"))))

¿Alguien podría arrojar luz al respecto?

Sea cómo sea, gracias.

Un cordial saludo.

Pedro11111

Masculino Cantidad de envíos : 20
Edad : 49
Ciudad - Pais : valencia - españa
Version de Excel : 2007
Fecha de inscripción : 29/10/2009

Volver arriba Ir abajo

Re: Probema con fórmula condicional "SI"

Mensaje por GalileoGali el Jue Oct 29, 2009 7:41 am

Fijate esto:
Hoja1

 A
1L
20
Spreadsheet Formulas
CellFormula
A2=BUSCARH(A1;{"M";"T";"N";"L"\7;7;10;0};2;0)


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Probema con fórmula condicional "SI"

Mensaje por Pedro11111 el Jue Oct 29, 2009 8:45 am

Hola GalileoGali,

francamente me has dejado anonadado !!! Funciona a las mil maravillas.

Muchísimas gracias.

Recibe un cordial saludo desde Valencia.

Pedro11111

Masculino Cantidad de envíos : 20
Edad : 49
Ciudad - Pais : valencia - españa
Version de Excel : 2007
Fecha de inscripción : 29/10/2009

Volver arriba Ir abajo

Re: Probema con fórmula condicional "SI"

Mensaje por Pedro11111 el Jue Oct 29, 2009 9:01 am

Hola de nuevo GalileoGali,

si es posible y si no es abusar,


Si no pongo ningún valor en la celda A1, en la celda A2 queda esto: #N/A

Por lo tanto, ¿sería posible añadir que si en la celda A1 no figura ningún valor, la celda A2 se quede en blanco?


Gracias de todos modos.

Saludos.

Pedro11111

Masculino Cantidad de envíos : 20
Edad : 49
Ciudad - Pais : valencia - españa
Version de Excel : 2007
Fecha de inscripción : 29/10/2009

Volver arriba Ir abajo

Re: Probema con fórmula condicional "SI"

Mensaje por Pedro11111 el Jue Oct 29, 2009 9:35 am

Hola otra vez GalileoGali,

ya tengo la solución.

La pongo por si le puede servir a alguién con alguna cuestión similar.

=SI(A1="M";"7";SI(A1="T";"7";SI(A1="N";"10";SI(A1="L";"0";SI(A1="";"0")))))

Muchas gracias por todo.

Saludos cordiales que hago extensivos a tod@s los forer@s.

Pedro11111

Masculino Cantidad de envíos : 20
Edad : 49
Ciudad - Pais : valencia - españa
Version de Excel : 2007
Fecha de inscripción : 29/10/2009

Volver arriba Ir abajo

Re: Probema con fórmula condicional "SI"

Mensaje por GalileoGali el Jue Oct 29, 2009 2:04 pm

Siguiendo con el uso de BUSCAR para resolver multiples condicionales, aca va un toqeucito para "atajar el error" #N/A!
Hoja1

 A
1L
20
Spreadsheet Formulas
CellFormula
A2=SI(A1="";"";BUSCARH(A1;{"M";"T";"N";"L"\7;7;10;0};2;0))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Probema con fórmula condicional "SI"

Mensaje por GalileoGali el Jue Oct 29, 2009 2:07 pm

Esto para el caso que tu resultado en Balnco pretenda ser = (tal como ejemplificas, al final)

Hoja1

 A
1L
20
Spreadsheet Formulas
CellFormula
A2=SI(A1="";0;BUSCARH(A1;{"M";"T";"N";"L"\7;7;10;0};2;0))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Probema con fórmula condicional "SI"

Mensaje por GalileoGali el Jue Oct 29, 2009 2:09 pm

Hoja1

 A
1P
2 
Spreadsheet Formulas
CellFormula
A2=SI(ESNOD(BUSCARH(A1;{"M";"T";"N";"L"\7;7;10;0};2;0));"";BUSCARH(A1;{"M";"T";"N";"L"\7;7;10;0};2;0))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

y esto por si queres atajar el caso en que pudiera ingrsarse valores incorrectos

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Probema con fórmula condicional "SI"

Mensaje por Pedro11111 el Vie Oct 30, 2009 4:19 am

Tomo nota de tus interesantes soluciones.

Muchas gracias de nuevo.

Un cordial saludo.

Pedro11111

Masculino Cantidad de envíos : 20
Edad : 49
Ciudad - Pais : valencia - españa
Version de Excel : 2007
Fecha de inscripción : 29/10/2009

Volver arriba Ir abajo

Re: Probema con fórmula condicional "SI"

Mensaje por Toldeman el Lun Feb 15, 2010 6:15 pm

Hola.

Me parece muy interesante la forma de desarrollar esta formula, he estado practicando e intentando agregar dentro de la matriz una columna mas.

BUSCARH(A1;{"M";"T";"N";"L"\7;7;10;0\55;2;33;6};3;0)

Pero excel no me lo permite.

Se puede hacer esto asi?.

Gracias y un saludo.

Toldeman
Moderador
Moderador

Masculino Cantidad de envíos : 60
Edad : 52
Ciudad - Pais : España
Version de Excel : 2007
Fecha de inscripción : 05/04/2009

Volver arriba Ir abajo

Re: Probema con fórmula condicional "SI"

Mensaje por GalileoGali el Lun Feb 15, 2010 8:33 pm

Toldeman, Me limité a copiar tu ejemplo y a probarlo, y sin dudas: funciona correctamente

Hoja1

 ABC
1N  
2  33
Spreadsheet Formulas
CellFormula
C2=BUSCARH(A1;{"M";"T";"N";"L"\7;7;10;0\55;2;33;6};3;0)


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Probema con fórmula condicional "SI"

Mensaje por Toldeman el Mar Feb 16, 2010 2:17 am

Hola Gali.

Gracias por responder, lo acabo de probar y también me funciona, ya averigüe donde estaba el fallo. Cuando intentaba poner la función en la barra de formulas de excel, lo que sucedía es que al dividir la matriz unicamente insertaba dos elementos (estaba probando) por lo cual no me dejaba.
Cuando escribí el mensaje no se porque pero me dio por escribir los 4 elementos que corresponden a cada división. Y ahora que he intentado hacer una 4º división con 2 elementos y me sucedía lo mismo hasta que me di cuenta que todas las divisiones tienen que tener la misma dimensión.

Muchas gracias por todo maestro.

Un saludo.

Toldeman
Moderador
Moderador

Masculino Cantidad de envíos : 60
Edad : 52
Ciudad - Pais : España
Version de Excel : 2007
Fecha de inscripción : 05/04/2009

Volver arriba Ir abajo

Re: Probema con fórmula condicional "SI"

Mensaje por Gerson Pineda-El Catracho el Mar Feb 16, 2010 4:56 pm

Otra forma con BUSCARV:

=BUSCARV(A1,{"M";7\"T";7\"N";10\"L";0},2,0) puede que se utilice ";" por "," para separar argumentos en las formulas



Saludos desde Honduras
avatar
Gerson Pineda-El Catracho

Masculino Cantidad de envíos : 107
Edad : 39
Ciudad - Pais : SPS - Honduras
Version de Excel : 2003/2007/2010/2013
Fecha de inscripción : 02/04/2008

http://gerson-pineda-el-catracho.blogspot.com/

Volver arriba Ir abajo

Re: Probema con fórmula condicional "SI"

Mensaje por Toldeman el Miér Feb 17, 2010 7:08 am

Hola gerson.

Gracias por esta otra posibilidad.

Un gusto saber que estas por aquí.

Toldeman
Moderador
Moderador

Masculino Cantidad de envíos : 60
Edad : 52
Ciudad - Pais : España
Version de Excel : 2007
Fecha de inscripción : 05/04/2009

Volver arriba Ir abajo

Re: Probema con fórmula condicional "SI"

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.