............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

sigo con el problema

Ver el tema anterior Ver el tema siguiente Ir abajo

sigo con el problema

Mensaje por alberto1959 el Lun Mar 31, 2008 2:45 am

Felicidades por su foro Sr. Gali y para variar sigo con el problema que expuse en
[Tienes que estar registrado y conectado para ver este vínculo]

y que tuve el gusto de recibir su ayuda en la que me hace el siguiente comentario:

Si se trata de la Microsoft ProgresBar, deberias contar con el siguiente archivo:
COMCTL32.0CX gralte en c:\windows\system32

Efectivamente ese es mi problema y busque en un ordenador en que el problema no se da y copie el archivo que Ud. me menciona y lo puse en c:\windows\system32 pero el problema continua, sera que deba hacer lo del registro o lo del referenciado que me menciona en su primer ayuda? sin embargo con mucha pena tengo que decir que no se como se hace esto. Tendra una copia Ud. del archivo COMCTL32.0CX que me pudiera enviar , Que significa gralte? perdon por mi ignorancia y muchas GRACIAS por sus atenciones

alberto1959

Cantidad de envíos : 9
Fecha de inscripción : 31/03/2008

Volver arriba Ir abajo

Re: sigo con el problema

Mensaje por GalileoGali el Lun Mar 31, 2008 7:32 am

Bienvenido Alberto:
Para registrar un OCX:
1) El ocx deberia estar en donde lo pusiste, es decir c:\windows\system32\COMCTL32.OCX
2)Ir a INICIO>>Ejecutar >> escribir lo siguiente sin comillas "regsvr32 c:\windows\system32\COMCTL32.OCX". Deberia surgir un mensaje de confirmacion o no de regsitracion exitosa.

3) si esto no funciono habria que ver sino se trata de un problema de referencias o versiones, pero en tu caso, en el que se trta de trabaar en varios ordenadores diferentes buscaria una ProgressBar de esas que funcionan con dos TexttBox yuxtapuestos....

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: sigo con el problema

Mensaje por alberto1959 el Lun Mar 31, 2008 8:16 am

Mil Gracias MAESTRO......DIOS lo bendiga....soluciono mi problema

alberto1959

Cantidad de envíos : 9
Fecha de inscripción : 31/03/2008

Volver arriba Ir abajo

PERDON SR. GALI

Mensaje por alberto1959 el Mar Abr 01, 2008 7:04 pm

Cada ves me pesa mas mi ignorancia, la solucion que me dio me funciona perfectamente al unos equipos y en otros no, sera que me falte algo mas? me envia el siguiente mensaje:[Tienes que estar registrado y conectado para ver esa imagen]

como vera no tiene acticada la opcion de depurar, entrando al editor de visual basic no me da ningun error en algun equipo pero en otro si situa en alguna de las lineas de ProgressBar .

Gracias por todas sus atenciones

alberto1959

Cantidad de envíos : 9
Fecha de inscripción : 31/03/2008

Volver arriba Ir abajo

Re: sigo con el problema

Mensaje por GalileoGali el Miér Abr 02, 2008 8:41 am

Supongo que te refieres a equipos donde la Registracion del OCX, fue exitosa.....Es decir donde el OCx esta, y alojado conde tiene que ser.....

El error 424 puede obedecer a muchas cosas que bien podrian no tener que ver con el OCX, pero si a este se refiere, habria que revisar, las referencias al Control en VBE.
Para esto ir al Editor de visual >> Herramientas >> Referencias. Y primero que nada destildar CUALQUIER "FALTA" es decir pueden haber quedado marcas de busquedas de CONTROL ausente, donde figura la palabra "FALTA", simplemente destilda estas marcas.
Por otra parte tienes que buscar la referencia al control Microsoft Windows Common Controls y un Numero que en Mi version es 5.0 (SP2)
y tildarlo si es que no lo esta....
supongo que asi debe funcionar...., salvo problemas de versiones de una maquina a otra, ahi ya el proble seria otro....

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: sigo con el problema

Mensaje por alberto1959 el Miér Abr 02, 2008 6:38 pm

Gracias por sus atenciones Maestro Gali el archivo MSCOMCTL.OCX si se encuentra en la carpeta c:\windows\system32 que me parece es el referente a Microsoft Windows Common Controls y realizo el registro correctamente pero mi problema persiste, en Editor de visual >> Herramientas >> Referencias ninguna de las opciones tiene la palabra FALTA, por lo que en esta parte no destilde nada y no entiendo a que se refiere un Numero que en Mi version es 5.0 (SP2)
Que tenga un buen dia.

alberto1959

Cantidad de envíos : 9
Fecha de inscripción : 31/03/2008

Volver arriba Ir abajo

Re: sigo con el problema

Mensaje por GalileoGali el Miér Abr 02, 2008 7:31 pm

Seguimos sin entendernos...seguimos intentando:
Abrir el VBE (editor de Visual Basic)
En la Barra de Comandos, Buscar Herramientas
>>Referencias
>>Busca Examinar el Archivo COMCTL32.OCX
(Es probable que en el Cuadro Agregar Referencias, aparezca abajo en Tipo, las dll asi que cambia a "Controles ActiveX (".ocx")
Una vez ubiques y selecciones el archivo COMCTL32.OCX, ACEPTAR.
Ahi deberia figurarte tildado Microsoft Windows Common Controls
De no resultar aun
Ve a la Barra de Controles y teneinedola visible, a Herramientas Controles Adicionales,
Busca Microsoft ProgressBar Control, yo tengo dos una 6.0 (SP6) y otra SP2 5.0.

Habria que probar si tenes las dos, tildar la que tengas para que pase a la Tool Box
y desde alli probar en el formulario, a ver si cambiandola se soluciona....

la 6.0 sí se basa en el OCX MSCOMCTL.OCX y no en el COMCTL32.OCX, yo tendira referenciados los dos.....

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional
avatar
GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Nuevamente GRACIAS

Mensaje por alberto1959 el Vie Abr 11, 2008 12:14 am

MAESTRO GALI

Nuevamente GRACIAS por sus atenciones.....asi con manzanas por fin entendi lo que debia hacer......

Que este bien siempre.

alberto1959

Cantidad de envíos : 9
Fecha de inscripción : 31/03/2008

Volver arriba Ir abajo

Re: sigo con el problema

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.