............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Listar Unicos con Formula

Ver el tema anterior Ver el tema siguiente Ir abajo

Listar Unicos con Formula

Mensaje por GalileoGali el Vie Nov 20, 2009 9:28 pm

Hoja1

 ABCD
1A  Unicos
2B  A
3C  B
4A  C
5D  D
6B  E
7E  F
8E  G
9F   
10B   
11G   
12F   
Spreadsheet Formulas
CellFormula
D2{=SI(O(CONTAR.SI($D$1:D1;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)))=0);INDICE(INDIRECTO("A$1:$A$"&CONTARA($A$1:A$12));COINCIDIR(0;CONTAR.SI($D$1:D1;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)));0));"")}
D3{=SI(O(CONTAR.SI($D$1:D2;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)))=0);INDICE(INDIRECTO("A$1:$A$"&CONTARA($A$1:A$12));COINCIDIR(0;CONTAR.SI($D$1:D2;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)));0));"")}
D4{=SI(O(CONTAR.SI($D$1:D3;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)))=0);INDICE(INDIRECTO("A$1:$A$"&CONTARA($A$1:A$12));COINCIDIR(0;CONTAR.SI($D$1:D3;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)));0));"")}
D5{=SI(O(CONTAR.SI($D$1:D4;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)))=0);INDICE(INDIRECTO("A$1:$A$"&CONTARA($A$1:A$12));COINCIDIR(0;CONTAR.SI($D$1:D4;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)));0));"")}
D6{=SI(O(CONTAR.SI($D$1:D5;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)))=0);INDICE(INDIRECTO("A$1:$A$"&CONTARA($A$1:A$12));COINCIDIR(0;CONTAR.SI($D$1:D5;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)));0));"")}
D7{=SI(O(CONTAR.SI($D$1:D6;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)))=0);INDICE(INDIRECTO("A$1:$A$"&CONTARA($A$1:A$12));COINCIDIR(0;CONTAR.SI($D$1:D6;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)));0));"")}
D8{=SI(O(CONTAR.SI($D$1:D7;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)))=0);INDICE(INDIRECTO("A$1:$A$"&CONTARA($A$1:A$12));COINCIDIR(0;CONTAR.SI($D$1:D7;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)));0));"")}
D9{=SI(O(CONTAR.SI($D$1:D8;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)))=0);INDICE(INDIRECTO("A$1:$A$"&CONTARA($A$1:A$12));COINCIDIR(0;CONTAR.SI($D$1:D8;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)));0));"")}
D10{=SI(O(CONTAR.SI($D$1:D9;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)))=0);INDICE(INDIRECTO("A$1:$A$"&CONTARA($A$1:A$12));COINCIDIR(0;CONTAR.SI($D$1:D9;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)));0));"")}
D11{=SI(O(CONTAR.SI($D$1:D10;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)))=0);INDICE(INDIRECTO("A$1:$A$"&CONTARA($A$1:A$12));COINCIDIR(0;CONTAR.SI($D$1:D10;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)));0));"")}
D12{=SI(O(CONTAR.SI($D$1:D11;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)))=0);INDICE(INDIRECTO("A$1:$A$"&CONTARA($A$1:A$12));COINCIDIR(0;CONTAR.SI($D$1:D11;INDIRECTO("A1:$A$"&CONTARA($A$1:$A$12)));0));"")}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

adapté una formula de DOMENIC. Se estira la lista Original. El uso de INDIRECTO no es lo mas aconsejable, pero como para no complicarla tanto.
Si no se entiende cómo funciona, la explico -----

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Listar Unicos con Formula

Mensaje por Alejandro62 el Sáb Nov 21, 2009 1:57 am

Hola Galileo, muy bonita formula y muy ingeniosa.
Aprovechando tu gentileza, podriamos ver tambien la formula de Domenic?

Saludos.

Alejandro62

Masculino Cantidad de envíos : 37
Edad : 54
Ciudad - Pais : Mexico, Estado de Mexico
Version de Excel : Excel 2010
Fecha de inscripción : 21/11/2009

Volver arriba Ir abajo

Re: Listar Unicos con Formula

Mensaje por GalileoGali el Sáb Nov 21, 2009 11:15 am

Esta recopilación fue hecha y analizada comparativamente por KL (Kirill Lapin - MS MVP EXCEL)


_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Listar Unicos con Formula

Mensaje por Alejandro62 el Sáb Nov 21, 2009 5:43 pm

Gracias Galileo por el Link, las formulas se ven muy buenas.
Saludos.

Alejandro62

Masculino Cantidad de envíos : 37
Edad : 54
Ciudad - Pais : Mexico, Estado de Mexico
Version de Excel : Excel 2010
Fecha de inscripción : 21/11/2009

Volver arriba Ir abajo

Re: Listar Unicos con Formula

Mensaje por Contenido patrocinado Hoy a las 3:12 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.