............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

Diccionario Matricial

Ver el tema anterior Ver el tema siguiente Ir abajo

Diccionario Matricial

Mensaje por GalileoGali el Mar Abr 01, 2008 8:27 am

Devolver Ordenado en forma ascendente un Rango que contenga Texto, solo con formulas:

DESCARGAR ARCHIVO


Última edición por GalileoGali el Mar Abr 15, 2008 6:51 pm, editado 2 veces

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Diccionario Matricial

Mensaje por ioyama el Miér Abr 02, 2008 3:00 am

Hola Gali

Como alternativa (imperfecta) a

{=SI(SUMAPRODUCTO(($C$1:C1<>"")*1)>SUMAPRODUCTO(($B$1:$B$38<>"")*1);"";INDICE($B$1:$B$38;COINCIDIR(K.ESIMO.MENOR($C$1:$C$38;FILA()+SUMAPRODUCTO(($C$1:$C$38=0)*1));$C$1:$C$38;0)))}

se podría usar

=SI(ESERROR(INDIRECTO("B"&COINCIDIR(FILA();$C$1:$C$38;0)));"";INDIRECTO("B"&COINCIDIR(FILA();$C$1:$C$38;0)))

con la salvedad de que si hay palabras repetidas se produce un hueco en blanco (quizás le pueda ser útil a alguien).

Un saludo desde Vitoria

ioyama
Moderador
Moderador

Masculino Cantidad de envíos : 128
Edad : 53
Ciudad - Pais : Vitoria (España)
Fecha de inscripción : 03/03/2008

Volver arriba Ir abajo

Re: Diccionario Matricial

Mensaje por GalileoGali el Miér Abr 02, 2008 10:40 pm

Muy buena construccion!!
Me peermiti usarla para agregar una muestra en el thread....

Hoja1

 ABC
1retama534567
2coliarí2coliarí
3 0cráter
4trépano6escomaro
5escomaro4retama
6 0trépano
7cráter3 
8345671 
Spreadsheet Formulas
CellFormula
B1=SUMAPRODUCTO((A1>=$A$1:$A$38)*($A$1:$A$38<>"")*1)
C1=SI(ESERROR(INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)));"";INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)))
B2=SUMAPRODUCTO((A2>=$A$1:$A$38)*($A$1:$A$38<>"")*1)
C2=SI(ESERROR(INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)));"";INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)))
B3=SUMAPRODUCTO((A3>=$A$1:$A$38)*($A$1:$A$38<>"")*1)
C3=SI(ESERROR(INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)));"";INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)))
B4=SUMAPRODUCTO((A4>=$A$1:$A$38)*($A$1:$A$38<>"")*1)
C4=SI(ESERROR(INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)));"";INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)))
B5=SUMAPRODUCTO((A5>=$A$1:$A$38)*($A$1:$A$38<>"")*1)
C5=SI(ESERROR(INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)));"";INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)))
B6=SUMAPRODUCTO((A6>=$A$1:$A$38)*($A$1:$A$38<>"")*1)
C6=SI(ESERROR(INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)));"";INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)))
B7=SUMAPRODUCTO((A7>=$A$1:$A$38)*($A$1:$A$38<>"")*1)
C7=SI(ESERROR(INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)));"";INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)))
B8=SUMAPRODUCTO((A8>=$A$1:$A$38)*($A$1:$A$38<>"")*1)
C8=SI(ESERROR(INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)));"";INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0)))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

De paso por qué no ir empezando a usar la "Novedosa" ("Excel 2007.....) función SI.ERROR....
=SI.ERROR(INDIRECTO("a"&COINCIDIR(FILA();$B$1:$B$38;0));"")

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: Diccionario Matricial

Mensaje por Contenido patrocinado Hoy a las 12:37 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.