............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

MODAS TEXTO Y NUMEROS CON CRITERIOS INCLUSIVOS

Ver el tema anterior Ver el tema siguiente Ir abajo

MODAS TEXTO Y NUMEROS CON CRITERIOS INCLUSIVOS

Mensaje por GalileoGali el Miér Feb 24, 2010 11:41 pm

CUAL es el Modelo de la SubMarca Mas vendida?


Hoja1

 ABC
1MARCA SUB MARCA MODELO
2NISSAN PLATINA 1995
3NISSAN APRIO 2010
4CHEVROLET CHEVY 1980
5V.W. SEDAN 2000
6V.W. POINTER 2010
7CHRYSLER SHADOW 1985
8CHRYSLER CARAVAN 1996
9NISSAN TSURU 1996
10NISSAN TSURU 1990
11NISSAN APRIO 1980
12NISSAN APRIO 2005
13NISSAN APRIO 2001
14NISSAN APRIO 2001
15CHRYSLER VOYAGER 2001
16   
17   
18NISSAN APRIO 2001
19   
20  2001
Spreadsheet Formulas
CellFormula
A18{=INDICE(A2:A15;MODA(COINCIDIR(A2:A15;A2:A15;0)))}
B18{=INDICE(SI(A2:A15=A18;B2:B15);MODA(COINCIDIR(SI(A2:A15=A18;B2:B15;FILA(B2:B15));SI(A2:A15=A18;B2:B15;FILA(B2:B15));)))}
C18{=INDICE(SI(B2:B15=B18;C2:C15);MODA(COINCIDIR(SI(B2:B15=B18;C2:C15;FILA(C2:C15));SI(B2:B15=B18;C2:C15;FILA(C2:C15));)))}
C20{=MODA(SI((A2:A15=A18)*(B2:B15=B18);C2:C15;FILA(C2:C15)))}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: MODAS TEXTO Y NUMEROS CON CRITERIOS INCLUSIVOS

Mensaje por GalileoGali el Miér Feb 24, 2010 11:43 pm

No obstante VISTO que las SUBMARCAS los son RESPECTO de una DETERMINADA marca y SOLO de ellas, EL PLANTEO ANTERIOR PODRIA REDUCRISE A APLICAR LA pRIMERA fORMULA SOLAMENTE EN LA SEGUNDA COLUMNA "SUB MARCA" y luego la TERCERA FORMULA en su version RESUMIDA
C20

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: MODAS TEXTO Y NUMEROS CON CRITERIOS INCLUSIVOS

Mensaje por GalileoGali el Jue Feb 25, 2010 12:02 am

Mas sintetica, y basado en que la misma SUBMARCA no puede corresponder a mas de una marca

Hoja2

 ABC
1MARCA SUB MARCA MODELO
2NISSAN PLATINA 1995
3NISSAN APRIO 2010
4CHEVROLET CHEVY 1980
5V.W. SEDAN 2000
6V.W. POINTER 2010
7CHRYSLER SHADOW 1985
8CHRYSLER CARAVAN 1996
9NISSAN TSURU 1996
10NISSAN TSURU 1990
11NISSAN APRIO 1980
12NISSAN APRIO 2005
13NISSAN APRIO 2001
14NISSAN APRIO 2001
15CHRYSLER VOYAGER 2001
16   
17   
18NISSAN APRIO 2001
Spreadsheet Formulas
CellFormula
A18=INDICE(A2:A15;COINCIDIR(B18;B2:B15;))
B18{=INDICE(B2:B15;MODA(COINCIDIR(B2:B15;B2:B15;0)))}
C18{=MODA(SI(B2:B15=B18;C2:C15;FILA(C2:C15)))}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: MODAS TEXTO Y NUMEROS CON CRITERIOS INCLUSIVOS

Mensaje por GalileoGali el Jue Feb 25, 2010 12:05 am

La ultima formula puede no llevar FILA(C2:c15) Y QUEDAR ASÍ

=MODA(SI(B2:B15=B18;C2:C15))
CTRL+MAYUSC +ENTER

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: MODAS TEXTO Y NUMEROS CON CRITERIOS INCLUSIVOS

Mensaje por Gerson Pineda-El Catracho el Jue Feb 25, 2010 4:33 pm

Gracias Gali


Saludos desde Honduras

Gerson Pineda-El Catracho

Masculino Cantidad de envíos : 107
Edad : 38
Ciudad - Pais : SPS - Honduras
Version de Excel : 2003/2007/2010/2013
Fecha de inscripción : 02/04/2008

http://gerson-pineda-el-catracho.blogspot.com/

Volver arriba Ir abajo

Re: MODAS TEXTO Y NUMEROS CON CRITERIOS INCLUSIVOS

Mensaje por ALREY2010 el Sáb Feb 27, 2010 11:42 am

Hola, que tal?

Bueno pues dejenme decirles que me funcionó de maravilla esa formula, ya la aplique a mi base de datos y esta excelente. (Algun día sere como ustedes jajajaja)

Pues no me queda de otra mas que continuar trabajando y espero volver a contactarlos muy pronto aunque sea para saludarlos.

mi correo electrónico es [Tienes que estar registrado y conectado para ver este vínculo]

Bye.

Saludos desde mi México querido

ALREY2010

Masculino Cantidad de envíos : 2
Edad : 39
Ciudad - Pais : México
Version de Excel : 2007
Fecha de inscripción : 27/02/2010

Volver arriba Ir abajo

Re: MODAS TEXTO Y NUMEROS CON CRITERIOS INCLUSIVOS

Mensaje por ALREY2010 el Sáb Feb 27, 2010 1:04 pm

Otra vez yo.

Definitivamente ya se resolvio mi problema inicial, pero creo que estoy pidiendo mucho verdad?, lo que pasa es que ahora mi último problema ( y con eso se acaban se los prometo) es que como mi base de datos tiene muchos campos con el valor "0", ya que hay algunos campos que no tienen todos los datos asi que los rellené con el valor "0", solo que cuando encuentra este valor pues es el que me despliega.

Hay alguna forma para que los datos que encuentre con el valor de "0" los omita?

Gracias.

ALREY2010

Masculino Cantidad de envíos : 2
Edad : 39
Ciudad - Pais : México
Version de Excel : 2007
Fecha de inscripción : 27/02/2010

Volver arriba Ir abajo

Re: MODAS TEXTO Y NUMEROS CON CRITERIOS INCLUSIVOS

Mensaje por GalileoGali el Sáb Feb 27, 2010 5:34 pm

Paso a Bloquear este post, no estamos para juegos infructíferos, ni rendir pleitecías a tus caprichos,

(Para los lectores no advertidos valga aclarar que el Forista requirente ya produjo marchas y contramrchas, tal como acaba de reconocer, participando en el foro de emagister, dónde ya se le aclaró tanto mi hartazgo como el de otros expertos que le estuvimos respondiendo)

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: MODAS TEXTO Y NUMEROS CON CRITERIOS INCLUSIVOS

Mensaje por Contenido patrocinado Hoy a las 1:32 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.