............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

NECESITO AYUDA CON FUNCION

Ver el tema anterior Ver el tema siguiente Ir abajo

NECESITO AYUDA CON FUNCION

Mensaje por martinachoz el Lun Abr 26, 2010 4:11 pm

Hola Galileo:

Sabes necesito de tu ayuda y sabiduría, estoy haciendo una planilla estadística y necesito que me arroje el siguiente dato, en unas de las columnas tengo las comunas de mi país,desde a1:A20 en este rango se repiten mas de algunas; ¿Como puedo hacer para que me entregue la comuna que mas se repite y la que menos se repite?

martinachoz

Cantidad de envíos : 3
Fecha de inscripción : 28/08/2008

Volver arriba Ir abajo

Re: NECESITO AYUDA CON FUNCION

Mensaje por GalileoGali el Lun Abr 26, 2010 5:53 pm

Seguidamente, en la columna B puse un contador al solo efecto de verficar el ejemplo, pero innecesaro para la solucion, la formula para el menos repetido es un pco más compleja que la delmas repetido, porque hay que contemplar el caso en que haya alguna celda vacia y la descarte del conteo....

Hoja1

 ABCDEF
1A6 AValor más repetido 
2G4    
3B6 HValor menos repetido 
4H3    
5G4    
6A6    
7B6    
8B6    
9H3    
10G4    
11 0    
12A6    
13B6    
14B6    
15H3    
16G4    
17A6    
18A6    
19A6    
20B6    
Spreadsheet Formulas
CellFormula
B1=CONTAR.SI($A$1:$A$20;A1)
D1{=INDICE(A1:A20;COINCIDIR(VERDADERO;CONTAR.SI(A1:A20;A1:A20)=MAX(CONTAR.SI(A1:A20;A1:A20));0))}
B2=CONTAR.SI($A$1:$A$20;A2)
B3=CONTAR.SI($A$1:$A$20;A3)
D3{=INDICE(A1:A20;COINCIDIR(VERDADERO;CONTAR.SI(A1:A20;A1:A20)=MIN(CONTAR.SI(A1:A20;A1:A20)+(A1:A20="")*FILAS(A1:A20));0))}
B4=CONTAR.SI($A$1:$A$20;A4)
B5=CONTAR.SI($A$1:$A$20;A5)
B6=CONTAR.SI($A$1:$A$20;A6)
B7=CONTAR.SI($A$1:$A$20;A7)
B8=CONTAR.SI($A$1:$A$20;A8)
B9=CONTAR.SI($A$1:$A$20;A9)
B10=CONTAR.SI($A$1:$A$20;A10)
B11=CONTAR.SI($A$1:$A$20;A11)
B12=CONTAR.SI($A$1:$A$20;A12)
B13=CONTAR.SI($A$1:$A$20;A13)
B14=CONTAR.SI($A$1:$A$20;A14)
B15=CONTAR.SI($A$1:$A$20;A15)
B16=CONTAR.SI($A$1:$A$20;A16)
B17=CONTAR.SI($A$1:$A$20;A17)
B18=CONTAR.SI($A$1:$A$20;A18)
B19=CONTAR.SI($A$1:$A$20;A19)
B20=CONTAR.SI($A$1:$A$20;A20)
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: NECESITO AYUDA CON FUNCION

Mensaje por sailepaty el Mar Abr 27, 2010 11:07 am

Hola Gali, me parece que tambien hay que contemplar las celdas en blanco en la formula de la que mas se repite.

=INDICE(A1:A20;COINCIDIR(VERDADERO;CONTAR.SI(A1:A20;A1:A20)=MAX(CONTAR.SI(A1:A20;A1:A20)-(A1:A20="")*FILAS(A1:A20));0))

Saludos

_________________
I didn't ask to be Mexican I just got lucky!!!

sailepaty
Moderador
Moderador

Masculino Cantidad de envíos : 135
Edad : 53
Ciudad - Pais : Dallas, TX
Version de Excel : 2007 y 2010
Fecha de inscripción : 04/03/2008

Volver arriba Ir abajo

Re: NECESITO AYUDA CON FUNCION

Mensaje por martinachoz el Mar Abr 27, 2010 11:55 am

Muchas gracias Galileo, me ha servido muchísimo tu ayuda y sabiduría,sobre todo para personas como yo que trabajamos enseñando la herramienta de excel...

martinachoz

Cantidad de envíos : 3
Fecha de inscripción : 28/08/2008

Volver arriba Ir abajo

Re: NECESITO AYUDA CON FUNCION

Mensaje por GalileoGali el Mar Abr 27, 2010 6:53 pm

Te agradezco mucho tus palabras, pero mira aqui todos aportamos, por ejemplo si sailepaty no se hubiera percatado y no hubiera corregido mi error, habrias tenido una fórmula con un error.....

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: NECESITO AYUDA CON FUNCION

Mensaje por martinachoz el Mar Abr 27, 2010 10:14 pm

Entonces Gracias a todos¡¡¡¡¡¡

martinachoz

Cantidad de envíos : 3
Fecha de inscripción : 28/08/2008

Volver arriba Ir abajo

Re: NECESITO AYUDA CON FUNCION

Mensaje por Contenido patrocinado Hoy a las 3:13 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.