............ Foro Excel
Si no lo has hecho aún: REGISTRATE!!!

SUMAR A PARTIR DE CADENA DE NUMEROS SEPARADOS POR COMAS

Ver el tema anterior Ver el tema siguiente Ir abajo

SUMAR A PARTIR DE CADENA DE NUMEROS SEPARADOS POR COMAS

Mensaje por GalileoGali el Sáb Mayo 01, 2010 7:39 pm

supongamos en A2 tengo:
1,22,25,3

En el adjunto, muestro una manera matricial de resolverlo



Hoja1

 A
1Texto
21,22,25,3

Hoja1

 E
1Fórmula
251
Spreadsheet Formulas
CellFormula
E2{=SUMAPRODUCTO(EXTRAE(A2;K.ESIMO.MENOR(SI(EXTRAE(","&A2;FILA(INDIRECTO("$1:"&LARGO(A2)));1)=",";FILA(INDIRECTO("$1:"&LARGO(A2))));FILA(INDIRECTO("$1:"&LARGO(A2)-LARGO(SUSTITUIR(A2;",";""))+1)));K.ESIMO.MENOR(SI(EXTRAE(A2&",";FILA(INDIRECTO("$1:"&LARGO(A2)+1));1)=",";FILA(INDIRECTO("$1:"&LARGO(A2)+1)));FILA(INDIRECTO("$1:"&LARGO(A2)-LARGO(SUSTITUIR(A2;",";""))+1)))-K.ESIMO.MENOR(SI(EXTRAE(","&A2;FILA(INDIRECTO("$1:"&LARGO(A2)));1)=",";FILA(INDIRECTO("$1:"&LARGO(A2))));FILA(INDIRECTO("$1:"&LARGO(A2)-LARGO(SUSTITUIR(A2;",";""))+1))))+0)}
Formula Array:
Produce enclosing
{ } by entering
formula with CTRL+SHIFT+ENTER!


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: SUMAR A PARTIR DE CADENA DE NUMEROS SEPARADOS POR COMAS

Mensaje por KL el Miér Jun 23, 2010 3:08 pm

Un pelín más corto:
Sheet1

 AB
11,22,25,351
Spreadsheet Formulas
CellFormula
B1=SUMAPRODUCTO(--ESPACIOS(EXTRAE(SUSTITUIR(A1;",";REPETIR(" ";LARGO(A1)));LARGO(A1)*(FILA(INDICE(A:A;1):INDICE(A:A;1+LARGO(A1)-LARGO(SUSTITUIR(A1;",";""))))-1)+1;LARGO(A1))))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


KL
MS MVP
MS MVP

Cantidad de envíos : 3
Fecha de inscripción : 23/04/2010

Volver arriba Ir abajo

Re: SUMAR A PARTIR DE CADENA DE NUMEROS SEPARADOS POR COMAS

Mensaje por Alejandro62 el Miér Jun 23, 2010 7:43 pm

Hola otra opción, saludos.


Alejandro62

Masculino Cantidad de envíos : 37
Edad : 54
Ciudad - Pais : Mexico, Estado de Mexico
Version de Excel : Excel 2010
Fecha de inscripción : 21/11/2009

Volver arriba Ir abajo

Re: SUMAR A PARTIR DE CADENA DE NUMEROS SEPARADOS POR COMAS

Mensaje por GalileoGali el Miér Jun 23, 2010 7:55 pm

Espectacular KL.
Tratare este fin de semana, con más tiempo, brindar una explicacion de esta matricial (aunque con SUMAPRODUCTO)...
Mientrasa tanto otra que acude al uso de la XlmFunction EVALUAR (EVALUATE)

Hoja1

 ABCDE
11,22,23,6,1365  1
2    22
3    23
4    6
5    13
6    65
Spreadsheet Formulas
CellFormula
B1=SumarCadena
E6=SUMA(E1:E5)
Names in Formulas
CellNameApplies to
B1SumarCadena=EVALUAR(SUSTITUIR(Hoja1!$A1;",";"+"))


Excel tables to the web >> [Tienes que estar registrado y conectado para ver este vínculo]


_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: SUMAR A PARTIR DE CADENA DE NUMEROS SEPARADOS POR COMAS

Mensaje por GalileoGali el Miér Jun 23, 2010 7:57 pm

Bueno,,,
Alejandro 62, parece que me ganaste de mano con la misma táctica

_________________
GalileoGali
M.A.P. 2010-2013
Microsoft Active Professional

GalileoGali
Admin

Masculino Cantidad de envíos : 1962
Edad : 61
Ciudad - Pais : QUIROGA, Argentina
Version de Excel : 2000-2003-2007-2010
Fecha de inscripción : 24/01/2008

http://excelgali.mejorforo.net

Volver arriba Ir abajo

Re: SUMAR A PARTIR DE CADENA DE NUMEROS SEPARADOS POR COMAS

Mensaje por Alejandro62 el Miér Jun 23, 2010 8:13 pm

Asi es Galileo, por segundos la mande antes, jejejeje

Alejandro62

Masculino Cantidad de envíos : 37
Edad : 54
Ciudad - Pais : Mexico, Estado de Mexico
Version de Excel : Excel 2010
Fecha de inscripción : 21/11/2009

Volver arriba Ir abajo

Re: SUMAR A PARTIR DE CADENA DE NUMEROS SEPARADOS POR COMAS

Mensaje por Contenido patrocinado Hoy a las 12:38 pm


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.